RunRyder RC
WATCH
 1 page 32 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterFlybarless Rotor Head SystemsBrain iKon › 4649T not communicating with Ikon2
04-15-2021 11:27 AM  22 days ago
Topic Vote0Post 1
basmntdweller

rrKey Veteran

Indianapolis IN

MyPosts All Forum Topic
4649T not communicating with Ikon2
I got a new 550X a few weeks ago. I got it all together and setup. I took it out Tuesday afternoon for its maiden flights. It is flying fantastic but I wasn’t getting any telemetry. I tried a bunch different things but still wasn’t getting anywhere. I finally figured out that while the 4659T was showing bound, it wasn’t actually working. I had two satellites plugged in to the side of my Ikon. When I unplugged them I no longer had any control of the heli even though the 4659T was showing bound. I swapped to another 4659T from one of my other helis but got exactly the same results. No communication between the Ikon and rx. During all my troubleshooting I also noticed if I connected the Ikon to my pc and then plugged in a battery, it put the rx into bind mode. However if I plugged in the battery first, the receiver either came on bound if I had previously bound it or it would stay dark if it wasn’t already bound.
I think something may be messed up in my Ikon2. It seems the channel 3 port where I plug in the rx isn’t working properly.
Any ideas short of buying another Ikon?

Thanks, Matt

Stupid people have no idea how stupid they are!!!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-15-2021 02:32 PM  21 days ago
co_rotorhead

rrVeteran

Centennial, CO, USA

MyPosts All Forum Topic
Is this the receiver you are using?

https://www.spektrumrc.com/Products...ProdId=SPM4649T

If so, it looks like its designed for racing quads, not helicopters.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-15-2021 03:03 PM  21 days ago
basmntdweller

rrKey Veteran

Indianapolis IN

MyPosts All Forum Topic
That’s it but it’s just a serial bus receiver with telemetry capability. I have them on 5 of my helis. It’s the rx that Ikon recommended when they first started pushing their telemetry features.

Matt

Stupid people have no idea how stupid they are!!!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-15-2021 07:13 PM  21 days ago
Rojoalfa

rrKey Veteran

Punta de Mata, Monagas-Venezuela

MyPosts All Forum Topic
/
/

That is correct.

You need To figure it out how SBUS is mapping the different channels.

In some cases, it is not as simple as "plug and play"...

/
Saludos cordiales,
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-16-2021 01:08 AM  21 days ago
basmntdweller

rrKey Veteran

Indianapolis IN

MyPosts All Forum Topic
I figured it out. I was having a dumbass attack! I know the rx plugs into channel 3 on the Ikon. I’ve looked at it several times, plugs in right next to the wire in channel 5 from the ESC. The problem is that with the way the Ikon is mounted, I wasn’t seeing the Ikon header clearly. I had apparently plugged the wire from the esc into the channel 3 slot and was plugging the rx into channel 2 slot. No wonder it wasn’t working!
Plugged in everything to their correct ports and everything works perfectly!
Sometimes my sig line applies to me!

Stupid people have no idea how stupid they are!!!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 32 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterFlybarless Rotor Head SystemsBrain iKon › 4649T not communicating with Ikon2
Print TOPIC

 2  Topic Subscribe

Friday, May 7 - 12:46 pm - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online