RunRyder RC
WATCH
 1 page 104 views POST REPLY
07-13-2020 06:33 PM  23 days ago
Topic Vote0Post 1
Blue Angel

rrApprentice

Redford, Mi - USA

MyPosts All Forum Topic
KST HV TR servo
Is there anyone going to IRCHA that uses KST servos in their helicopter. I have a brand new TR servo that needs to be checked out prior to installation. I have not been able to get it working at all. I check all my new servos before installation. Can anyone out there help? Thanks!

Blue Angel
SHARE  PM  EMAIL  Attn:RR  Quote
07-16-2020 08:33 AM  21 days ago
wjvail

rrElite Veteran

Meridian, Mississippi

MyPosts All Forum Topic
💎Sustaining Member
Can you describe how you are "checking" it?

Tail rotor servos typically cannot be simply plugged into a receiver and tested. They must be plugged into a properly setup gyro or they appear to be dead.
"Well, nothing bad can happen now."
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-28-2020 04:44 PM  8 days ago
Blue Angel

rrApprentice

Redford, Mi - USA

MyPosts All Forum Topic
I've done what you are saying using another helicopter with a Futaba 520 gyro. I disconnected my Futaba 9254 servo and added the KST. Still no response. However, my battery was 4.8V. Don't think this should matter, as the servo is designed for either voltage. Thanks for your input.

Blue Angel
SHARE  PM  EMAIL  Attn:RR  Quote
07-28-2020 08:51 PM  8 days ago
wjvail

rrElite Veteran

Meridian, Mississippi

MyPosts All Forum Topic
💎Sustaining Member
Hmm... The mystery continues. Exactly which KST servo do you have?"Well, nothing bad can happen now."
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-29-2020 01:30 AM  8 days ago
wjvail

rrElite Veteran

Meridian, Mississippi

MyPosts All Forum Topic
💎Sustaining Member
I believe the 9254 is wide pulse width servo (Pulse width of 1,520μS) and that is likely how your 520 gyro is set up - so, as expected, they work fine together. Plugging in a narrow pulse servo into the same gyro will give the appearance the servo is dead. It will not respond. Similarly, if you plug a modern T/R servo (narrow pulse) directly into your receiver the servo won't respond. At the risk of repeating myself,
wjvail ...They [tail rotor servos] must be plugged into a properly setup gyro or they appear to be dead.
Most likely your KST is a dedicated tail servo and you will have to program the gyro for a narrow pulse servo (typically 760μS).

Below is a link to your 520's manual. On page #18 there is a section titled "Servo selection". For a modern T/R servo you will have to select the digital mode. I'm not certain how you are programming your gyro so I can't help you with exactly how to accomplish this.

There is also the possibility I'm completely wrong about why your servo is unresponsive and there is something else going on.

https://futabausa.com/wp-content/up...18/09/GY520.pdf
"Well, nothing bad can happen now."
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-29-2020 02:57 AM  8 days ago
Rojoalfa

rrKey Veteran

Punta de Mata, Monagas-Venezuela

MyPosts All Forum Topic
/
/

At this time, that servo is probably dead.

Connecting a 760us servo on a 1520us gyro setting is a big mistake. Your servo become useless.

It is a common problem.

The gyro instruction manual always make a warning when installing the tail servo.
You must select the correct frame before connecting the tail servo..!

/
Saludos cordiales,
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-29-2020 07:50 PM  7 days ago
SoCal Scott

rrNovice

Kailua, Hawaii

MyPosts All Forum Topic
💎Sustaining Member
Running a 760us servo on 1520us will not kill it. Some servos won’t recognize this as a valid pulse-width and will simply turn off and appear dead(until the appropriate pulse is selected). Other servos may “work” but their center-position will be... well far from center.

You either need a tester that can do 760us or plug it into a gyro that is correctly configured for 760us.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-29-2020 08:30 PM  7 days ago
JLF92677

rrApprentice

Southern California

MyPosts All Forum Topic
SoCal Scott Running a 760us servo on 1520us will not kill it. Some servos won’t recognize this as a valid pulse-width and will simply turn off and appear dead(until the appropriate pulse is selected). Other servos may “work” but their center-position will be... well far from center.

You either need a tester that can do 760us or plug it into a gyro that is correctly configured for 760us.
Scott is correct. Running a 760us servo on 1520us or vice versa will not kill the servo.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-29-2020 11:11 PM  7 days ago
wjvail

rrElite Veteran

Meridian, Mississippi

MyPosts All Forum Topic
💎Sustaining Member
Rojoalfa /
/

At this time, that servo is probably dead.

Connecting a 760us servo on a 1520us gyro setting is a big mistake. Your servo become useless.

It is a common problem.

The gyro instruction manual always make a warning when installing the tail servo.
You must select the correct frame before connecting the tail servo..!

/
Rojoalfa... I've been trying to find the right time and place to ask this - but why the slashes before and after your comments? Is it cultural? Does it mean something in Venezuela?

I know I'm hijacking this thread but I gotta ask.
"Well, nothing bad can happen now."
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-30-2020 12:09 PM  7 days ago
Rojoalfa

rrKey Veteran

Punta de Mata, Monagas-Venezuela

MyPosts All Forum Topic
/
/

That little slashes at the beginning and at the end...
Thank you for asking!

It give me some "space", so my writing is clear to read. I also help "my bad English" with this approach.

BTW, you are correct.
I got confused with 760us servo on a 1520us device...

/
Saludos cordiales,
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 104 views POST REPLY
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Thursday, August 6 - 2:54 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online