RunRyder RC
WATCH
 1 page 109 views POST REPLY
HomeTurbine✈️Aircraft🚁HelicopterTurbine Helicopters › Wren 44 no start
06-19-2020 11:27 PM  13 days ago
Topic Vote0Post 1
Jim Cimino

rrKey Veteran

NE Pennsylvania

MyPosts All Forum Topic
Wren 44 no start
I have a wren 44H engine that I’ve had a few years and it has run great. I went to start it today for the first time this year and it will not run. It seems like it is not pumping fuel. If I prime the engine using the pump it starts to spool up but then never gets going. I don’t have air in the fuel lines. But it seems like the pump won’t run unless it is powered through the prime function.
Team Synergy, Team Scorpion, No good deed goes unpunished
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-20-2020 04:15 AM  13 days ago
Rojoalfa

rrKey Veteran

Punta de Mata, Monagas-Venezuela

MyPosts All Forum Topic
/
/

A turbine!
Good stuff!

Pump? you already check

Igniter valve?
Fuel valve?

/
Saludos cordiales,
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-20-2020 12:41 PM  13 days ago
Jim Cimino

rrKey Veteran

NE Pennsylvania

MyPosts All Forum Topic
As I mentioned, I can prime it with the pump using the hand held control and it runs on that fuel but does not keep getting fuel on its own.Team Synergy, Team Scorpion, No good deed goes unpunished
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-20-2020 05:15 PM  13 days ago
dgoss999

rrApprentice

UK - Lancashire

MyPosts All Forum Topic
Is it a kero or gas start engine?"Believe none of what you hear, and only half of what you see." • Benjamin Franklin
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-20-2020 10:14 PM  12 days ago
MattJen

rrElite Veteran

UK

MyPosts All Forum Topic
Bad fuel valve?
Bad fadec battery ?
Do a video of the start sequence with GSU attached so we can see the sequence..by what your saying you are probably getting the ign time out fault..

If it's a kero start then valve or battery maybe faulty as they taken an awful lot of power on startup..

Matt
All The Best
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-27-2020 03:58 PM  6 days ago
Jim Cimino

rrKey Veteran

NE Pennsylvania

MyPosts All Forum Topic
I put a new ECU battery in and that fixed the problem. The battery that I was using tested fine and was perfectly balanced and when I load tested it, it checked good. It was a few years old, but apparently not enough for the turbine.Team Synergy, Team Scorpion, No good deed goes unpunished
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 109 views POST REPLY
HomeTurbine✈️Aircraft🚁HelicopterTurbine Helicopters › Wren 44 no start
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Friday, July 3 - 6:08 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online