RunRyder RC
WATCH
 1 page 105 views POST REPLY
HomeAircraftHelicopterHelicopter Main Discussion › AR7200BX with Tail Servo KST BLS805X
09-15-2018 10:41 PM  5 days agoPost 1
flustercluck

rrVeteran

Newnan Ga (Just S. of ATL)

My Posts: All  Forum  Topic

Hey guys, anybody using this tail servo with the BeastX? (My heli is 700E DFC)?

I'm needing some setup help- thanks!

Jeff in ATL

PM  EMAIL  GALLERY  Attn:RR  Quote
09-15-2018 10:45 PM  5 days agoPost 2
flustercluck

rrVeteran

Newnan Ga (Just S. of ATL)

My Posts: All  Forum  Topic

oh- and I'm running the servo at 8.4V, straight off a 2S rx pack

PM  EMAIL  GALLERY  Attn:RR  Quote
09-15-2018 11:19 PM  5 days agoPost 3
Heli_Splatter

rrElite Veteran

USA

My Posts: All  Forum  Topic

What is happening? I am running HV servos on my 800. Setup is pretty straight forward. What is going on.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2018 12:09 AM  5 days agoPost 4
flustercluck

rrVeteran

Newnan Ga (Just S. of ATL)

My Posts: All  Forum  Topic

more like what's NOT going on

I'm very experienced heli, very experienced beastx, The KST specs say: Operating signal: 760us / 560Hz

This is how it's set up: setup "C", red solid (760us), Setup "D" blue solid (560hz). Both setup steps "E" (endpoints) and "F" (sensor direction) are correct.

When I spooled up today, tail was holding fine, rudder was correct, but just as I got lite on the skids (and before the hover) the servo in a split second went full right rudder, locked itself, shattering both tailblades, and the 700 did a ground piro

When I went back to the pits, the servo was so hot I could barely touch it

What do you think is happening here??

thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2018 01:10 AM  5 days agoPost 5
Heli_Splatter

rrElite Veteran

USA

My Posts: All  Forum  Topic

I am thinking servo burned up. Can you smell anything? Does the servo operate now? I checked and agree with settings. Sounds like you know what you are doing. What you describe sure sounds like a reversed tail gyro, but that is too simple.

I would take servo apart. That might give some info. Maybe the main gear is stripped. Check smell too.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2018 12:55 PM  5 days agoPost 6
flustercluck

rrVeteran

Newnan Ga (Just S. of ATL)

My Posts: All  Forum  Topic

no smell, seems to work (ie, responds normally to inputs)....but what in the WORLD would burn up a new servo???

think my AR7200BX rudder channel is bad somehow?

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2018 10:15 PM  4 days agoPost 7
Heli_Splatter

rrElite Veteran

USA

My Posts: All  Forum  Topic

I think that I would do a reset and reenter everything again. Still a problem? Send it off to have checked out. I do think this receiver is a bit small for such a large heli.

Oops, just checked recommended up to 800 and 2s voltage.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-18-2018 02:20 PM  3 days agoPost 8
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

Double check the gyro isn't reversed or the tail grips aren't the wrong way round. Although you said it went full right rudder? I think it would usually tend to go full left rudder (nose left) if the gyro direction was reversed.

If everything checks out ok and all going the right direction I would seriously consider reducing either the frequency (down to 270 or 333hz) or the input voltage. I know it says it's rated at that but you don't have to run it at that and since you said the servo was hot, this is what I would do. Also check the tail pitch mechanics are free and smooth and check your servo arm isn't too long, the servo should turn through at least 90 degrees from left to right tail limit. Also check your gain isn't too high, a good starting point is to rotate the heli by hand once it's initialized, the pitch slider should just reach it's limit when the heli reaches 45 degrees.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-18-2018 08:18 PM  2 days agoPost 9
barely can fly

rrApprentice

oxford ga. usa

My Posts: All  Forum  Topic

I did this once, set a servo to 760/560hz because that is what the box said, did the exact same thing, flew good for a couple of flights then suddenly went full lock to one side and wouldn't go back to neutral.
Even sent servo in for warranty check and was told found nothing wrong.
set to 333hz and should work right again.

ATLRC wrecking crew / NCRC

PM  EMAIL  Attn:RR  Quote
09-19-2018 11:08 AM  2 days agoPost 10
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

560Hz makes the servo work really hard especially coupled with higher voltage and higher gain (you can crank the gain up too high without realizing it with a 760us servo at 560Hz). I have run a servo at this in the past but it was a high end Futaba HV servo running on 6.6v.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 105 views POST REPLY
HomeAircraftHelicopterHelicopter Main Discussion › AR7200BX with Tail Servo KST BLS805X
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Friday, September 21 - 4:27 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online