RunRyder RC
WATCH
 1 page 100 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 230S › Blade 230S won't bind
04-29-2018 02:10 PM  3 months agoPost 1
Ausable

rrVeteran

Montreal, Quebec

My Posts: All  Forum  Topic

I am trying to bind my heli to my Spectrum DX6
The light on the Heli is solid red, it does't flash.
When I try to bind I hear two beeps then the light stays Red
Can someone tell what i am doing wrong
Thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2018 10:43 PM  3 months agoPost 2
pH7

rrKey Veteran

Sterling Heights, MI - USA

My Posts: All  Forum  Topic

This is the procedure from the manual. I have emphasized the part that you may be doing wrong if the receiver does not flash. Following the whole thing should get the job done.
  1. Disconnect the flight battery from the helicopter.
  2. Refer the Transmitter Setup Table to correctly setup your transmitter.
  3. Lower the throttle stick to the lowest position. Set all trims to the center position.
  4. Power off the transmitter and move all switches to the 0 position. Move the throttle to the low/off position.
  5. Install the bind plug in the receiver BIND/PROG port (far left side of the receiver).
  6. Connect the flight battery to the ESC. The receiver LED flashes, indicating it is in bind mode.
  7. Put the transmitter into bind mode while powering on the transmitter.
  8. Release the bind button/switch after 2–3 seconds. The helicopter is bound when the LED on the receiver turns solid.
  9. Disconnect the flight battery and power the transmitter off.

Phil Heavin

PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2018 10:55 PM  3 months agoPost 3
Ausable

rrVeteran

Montreal, Quebec

My Posts: All  Forum  Topic

Ok thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 100 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 230S › Blade 230S won't bind
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, August 17 - 10:26 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online