RunRyder RC
WATCH
 1 page 492 views POST REPLY
HomeOff Topics › Icharger screwup.
07-30-2017 03:35 AM  14 months agoPost 1
Raptor Freak

rrApprentice

Auburn, Wa

My Posts: All  Forum  Topic

I made a mistake and plugged in two 6S lipos in series to channel 1 of my icharger 308duo for a total of 50volts, and now it isnt reading any voltage to the output port and the balance port isnt reading correctly. On top of that it wont even charge. But channel 2 is still fine didnt screw that one up. is there a fix to repair this mistake i made?

PM  EMAIL  GALLERY  Attn:RR  Quote
08-01-2017 05:16 AM  14 months agoPost 2
artimus

rrKey Veteran

Buckley WA

My Posts: All  Forum  Topic

Hey Dave here a link to an nother post about the same kinda thing.....
https://rc.runryder.com/t820115p1/

Fly Hard......Team Viagra

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 492 views POST REPLY
HomeOff Topics › Icharger screwup.
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Friday, October 19 - 12:00 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online