RunRyder RC
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 2569 views POST REPLY
HomeRC & Power✈️Aircraft🚁Helicoptere-Kontronik Electric Components › ProgUnit not progressing
11-03-2016 11:38 PM  3 years ago
Topic Vote0Post 1
Tyler

rrElite Veteran

Chicagoland area

MyPosts All Forum Topic
ProgUnit not progressing
I have a new Kontronik Jive Pro 120hv+ and a new ProgUnit.

I started the esc update procedure and it seems to have stopped about 33% into the process. I have read that we should not interrupt the update no matter what.

After 20 minutes of staring at the screen I am getting concerned.

Please advise on what I should do to prevent bricking my new esc.

Thanks
Tyler
Enjoy things that money can buy IF you don't lose the things money can't buy.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-03-2016 11:41 PM  3 years ago
Dr.Ben

rrMaster

Richmond, VA, USA

MyPosts All Forum Topic
Leave it be for a lot longer. If you pull the cord as it sits there is high likelihood of bricking it.

Ben
Peak Aircraft/Team Minicopter Team Futaba Team Kontronik USA
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-03-2016 11:43 PM  3 years ago
Tyler

rrElite Veteran

Chicagoland area

MyPosts All Forum Topic
Worried, it has done nothing for 30 minutes.

I will attempt to exercise patience a while longer. Now, what can I do to distract me for the next 15 minutes????
Enjoy things that money can buy IF you don't lose the things money can't buy.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-04-2016 12:32 AM  3 years ago
Tyler

rrElite Veteran

Chicagoland area

MyPosts All Forum Topic
Update was successful. Thanks for encouraging me to be patient, Dr. Ben. I was able to install a new fpv camera on my racing quad in the mean time. The update took almost an hour.

Tyler
Enjoy things that money can buy IF you don't lose the things money can't buy.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-05-2016 01:51 PM  3 years ago
Ace Dude

rrProfessor

USA

MyPosts All Forum Topic
Glad to hear that worked.

One thing I always do as a precautionary measure when doing firmware updates on any device is to shutdown every application I can before doing the update. On many devices the timing can be critical. Even temporarily disabling an Internet connection isn't a bad idea as it's always possible for an automatic software update to take place right in the middle of your firmware update.
  
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-03-2017 12:32 PM  3 years ago
Phoenix NOTAR

rrApprentice

Tallahassee, Florida USA

MyPosts All Forum Topic
Should a Kosmik 160 be able to be programmed with a Prog Unit when the Kosmik is"only" powered up using a 6S battery? Mine did not. No LED's lit up. The Kosmic was not plugged into a motor at this time.

I had the Prog Unit plugged into the Master port of the ESC, a 6S battery plugged into the Kosmik, and a usb into the Prog unit and my PC running the K-Konfig V1.21.

The message window stated that it found the Prog unit, but no updatable ESC.

I tried a receiver battery into the other lead of the prog unit, but it made no difference.

Thank you for any help with this,

Sandy
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-03-2017 02:19 PM  3 years ago
Ace Dude

rrProfessor

USA

MyPosts All Forum Topic
I've updated my Kosmik 160 ESCs a number of times using the ProgUNIT.

I have never used an external RX on the other lead of the ProgUNIT. I've always had a motor connected and have used a 12s pack, however, the Kosmik is rated for 5-14s so I don't see why a 6s pack wouldn't work. I'd suggest connecting a motor and see if that works. Although I've never tried it w/o a motor attached, I recall hearing that a Kosmik will not properly initialize w/o a motor attached.
  
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-03-2017 02:39 PM  3 years ago
Phoenix NOTAR

rrApprentice

Tallahassee, Florida USA

MyPosts All Forum Topic
Ace Dude,

I just tried it again with the ESC connected to the Pyro 800 motor. No change, the ESC still has no LED's lit or flashing when connected to the Prod unit and a 6S battery. (the Prog unit led flashes fast, then flashes slower).

Sandy
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-03-2017 02:59 PM  3 years ago
Dr.Ben

rrMaster

Richmond, VA, USA

MyPosts All Forum Topic
Curious.....Will it still boot up and arm as usual?

Ben Minor
Peak Aircraft/Team Minicopter Team Futaba Team Kontronik USA
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-03-2017 03:57 PM  3 years ago
Tyler

rrElite Veteran

Chicagoland area

MyPosts All Forum Topic
I believe it requires more than 18v or perhaps 20v to initialize the origramming mode, according to the progunit manual.

I fiddled for hours trying to find the exact procedure needed to upgrade my esc's. Id have to experiment again to report back on my final steps. The instructions simply didnt work.

Also, my bec voltage keeps returning to 5:6 v after repgrogramming several times. It wont save the bec to 8 v.
Enjoy things that money can buy IF you don't lose the things money can't buy.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-03-2017 05:47 PM  3 years ago
Ace Dude

rrProfessor

USA

MyPosts All Forum Topic
I believe it requires more than 18v or perhaps 20v to initialize the origramming mode, according to the progunit manual.

I fiddled for hours trying to find the exact procedure needed to upgrade my esc's. Id have to experiment again to report back on my final steps. The instructions simply didnt work.

Also, my bec voltage keeps returning to 5:6 v after repgrogramming several times. It wont save the bec to 8 v.
I had the same issue trying to set the BEC output voltage on my Kosmik 160 using the ProgUNIT last year. Turns out that you cannot set the BEC output voltage until you program the stickway. In the end I was trying to program it in the incorrect order using the ProgUNIT. What I was doing wrong was using the ProgUNIT to set the BEC output voltage before programming mode 4. Once did a mode 1 reset, then programmed mode 4, I was able to then set the BEC voltage using the ProgUNIT. Try it again in that order. Also, make sure you're using the latest K-KONFIG software (v1.2.1):

http://www.kontronik.com/en/downloads.html
  
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-04-2017 02:38 AM  3 years ago
Phoenix NOTAR

rrApprentice

Tallahassee, Florida USA

MyPosts All Forum Topic
OK, My questions and issues have been resolved.

First - Yes, a 6s LiPo battery is fine for the Kosmik 160 programming, updating etc.

Next - My original issue was due to me using the Prog Unit lead with the small end (male/servo) inserted into the "Master" port of the ESC (Hey, it fit!). This is NOT correct! you MUST insert the lead from the Prog Unit with the large end (female) by use a male/male connector lead.
Now the Prog Unit will interface happily with the Kosmic ESC and a PC using the Kontronik software (programming or updating). I was successful in updating the ESC from ver 4.5 to ver 4.10 so I can use the Telme Jeti telemetry unit.

Additional - It seems that ver 4.5 did not like me using UDI communication from the Jeti receiver to the ESC for throttle with my V bar Silverline.
Ver 4.10 using the throttle limits /range per the V bar set-up on the default throttle channel 5 worked fine, still using UDI.

Note: after the update to 4.10, The Kosmic ESC would only power-with both LED's solid green ("Programming invalid" ) . I NEEDED to use the "press" button and enter and set mode 1 programming, and then program mode 4 for the helicopter.

All seems to be fine for now.

Sandy
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-06-2017 04:20 PM  3 years ago
Ace Dude

rrProfessor

USA

MyPosts All Forum Topic
Thanks for the update Sandy, glad to hear you got it working. Did you perform the update with or without a motor connected? Just curious if it will work without a motor connected if you tried it that way.  
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-06-2017 04:54 PM  3 years ago
Phoenix NOTAR

rrApprentice

Tallahassee, Florida USA

MyPosts All Forum Topic
Ace Dude,

I updated the Kosmik with just the Prog Unit, usb cable (PC to Kosmik), and a 6s battery connected to the Kosmik. And of course, connecting the Prog Unit to the Kosmik correctly!

No motor connection needed.

Sandy
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-06-2017 05:19 PM  3 years ago
Ace Dude

rrProfessor

USA

MyPosts All Forum Topic
Thanks, good to know for future reference.  
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-11-2017 11:45 PM  3 years ago
Tyler

rrElite Veteran

Chicagoland area

MyPosts All Forum Topic
I am still struggling with getting both of my Kontronik Jive Pro 120 esc's programmed using a Vcontrol radio and ProgUnit.

Enjoy things that money can buy IF you don't lose the things money can't buy.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
02-22-2017 05:02 AM  35 months ago
EEngineer

rrProfessor

TX

MyPosts All Forum Topic
It can be frustrating....was for me.

"Please advise on what I should do to prevent bricking my new esc."

Because of that, I generated a update procedure using first the old ProgDisc....and then the new ProgUnit.

The procedure was in "cook-book" fashion...step by step...with details on what one will see....Must have re-updated my Kos's > 100 times....lol

I found that no matter what I did wrong, the Kos didn't ever "brick"...so don't worry.

What consistently made the upgrade DL "hang" was to touch "anything"....the computer, the mouse or touchpad, etc.

It takes a while to complete, so just be patient as Dr. Ben said....and don't touch it while DLing...lol

FWIW
Logo 600SXs, 800XX, TDR IIs
SHARE  PM  EMAIL  Attn:RR  Quote
02-22-2017 09:49 PM  35 months ago
Dan Minick

rrKey Veteran

Columbus, WI

MyPosts All Forum Topic
I found on my computer the program will freeze up if you mouse click anywhere else. Let it do its thing and dont multitask it should be fineTeam Synergy, Team FBL Rotors-------if its not broke...it will be!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2017 04:33 AM  35 months ago
Dingo07

rrApprentice

Newport Coast, CA - USA

MyPosts All Forum Topic
JIVE Pro 120+ HV
I'm trying to use the ProgUNIT to connect my Jive to the computer so that I can update it or even see it in K-Konfig. Is there an LED on the JIVE that I'm supposed to see light up when I plug in my flight pack to it?
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2017 06:28 AM  35 months ago
EEngineer

rrProfessor

TX

MyPosts All Forum Topic
Did you use the proper progunit cable to plug it into the master port?

Also try executing the K-Konfig program 1st.

FWIW
Logo 600SXs, 800XX, TDR IIs
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 2569 views POST REPLY
HomeRC & Power✈️Aircraft🚁Helicoptere-Kontronik Electric Components › ProgUnit not progressing
 Print TOPIC  Make Suggestion 

 8  Topic Subscribe

Tuesday, January 21 - 3:37 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online