RunRyder RC
WATCH
 1 page 578 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Gy701 governor problems
02-28-2016 02:50 PM  30 months agoPost 1
Jamovich

rrVeteran

Bangalore, India

My Posts: All  Forum  Topic

Hi guys

I'm having serious problems getting my governor to work on my heli (os GT 15hz engine).

Basically whenever I turn on my heli the gyro is flashing red and there is a flashing exclamation mark on the gyro box. According to the very helpful manual it is because the governor cannot be on when the engine is started up and will only work when the condition is off. Here is a (rather long) video showing what the problem is.

Watch at YouTube

Any suggestions would be helpful!

Thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
02-29-2016 04:56 AM  30 months agoPost 2
Jamovich

rrVeteran

Bangalore, India

My Posts: All  Forum  Topic

Anyone? If anyone has a simple guide to setup this governor on a t18sz/mz it would be most helpful. The manual is awful. I'm using it on sbus mode with the governor to be turned off/on by switch.

It is unclear how the switch is assigned to turn the governor on and off.

Do you still need to set the stick position when using the switch? (What does SW on/off mean under the governor basic menu- do I have to do anything??)

Manual alludes to some cryptic setting that is 60% of the set point but if not using the stick to turn on the governor (inhibited) what does this mean I must do??

Is just setting the limit enough?

Does the idle up switch both serve as the switch to turn the governor on/off or does it have to be a separate switch?

If it is a separate switch to which channel do I assign the switch to? There are 2 channels for the governor on the radio.

If anyone can simplfy this it would be most helpful

Thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
02-29-2016 06:35 AM  30 months agoPost 3
Dr.Ben

rrMaster

Richmond, VA, USA

My Posts: All  Forum  Topic

Are you setting up with SBus and conventionally? You turn off stick switching if you are using a switch. Make sure the on/off channel is correctly assigned to your chosen switch in the trans's function menu.

Ben Minor

Peak Aircraft/Team Minicopter Team Futaba Team Kontronik USA

PM  EMAIL  GALLERY  Attn:RR  Quote
02-29-2016 05:56 PM  30 months agoPost 4
ZR2Chevy22

rrApprentice

Kemah, TX

My Posts: All  Forum  Topic

Why not setup your RPM channel to 7 and then set rpm 1 to off, rpm 2 to your desired head speed in idle 1 and rpm 3 to your other desired head speed in idle 2.

I set mine up where normal and idle 1 are the same pitch curve (for sport flying) only difference is governer is on in idle 1 and off in normal. Idle 2 is governor on and mirrored collective.

It's Chevy's Fault!!!!
Team Me

PM  EMAIL  GALLERY  Attn:RR  Quote
02-29-2016 06:27 PM  30 months agoPost 5
Jamovich

rrVeteran

Bangalore, India

My Posts: All  Forum  Topic

Thanks Ben that was the problem. I assigned it to the wrng channel. Now it works

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 578 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Gy701 governor problems
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, August 20 - 5:31 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online