RunRyder RC
WATCH
 1 page 439 views POST REPLY
HomeRC & PowerAircraftHelicopterFlybarless Rotor Head SystemsV-Bar › vbar 5.3 DSM2 gov setup---what am I doing wrong
01-23-2016 03:51 PM  33 months agoPost 1
cudaboy_71

rrElite Veteran

sacramento, ca, u.s.

My Posts: All  Forum  Topic

Trying to help a buddy set up a minivbar 5.3 pro on his DX9

I've done this many times on my own helis, but the sensor count thing is throwing me on this one for some reason.

gov and hobbywing sensor are set up and working apparently fine. He's running a scorpion HK2221-10 on a 450. In the gov2 tab I've set the max HS to 3200, ratio to 12.5 (150t main w/ 12t pinion), and entered 3 for pole count (half of 6 magnetic poles).

I've done this many times on my own 450s and it worked great...even on this same spec motor and hobbywing sensor.

Problem is, it's showing 1930 requested and 2400 current HS in the software.

Ok, so I tried putting *actual* sensor count in as 6. Now HS requested and current is showing correctly in the software. But, the HS SOUNDS way too high...like it might actually be double.

If I had an optical tach I could verify. But, I don't. I have a software tach, but it requires the blades to be on. But, I'm afraid I'll throw the grips if I'm really running double.

Has anyone EVER had to set the actual sensor count on an electric motor? (I haven't). Any other ideas what may be going on? I'm stumped, thinking maybe it's something I'm not familiar with in the DX9---it's very similar to my old 9303 software, but not identical.

if it ain't broke, break it.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-23-2016 11:12 PM  33 months agoPost 2
cudaboy_71

rrElite Veteran

sacramento, ca, u.s.

My Posts: All  Forum  Topic

update: still no fix

I decided to dial the gov down to 45% t-curve and put on blades.

based on gearing and motor, I should have a theoretical max headspeed of 3800RPM ((3000kv * 16.8v)/12.5 )*.94 = 3790 (it's a 4s setup)

So, setting the t-curve to 45% should yield about 1705RPM.

I turned on my software tach and it reads 1685...or pretty much right on. But, the main screen on the vbar software shows only 800RPM requested and 800RPM current. So, the sensor is reading, and the vbar is maintaining. It's just showing the wrong value.

When I figured this out, I facepalmed..."oh, I just counted the pinion wrong, so the ratio is not correct" I double and triple checked. It is definitely a 12t pinion. And, the trex 450 straight gears only come in 150t.

At least now it can be flown. But, I have to manually calculate the headspeeds in order to set the t-curves. Plus, he'll have to remember to not trust the software RPM readings.

I'm sorely tempted to fudge the ratio so that the RPMs are closer to actual.

Is there some secret setting in the vbar that could be overriding what I have set in gov2 tab?

if it ain't broke, break it.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 439 views POST REPLY
HomeRC & PowerAircraftHelicopterFlybarless Rotor Head SystemsV-Bar › vbar 5.3 DSM2 gov setup---what am I doing wrong
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Thursday, October 18 - 11:02 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online