RunRyder RC
WATCH
 1 page 853 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › Trex 450 pro issues
09-12-2015 09:07 PM  3 years agoPost 1
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Having issues with throttle headspeed . When I advance throttle it climbs very slowly like there is not enough headspeed. I am running a mx450 stock 35 amp esc, 13 tooth pinion, +12-12 , 0 mids tick this thing should take off like a rocket but it does not. My throttle curves are norm 0, 50, 100, idle 1 100 straight pitch set At 50, 50, 100 in normal and 0,50,100 idle 1 using 9503 tx. I have had other 450 pros set up like this and they have flown aperfect but this is baffling to me. I have tried different motors and esc with same result. Thanks for looking and any help would be appreciated
Also not running Governer modez

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-12-2015 10:04 PM  3 years agoPost 2
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

When you advance the throttle to mid stick AND WAIT A FEW SECONDS does the throttle come to flying speed ?? It should if all ok....

If not, it's probably a setting on your ESC ...... It's designed to ramp up slow (if set up properly) so that a sudden and abrupt throttle does not strip your main gear due to the sudden torque ....

Check your ESC settings and see what your choices are under "startup"

The other thing you can try is to re-calibrate your throttle stick .... Make sure that your throttle trim is all the way down and that you "temporarily" set your throttle curve to 0-25-50-75-100 before you calibrate. Afterwards , you can adjust the throttle curve to your liking ....

Let us know how you make out .....

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
09-12-2015 10:15 PM  3 years agoPost 3
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

I have esc programmed to soft start.. Will calibrate and see thanks

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-12-2015 10:38 PM  3 years agoPost 4
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

It is set up in soft start and I calibrated throttle with trim all the way down with no luck. Seems

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-12-2015 10:59 PM  3 years agoPost 5
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Did you remember to set your throttle curve from what you have it now to 0-25-50-75-100 before re-calibration???

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
09-12-2015 11:14 PM  3 years agoPost 6
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Yes even idle up 1,2. At +12 it should be a rocket. Just seems like it is not getting enoug head speed. Might have to buy a tach to c how fast head is spinning.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 12:39 AM  3 years agoPost 7
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Seems kinda silly to ask but are your blades on the right way around ??

I wonder if your one way clutch is working properly is, slipping ????

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 12:57 AM  3 years agoPost 8
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Blades right and have tried two one way bearings to make sure. It flies great otherwise.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 01:08 AM  3 years agoPost 9
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Humm, sounds like you've tried just about everything.....
How are you measuring your blade pitch ???

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 02:13 AM  3 years agoPost 10
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Pitch gauge for 450.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 04:12 AM  3 years agoPost 11
AWittleWabbit

rrElite Veteran

O.C., CA

My Posts: All  Forum  Topic

Questions for you
Are you using the 3400kv 450MX?

Are your lipos healthy?

Heli-itis sufferer.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 01:57 PM  3 years agoPost 12
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Yes on motor and lipos 40c new lipos

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 02:23 PM  3 years agoPost 13
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Any chance you can post a short video of what you're experiencing ?? Might help to "hear" what's going on .....

Also, without the motor spinning the blades, the "pitch range" showing low, middle and high stick ??

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 02:29 PM  3 years agoPost 14
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Well I tried a 15 tooth pinion and it is performing . Had to dial back headspeed but it is doing as it should. Also dialed pitch back to +11-11. Can not explain why head speed was not as it should be with a 13 tooth pinion but it's working great now. Thanks for the help.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 02:39 PM  3 years agoPost 15
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Know the problem now. I was using a 1700kv mx with 13 tooth just as the previous person asked. I put in a 3400 kv that was in parts bin with a 15 tooth pinion in no wonder I had to dial back head speed. Need to pay more attention to the details . Thank you Gus for the help RR is the best!

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 02:50 PM  3 years agoPost 16
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Glad you found the problem !

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2015 11:35 PM  3 years agoPost 17
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Thank you.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 853 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › Trex 450 pro issues
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, September 24 - 12:51 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online