RunRyder RC
 4  Topic Subscribe
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1328 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 300 › 7200bx / 300 ISSUE
06-25-2015 12:18 PM  36 months ago •• Post 21 ••
fla heli boy

rrKey Veteran

cape coral, florida

My Posts: All  Forum  Topic

hey... not silly at all.
But, I'll say this... he has redone the setup like 100 times.
But I'm going to shoot him a text right now just in case.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-26-2015 05:33 AM  36 months agoPost 22
PilotPin

rrApprentice

Indiana -- USA

My Posts: All  Forum  Topic

Did you spin it up without the main and tail blades. Then watch the swash for movement. This would be the best way to find a vibration problem.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-26-2015 11:25 AM  36 months agoPost 23
fla heli boy

rrKey Veteran

cape coral, florida

My Posts: All  Forum  Topic

yes, that's how he's been testing it.
He thinks it might be a motor bearing since those stock motors are notorious for that. I also told him to pay particular attention to step M in the setup.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-26-2015 11:36 AM  36 months agoPost 24
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

Ah so he's been testing it without blades and the swash suddenly jerks to the right?

I've had this happen and funnily enough it was with those KST servos! I never managed to fix it, tried different servos, eventually sent the BeastX back but also sold the 450.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-26-2015 01:17 PM  36 months agoPost 25
fla heli boy

rrKey Veteran

cape coral, florida

My Posts: All  Forum  Topic

well, it did that with the e-flite servos, which is why he changed to KST's. He's also changed BACK to the E-flites.... same thing.
We also put one of my new BX's in there. Same thing.
So he replaced all bearings, the frames (which did have a crack), replaced gyro tape with 3 different kinds...all no joy.
I think you might've been right about sensor direction. He's going to go thru the setup from scratch again... one more time. I'm hoping he just overlooked that step. He was somewhat of a noob, but by now he should be a BX expert...

PM  EMAIL  GALLERY  Attn:RR  Quote
06-26-2015 01:23 PM  36 months agoPost 26
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

It is very easy when checking the sensing directions to think "I'm tilting the helicopter to the right so the swash tilts to the right so that must be right!"

Having said that you say he's tried it with no blades and no cyclic input and the swash still goes hard right? I don't think it would do that even if the sensing direction was wrong.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-26-2015 04:08 PM  36 months agoPost 27
fla heli boy

rrKey Veteran

cape coral, florida

My Posts: All  Forum  Topic

all I know is that it's on his last nerve. I can't help because I'm 1300 miles away, though we did try when he was here on vaca a while back.
I'll headed up there to go to IRCHA with him and my dad, so hopefully he'll have it fixed by then before it becomes MY headache...

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1328 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 300 › 7200bx / 300 ISSUE
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Friday, June 22 - 6:49 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online