RunRyder RC
WATCH
 1 page 684 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade Nano › Blade Nano! No Left Rudder Solved!!!
03-16-2015 02:12 AM  3 years agoPost 1
Bladecpnitro

rrApprentice

Ga

My Posts: All  Forum  Topic

This heli has a 16,600KV Brushless motor, stock tail with a 125mm solid boom and stock tail motor. All else is stock. I've used all kinds of different lipos but now Im using eflite 150 45C Lipos. I'm still looking for better lipos in the 200 Mah range. 150 gives short 2:30 flight times but have a lot of pop with the weight savings. I used magnet wire from radio shack for longer tail motor wires and soldered them strait to the board to avoid tail failures.

The longer boom gives the tail motor a more leverage to handle the much more powerful brushless motor and has never had a problem holding the tail even in ridiculously high winds. For some reason the Nano's tail motor last much better than the Blade SR's brushed tail motor. I was lucky to get 70 flights out of those and have a pile of them.

I had sort of gotten discouraged with it after buying several parts and getting it going again and again and something else would fail and crash it and destroy my new parts.

Anyhow the tail went nuts on me the last time I fooled with it and I just parked it a while. Also the right servo had gotten to where it would come lose in flight and cause unnecessary crashes. That was fixed before the tail went nuts.

The problem I found was several. I had replaced the tail FET a while back and its very hard to see the solder joints without a magnifying glass. Turns out I had a poor solder joint on one of the 3 legs on the FET. Actually I think the solder must have popped off because there didn't appear to be any there on that leg.

Problem one solved! No left rudder. Although it had worked many flights the poorly soldered tail FET was the reason my tail had started only going nose right. The tail motor would not slow to a stop with full left rudder like it should, it continued to spin hard enough to piro the heli non stop even at full left rudder.

Problem 2... heli not initializing every time solved.
I had a poor connection from the ground of the ESC to the main board. The battery lead came to the ESC first and then onto the main board. I've never had much luck with that setup so I moved the battery leads back to the stock location on the main board and feed the ESC from those terminals from the front side of the board.

All is working well and I guess I'm a little excited.
And maybe it'll help some others figure out issues with their Nano.
Cheers!

If its fixed don't break it.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 684 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade Nano › Blade Nano! No Left Rudder Solved!!!
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, August 20 - 7:33 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online