RunRyder RC
WATCH
 1 page 1080 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 180CFX › Cyclic Servos
03-09-2015 06:17 PM  3 years agoPost 1
wrh0627

rrNovice

kelso, Wa

My Posts: All  Forum  Topic

I recently update my 180 cfx firmware to the latest revision1.53 but when I tried to fly it I noticed that all cyclic servos were all moving at the same time causing the whole helicopter to shake even after putting it in hold. I have upated my dx9 to the latest revisions for the firmware & sound and I rebound my radio to the heli before the fist flight so what gives? I have flown the heli and it flys great I just have to put my finger on the blades lightly and they stop moving.
Has anybody had this problem? If so what did you fo to fix it? I don't have my radio to close to the heli when I first plug it in so I assume that the radio is not the cause of this by being to close when the fbl unit is intializing at start up.

Thanks for the help and I'm sorry inadvace if this was discussed in an earlier thread.

PM  EMAIL  Attn:RR  Quote
03-10-2015 03:57 PM  3 years agoPost 2
BJames111

rrElite Veteran

San Diego, California

My Posts: All  Forum  Topic

Can you confirm that when you straighten the blades out in the grips this still occurs?

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-10-2015 11:43 PM  3 years agoPost 3
wrh0627

rrNovice

kelso, Wa

My Posts: All  Forum  Topic

I tried to flim the problem today and submit it but for the life of me it worked perfectly no matter what I did, unlike what it was doing last weekend.

I always make sure the heli is sitting on a level surface and the blades are alway striaght in the grips before I plug the battery in. When the cyclic servos all start to move around all it takes to make them stop is to put my finger on one side of the blades lightly and it calms all of them down.

I will film the heli next time it starts doing this, but for now I guess my problem is solved.

Thanks agin for your inquiry about this problem.

PM  EMAIL  Attn:RR  Quote
03-14-2015 10:46 PM  3 years agoPost 4
hyp05fxdl

rrNovice

King George Virginia USA

My Posts: All  Forum  Topic

Is it just doing that when you plug the battery in? If so does it stop after a few seconds? If both are the case mine does the same thing but flies fine.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1080 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 180CFX › Cyclic Servos
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Sunday, August 19 - 6:40 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online