RunRyder RC
WATCH
 1 page 1482 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - JR DMSS › XG14 IKON setup
01-11-2015 07:14 PM  5 years ago
Topic Vote0Post 1
The3dcrasher

rrNovice

Peabody MA USA

MyPosts All Forum Topic
XG14 IKON setup
Hi guys, Im trying to set up Ikon on 731bx receiver. First timer. I have set up radio as instructed for HOTT receiver. Transmitter is set under Xbus as mode B. The swashplate is set to 1 servo. I made wire to connect signal to center wire on CH 4 5 6, and other two wires in CH 3 on Ikon. Under Transmitter set up on IKON everything seems to be working like it should under IKON's transmitter display, and under xg14 transmitter display. Before checking display I went under Advance menu in the IKON. I changed channels to match IKON. This is what I did:

Ikon Transmitter
Receiver type.......................... .......HOTT
aileron........................................Channel 1
Elevator.......................................Channel 2
Tail............... ...........................Channel 3
pitch............ .............................Channel 4
Gain................... .......................gear Channel 6
Setup Selection ...............................Channel 7
Throttle.......................................Channel 5
Aux............... ............................Channel 7

All cyclic servos are working fine. I am having problem getting tail servo and throttle to respond to transmitter stick. I am using all JR servos. JR8917 on cyclic and throttle, and SPG01 for tail. The heli is a Trex 700 Nitro. Under IKON's servo selection I chose for the 8917's high end digital, and for the tail servo SPG01 I selected specific digital.
So this is where im lost the throttle servo when I go to full throttle with throttle stick moves very very slow. But when I bring throttle to closed position it moves very quick. On the tail servo, rudder stick only moves the servo a tiny bit, but only in one direction. I think my issue is in setup of transmitter.
Status light on IKON is solid green and active set up light is flashing continuously two red blinks when turned on.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-11-2015 08:17 PM  5 years ago
jmiceli11

rrApprentice

Erie, PA, USA

MyPosts All Forum Topic
Make sure you don't have the governor enabled until the servo is set up. It sounds like you do. The throttle will slowly move up until the desired rpm is achieved as a safety measure.

Also throttle is channel one on JR and pitch is six. Remap those channels and see.

John
Team Synergy, Rail Blades, Team JR Americas, Lynx Heli
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-11-2015 09:28 PM  5 years ago
The3dcrasher

rrNovice

Peabody MA USA

MyPosts All Forum Topic
When using xbus, the xg14 manual ishows xg14 throttle channel is channel 5 under mode b. Also pitch is channel 4.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-11-2015 11:08 PM  5 years ago
jmiceli11

rrApprentice

Erie, PA, USA

MyPosts All Forum Topic
I sent you a detailed PM please take a look.

John
Team Synergy, Rail Blades, Team JR Americas, Lynx Heli
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-12-2015 01:15 PM  5 years ago
The3dcrasher

rrNovice

Peabody MA USA

MyPosts All Forum Topic
Thanks for reply still have no throttle or tail servo movement. Governor is off.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1482 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - JR DMSS › XG14 IKON setup
Print TOPIC

 2  Topic Subscribe

Saturday, December 5 - 3:35 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online