RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 408 views POST REPLY
HomeAircraftHelicopter
e-
Electric General Discussion
› Blade 500 3d
10-21-2014 11:21 PM  3 years agoPost 1
erikb

rrNovice

atlanta ga

My Posts: All  Forum  Topic

Bought a second hand 500 and it is not smooth at all. I have a raptor 50 that I fly and a blade 4 hundred that hover very well..but the 500 is all over in a hover..r they like this. I suspect the stack up thought the blade grips is not correct....it is not vibrating and track looks good but it doesn't want to stay in one place at all....any suggestions...I'm thinking of looking for a stock head..it has a metal one and I can't verify hardware in it cause I don't know what kind it is...thx

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2014 04:39 AM  3 years agoPost 2
Slowpoke

rrKey Veteran

Dublin, OH

My Posts: All  Forum  Topic

Without seeing it, I can only offer a couple of possibilities.

What headspeed are you running? Too low of a headspeed will make it hard to maintain altitude in a hover.

Also, check your throttle and pitch curves to make sure there are no sudden changes in the curve.

Maybe dial down the dual rates and/or use a little expo to tame things down.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 408 views POST REPLY
HomeAircraftHelicopter
e-
Electric General Discussion
› Blade 500 3d
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Wednesday, June 20 - 8:27 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online