RunRyder RC
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 2962 views POST REPLY
HomeAircraftHelicopterLow Head Speed Helicopters › Boom Support Removed?
01-26-2015 04:59 AM  3 years agoPost 21
lloyd

rrKey Veteran

Perth,Australia (South African)

My Posts: All  Forum  Topic

It's not a 800 size machine but I took mine off and hadn't had a problem since but then again I'm no 3D guro

electrics DONT need to auto

PM  EMAIL  GALLERY  Attn:RR  Quote
01-26-2015 05:05 AM  3 years agoPost 22
gologo

rrKey Veteran

Sedalia, Mo USA

My Posts: All  Forum  Topic

Is that a Logo600 or 690 or.....?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-26-2015 05:23 AM  3 years agoPost 23
lloyd

rrKey Veteran

Perth,Australia (South African)

My Posts: All  Forum  Topic

Logo 400 SE swinging 500mm blades

electrics DONT need to auto

PM  EMAIL  GALLERY  Attn:RR  Quote
01-26-2015 05:26 AM  3 years agoPost 24
gologo

rrKey Veteran

Sedalia, Mo USA

My Posts: All  Forum  Topic

Man, I was waaaay off...trying to look by those angles....

BTW, I do remember running my L10 w/o boom supports near the end of my
time w. it. No issues either.

PM  EMAIL  GALLERY  Attn:RR  Quote
07-22-2015 07:21 PM  3 years agoPost 25
old nitroman

rrVeteran

Naples florida

My Posts: All  Forum  Topic

Make up brackets and put one support on

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 2962 views POST REPLY
HomeAircraftHelicopterLow Head Speed Helicopters › Boom Support Removed?
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Monday, August 20 - 12:27 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online