RunRyder RC
WATCH
 1 page 2062 views POST REPLY
HomeScaleAircraftScale HeliVario Scale Helicopters › Vario Schweizer 300 engine
07-21-2014 02:47 AM  4 years agoPost 1
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

I recently received an older Vario Schweizer 300. It has a Vario engine
The engine needs to be rebuilt but I'm not sure what size or model it is.
The info on the engine is 22ccm Benzinmotor
1:25.
Where can I get parts for this Vario engine, or what would be a good replacement for this engine.
Thanks

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-21-2014 12:37 PM  4 years agoPost 2
Notar

rrKey Veteran

Taxachussetts

My Posts: All  Forum  Topic

Zenoah RC240 is a very good replacement for this motor. We have them with the different carb installed on the motor, for easy tuning.
Joe

PM  EMAIL  GALLERY  Attn:RR  Quote
07-21-2014 02:23 PM  4 years agoPost 3
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

Thanks Joe
Ill be in touch

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-18-2014 03:36 PM  4 years agoPost 4
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

I want to give a thank you to East Coast Scale for the info and fast shipping of my order.
Ordered some parts on a Friday and was thrilled to see them on my door step Saturday.
Great service.
Thanks Joe

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-06-2014 11:15 PM  4 years agoPost 5
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

I replaced the engine with a G240rc Zenoah.Its running on the factory settings and seems to run well, not 1/2 a tank through it yet.
Some questions I have are:
Can you use an AR7200bx with this 3 blade head?
If so where and how did you mount it?
This heli goes crazy just as its lifting off the ground,
its un-flyable, wants to roll left and usually results in a tail strike.
I've set up other AR7200bx units so I know its correcting properly.
I've run it up without the blades and the swash doesn't move.
All blades are balanced and new.
I'm not sure if the phasing is correct as I've never had a multi blade head
I'm losing some patience with this one, I appreciate any input on 7200bx settings or head phasing.
Thanks

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2014 12:16 AM  4 years agoPost 6
doorman

rrProfessor

Sherwood, Arkansas

My Posts: All  Forum  Topic

7200Bx
This rx will not let you do electronic phasing, so you will need to phase it mechanically.. (not bad on a 3 blade)
Pull up Peter Whales here on RR and go to his website.. he has an excellent explanation on how to set up phasing.That should get you going..
If your swash is not moving with the engine running, you are going to have to relocate your rx away from the engine...are you running a sheilded plug cap?? If not you will need to get one..
Once you get things working, make sure you do a complete range check with engine off and again running..put the heli in the center of the field and walk all the way around it..
Hope this info helps you out..

Stan

AMA 2918-Team Spin Blades,,Castle Creations, Unique Aircraft

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2014 12:41 AM  4 years agoPost 7
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

I'm not using a shielded plug cap and the receiver is very close to the plug and wire. Where can I find this shielded plug cap?
How far from the engine should It be?
Thanks

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2014 01:50 AM  4 years agoPost 8
doorman

rrProfessor

Sherwood, Arkansas

My Posts: All  Forum  Topic

Plug Cap
I am sure Joe has them in stock at East Coast..
I would suggest putting the rx on the top rear of the heli.. build a plate in behind the main shaft.. or take a piece of angle aluminum and bolt it to the outside upper sideframe.. that should get you far enough away!!
Good luck
Stan
.

AMA 2918-Team Spin Blades,,Castle Creations, Unique Aircraft

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2014 12:44 PM  4 years agoPost 9
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

Thanks for the info, Ill give it a try

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2014 01:15 PM  4 years agoPost 10
Notar

rrKey Veteran

Taxachussetts

My Posts: All  Forum  Topic

All of the gas models had built in phasing on the mechanics on this heli. Check out the build plan here; http://www.vario-helicopter.net/pro...r-300c-145.html

Go to the build plan and look at printed page 6 of the instructions, in where it shows how it should look for the phasing on this model. If you set it up this way, no other phasing is required.
Joe

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2014 04:01 PM  4 years agoPost 11
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

I looked at the build plans and my swash is set up the way it says.
Should the follower be set so the links from the inner swash to the blade grips are straight?
Thanks

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2014 05:15 PM  4 years agoPost 12
Notar

rrKey Veteran

Taxachussetts

My Posts: All  Forum  Topic

Yes, the rods should be straight. When you give forward cyclic, the swashplate will tilt forward and to the right pointing to the 2 oclock position. Back will point left at about 7 oclock.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2014 05:28 PM  4 years agoPost 13
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

Thanks, This may be my problem as I think I have the phasing off quite a bit.
Thank you all for your help.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2014 05:31 PM  4 years agoPost 14
Notar

rrKey Veteran

Taxachussetts

My Posts: All  Forum  Topic

Once the rods are straight, position a blade over the tail boom. Give slow forward and back cyclic, and the blade should barely move at all when giving this command.
Joe

PM  EMAIL  GALLERY  Attn:RR  Quote
10-09-2014 04:19 PM  4 years agoPost 15
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

I've mover the follower so the links to the blade grips are straight, with one blade over the tail boom I get a lot of blade movement when I give forward or back cyclic. When I set the follower as in the pictures I get very little blade movement but only when I give right or left cyclic with one blade over the tail boom.
The photos show the type of swash I have.
I'm using a 7200bx FBL unit and the swash tips straight forward and straight back when I give forward or back inputs.
Still not sure if this is right.
Thanks

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-10-2014 12:37 PM  4 years agoPost 16
Notar

rrKey Veteran

Taxachussetts

My Posts: All  Forum  Topic

I am wondering if you have the servos plugged in properly.
The servo on the left side of the side frames is the aileron servo.
The servo on the right side in the front is the elevator servo, and the servo in the middle of the side frames controls the swashplate in the rear right is the collective servo. I am also not sure you have the balls positioned on the inner ring of the swashplate at the 120 degree spacing that is required. Check this as well.
Is this correct?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-11-2014 01:38 AM  4 years agoPost 17
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

Well Joe you were right, I found that I had the elevator and pitch servos reversed. The swash plate now moves as you described.
I'm looking forward to trying it.
Thank you for all your input
CR

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-11-2015 01:53 PM  3 years agoPost 18
kljw

rrNovice

Penicuik, Midlothian, Scotland

My Posts: All  Forum  Topic

Headsetup
Hi,
I am having similar issues with head setup. the first problem is that I am unsure of ball link positions, and second, unsure of where the phase should be set to.
looking at the pictures you have posted helps, but do you happen to have any pictures taken directly above in order to see correct position of fixings?

Keith

PM  EMAIL  Attn:RR  Quote
03-12-2015 02:08 AM  3 years agoPost 19
crflyer

rrApprentice

Maine

My Posts: All  Forum  Topic

Here are some pics of the head the way mine is setup, Fly's very well.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-12-2015 02:00 PM  3 years agoPost 20
kljw

rrNovice

Penicuik, Midlothian, Scotland

My Posts: All  Forum  Topic

Rotorhead Layout
Hi
many thanks for the pictures, just what was needed.
Keith

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 2062 views POST REPLY
HomeScaleAircraftScale HeliVario Scale Helicopters › Vario Schweizer 300 engine
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Saturday, December 15 - 8:23 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online