RunRyder RC
WATCH
 1 page 987 views TOPIC CLOSED
HomeAircraftHelicopter
e-
Align
T-REX 500 Vids  Electrical pre-flight issue
12-30-2013 09:51 PM  4 years agoPost 1
dj80550

rrVeteran

Texas

My Posts: All  Forum  Topic

This is a first with the 500. Plugged the lipo in, ran through controls, then receiver light went off and no cyclic action. New lipo and AR 7610 receiver with beastx. Castle esc is quite warm after cycling controls in the video. Periodically, aileron servo will stick (new ds515). Rebinded several times, swapped batteries, any experience in this?

Watch at YouTube

PM  EMAIL  Attn:RR
12-31-2013 02:58 AM  4 years agoPost 2
dj80550

rrVeteran

Texas

My Posts: All  Forum  Topic

Did several range checks, wire swapping..definitely seems to be dx7 or the RX's. Tried a ar 7000, same thing sudden lock-up of cyclic, sometimes no recovery. Two receivers? Must be a TX glitch that isn't linking to the band.

PM  EMAIL  Attn:RR
WATCH
 1 page 987 views TOPIC CLOSED
HomeAircraftHelicopter
e-
Align
T-REX 500 Vids  Electrical pre-flight issue
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Saturday, December 15 - 6:08 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online