RunRyder RC
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 3091 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Logo 500 › Tail Wag help
10-13-2013 04:47 PM  4 years agoPost 1
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

I cannot seem to get rid of a tail wag I have with my 500. The model has about 100 flights on it and I am using the mini vbar. I found a video on Youtube where someone else experiences the same problem. This is NOT my model:

Watch at YouTube

I have lowered the gain to about 25 and something else must be going on. Is there a gain value that would be considered too low? What could happen if it's too low?

I have checked the blades and they are balanced. I also have checked the tail slider and mechanics and there is no binding and everything moves very easily. Anytime I try a nose down funnel or similar maneuver I can hear and see the tail start to wag and I slow things down a bit for fear of the tail breaking loose. My head speed is 1900 rpm. I am afraid to attempt any pyro moves. I still consider myself fairly new to flying but I can fly inverted and perform some basic 3d stuff but the wag is keeping me from going all out Any help would be greatly appreciated.

TIA,
Andy

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 04:56 PM  4 years agoPost 2
wrongler

rrProfessor

Brewerton, New York

My Posts: All  Forum  Topic

What tail servo? Are they the right size tail blades?

Bill Whittaker

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 05:05 PM  4 years agoPost 3
Qrrambero

rrKey Veteran

San Francisco / Bay Area

My Posts: All  Forum  Topic

Are you using the original Logo tail blade holder and hub? Or are you using the Quick UK ?

Ae

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2013 12:05 PM  4 years agoPost 4
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

I am using a new Align DS655 which I use on my 600 without issue. I was using a set of Align blades but I swapped them out with the original blades that came with the kit but still have the same issue. I am using the original parts that came with the kit. I don't know what a Quick UK is????
I am going to have to take the tail apart and double check everything. I swapped the blades out yesterday in hopes that was the problem. I'm hoping that the servo is not a dud but I don't think so since it's new. Thx for the advice.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2013 02:13 PM  4 years agoPost 5
KevinB

rrKey Veteran

Saskatoon, Saskatchewan, Canada

My Posts: All  Forum  Topic

I changed mine to the Quick UK tail just because as the weather turns colder here, I didn't really trust those skinny little pitch arms on the stock tail grips. The Quick UK tail has less slop in it than the stock also. In sideways flight or funnels now, tail is quieter.

I had a wag in my 550sx that was there with the stock and Quick UK tail. The way I finally got rid of it was increasing the I Gain in the advanced tail settings (vbar) from the default of 60, to 80. I had to bring the basic tail gain down a little from where I had it because I would then get a little high speed wag under certain flight conditions. After tweaking that, my wag was pretty much gone.

KevinB

PM  EMAIL  GALLERY  Attn:RR  Quote
10-15-2013 12:29 AM  4 years agoPost 6
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

I'm having troubles finding a Quick UK Tail Grip Assembly for the 500. If you happen to know of a place I could purchase it it would be greatly appreciated?

TIA,
Andy

PM  EMAIL  GALLERY  Attn:RR  Quote
10-15-2013 04:23 PM  4 years agoPost 7
cgflyer

rrApprentice

Boca Raton, FL

My Posts: All  Forum  Topic

PM  EMAIL  GALLERY  Attn:RR  Quote
10-15-2013 04:56 PM  4 years agoPost 8
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

Awesome thank you. Sorry for the dumb question but the page states that it is for the 600 will it fit on the 500?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-15-2013 05:14 PM  4 years agoPost 9
cgflyer

rrApprentice

Boca Raton, FL

My Posts: All  Forum  Topic

No Dumb questions Andy , yes it will fit both the 500 and 600.

Rich

PM  EMAIL  GALLERY  Attn:RR  Quote
10-16-2013 02:52 PM  4 years agoPost 10
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

cgflyer,

I was looking at the KDE Direct Performance Tail Control unit on your site:

http://www.readyheli.com/ML40050060...E--p-39144.html

Would this be a better option? I see that you guys do not sell one of the required parts(HN6103). I have read that the unit does not fit on some machines but it does look really nice and if it fits and works well I'd like to get that particular setup if possible???

PM  EMAIL  GALLERY  Attn:RR  Quote
10-16-2013 03:40 PM  4 years agoPost 11
cgflyer

rrApprentice

Boca Raton, FL

My Posts: All  Forum  Topic

Hi Andy, in my opinion this is not needed and may be a little overkill for what you are looking for. Again just my opinion as some pilots really like this set up. I am also not convinced that this will solve your tail wag. As far as gain goes there is no real high or low number and keep in mind your radio numbers are only a reference and the actual gain will be displayed on the Vbar main screen. Most pilots who have this type of issue usually find the slightest binding or rough spot on tail shaft as the vbar is very sensitive to vibrations. Also if this is a mini, make sure the main board is not loose in the Vbar case. Lastly as you mentioned earlier, try a good set of carbon tail blades. Hope that helps.
ReadyHeli
Tech Support

Rich

PM  EMAIL  GALLERY  Attn:RR  Quote
10-16-2013 03:47 PM  4 years agoPost 12
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

Thx Rich. I think I will go with your original suggestion. I realize it may not fix my wag but I'd like to upgrade the tail since I am falling in love with this model and my other Logo as well. I also have been looking to get another model but most people I have talked with state that the Logos are the best. I don't want to get something not as good if you know what I mean.

Thx again,
Andy

PM  EMAIL  GALLERY  Attn:RR  Quote
10-16-2013 03:53 PM  4 years agoPost 13
Qrrambero

rrKey Veteran

San Francisco / Bay Area

My Posts: All  Forum  Topic

We have few logos in our area and we have seen this problem.
First the tail needs to move freely from the center to the left and to the right. Remove the tail rod from the servo and make sure that the tail control plate move freely.
We have solved the problem just using a 600 sand paper. You sand the tail shaft and put a drop of oil and check that the tail control move freely. Hope this help.

Ae

PM  EMAIL  GALLERY  Attn:RR  Quote
10-23-2013 04:46 AM  4 years agoPost 14
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

I got the Quick UK Tail Grip Assembly which looks good. I have a question regarding tightening the brass color on the tail slider? I'm not sure I have the correct part names but please see the attached image. I circled the part I have a question about. Should this be tight enough where the bearing can spin freely? I'm sure it must be able to, it is a bearing but I want to make sure I get rid of this wag. I can almost feel how the slider may studder when moving across the shaft.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-24-2013 02:08 PM  4 years agoPost 15
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

Does anyone know how tight this needs to be? Anyone out there

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2013 12:40 AM  4 years agoPost 16
KevinB

rrKey Veteran

Saskatoon, Saskatchewan, Canada

My Posts: All  Forum  Topic

Yes, the bearings should spin freely.

If you don't tighten it enough, there will be slop between the input collar (riding on the bearings) and the brass slider/output arm forks.
If you over-tighten it, the input collar bearings will begin to preload and will no longer spin freely.

You need to find that happy spot with no slop, and little to no preload on the bearings so everything moves freely.

KevinB

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2013 02:19 AM  4 years agoPost 17
BobOD

rrElite Veteran

New York- USA

My Posts: All  Forum  Topic

Your terminology on the heli stuff is fine Andy, but you didn't circle it, you squared it.
Sorry, I couldn't resist.

In addition to what Kevin said, make sure you haven't tightened it so much that the bearing race has impressed into the plastic fork. If permanently deformed, you'll have trouble. And avoid getting glue in the bearings. I figure you know that. I slip the edge of a paper towel in just before the last few turns to wick out any adhesive that might go into the bearing.

As for any high spot on the shaft causing the slider to stutter, you may have to do a little polishing. Needs to be absolutely smooth.

Team POP Secret

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2013 01:46 PM  4 years agoPost 18
HeliNutAndy

rrKey Veteran

worcester, MA USA

My Posts: All  Forum  Topic

Thx guys for the help I put the parts on last night and I really like the UK parts over the stock ones. It's so difficult to tell if the slider is moving freely because there seems to be a tiny amount of stutter. Before I sand the shaft I am going to take the model out for a flight or two to see if the new parts made a difference. I also purchased a new canopy. I can't believe how much better an after market canopy from Mikado is compared to the stock one that came with the kit. I thought the price was a bit high($125). It is much thicker and seems to be made from a better quality fiberglass. It's also much brighter than the stock red/blue one that came with the 500.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-26-2013 04:18 PM  4 years agoPost 19
smittylube

rrVeteran

Santa Cruz, CA

My Posts: All  Forum  Topic

Have you sanded the tailshaft as suggested, looked for flashing in the grips. How are you balancing the blades? The best way is the analyzer and feel of the boom spooled up w tail blades only IMO.
I had the quick and won't use anything but stock now.

RPM is your friend..................................until you crash

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-26-2013 10:20 PM  4 years agoPost 20
Busher

rrKey Veteran

Manchester, England

My Posts: All  Forum  Topic

Let us know how you get on

Good luck
Busher

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 3091 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Logo 500 › Tail Wag help
 Print TOPIC  Make Suggestion 

 10  Topic Subscribe

Saturday, July 21 - 8:41 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online