RunRyder RC
WATCH
 1 page 1195 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › Really weird issues, random aeloron rolling out of no where?
10-13-2013 02:08 AM  4 years agoPost 1
soulrider911

rrVeteran

Novato Ca

My Posts: All  Forum  Topic

Hey guys so I have been flying the blade 300 basically every other day, and it has been great. Today I lift of and immediately noticed that it is rolling RRAL HARD to the right, the more it tilts the worse it gets, it almost the the beast is trying to correct, but it's giving the wrong input? Does anyone have any suggestions, and it comes and goes randomly??

Why don't cats get gray hair with age?.....

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 02:38 AM  4 years agoPost 2
TomC

rrKey Veteran

Gold Coast, Queensland, Australia

My Posts: All  Forum  Topic

Sounds like one of your cyclic servo gears are striped or the servo itself is failing. Also could be a loose servo arm. Maybe bench test it for 30-60 seconds with some finger-pressure and see if you notice any notchy/sloppy servo movement.

Could also be vib-related but on a 300x this normally gives you a hard left tilt, not right tilt as you described. Maybe try 1-2 layers of 3m 4011 mounting tape instead of the stock bx tape.

Cheers,
TomC

Nqx,Mcpx-BL,300x,450x,500x,550x
Ion-x, 10s ,SS
TT X50E 10s, HC3-Sx

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 02:47 AM  4 years agoPost 3
Flys4Fun

rrApprentice

new mexico

My Posts: All  Forum  Topic

A friend of mines heli ,x50, did this too all of a sudden. i flew it and it was the freakiest thing ever as it just wanted to roll right into the ground randomly and it took full stick to get it level again. We checked and all the set up on the beastx was correct and he updated it to the latest version at that time but it still did it. He eventually changed tape mounting configurations to get it to stop.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 01:36 PM  4 years agoPost 4
meowguy

rrVeteran

Saco, ME

My Posts: All  Forum  Topic

One layer of 3M 411 is all you should need under the AR7200bx on an electric heli.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 06:16 PM  4 years agoPost 5
soulrider911

rrVeteran

Novato Ca

My Posts: All  Forum  Topic

So I checked servos, all good, horns are tight went through all the bolts screws etc.. in and around the swash, all good?? last thing to try I guess is changing the mounting tape to some 3M?? this is so frustrating, why all of the sudden it would do this
THanks

Why don't cats get gray hair with age?.....

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 09:06 PM  4 years agoPost 6
soulrider911

rrVeteran

Novato Ca

My Posts: All  Forum  Topic

changed out the mounting tape, used two piece of 3m and re-ziptied the beast x, now its all good, so weird.

Why don't cats get gray hair with age?.....

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2013 10:09 PM  4 years agoPost 7
TomC

rrKey Veteran

Gold Coast, Queensland, Australia

My Posts: All  Forum  Topic

Glad to hear it's all good. Don't muck around with anything else. just fly and enjoy, lol!

Cheers,
TomC

Nqx,Mcpx-BL,300x,450x,500x,550x
Ion-x, 10s ,SS
TT X50E 10s, HC3-Sx

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2013 12:48 AM  4 years agoPost 8
Flys4Fun

rrApprentice

new mexico

My Posts: All  Forum  Topic

good deal, glad I could help

PM  EMAIL  GALLERY  Attn:RR  Quote
10-15-2013 03:56 PM  4 years agoPost 9
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

Hmm ive had a microbeast on a Trex 450 Sport do a similar thing, however each time it would kill the pitch/aileron servo! After the 3rd set of different servos, anti static leads, bearing changes etc. that unit went back to the shop!

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-15-2013 11:10 PM  4 years agoPost 10
soulrider911

rrVeteran

Novato Ca

My Posts: All  Forum  Topic

So my heli flew great for about 10 flights, then all of the sudden these issues started arising, namely this aileron roll hard to the right, changing the mounting tape out helped for about one flight, and then the issues came back.

So after lots of research and some tinkering with the 300 and the beastx, i came up to this. The beastX is very sensitive to high frequency vibrations. This can and will cause random rolling, and in some cases other issues. Im my situation, I noticed i was getting some serious motor vibrations, and some from the tail. I have since done a minor locktite mod:

Watch at YouTube

on my motor and replaced the rear tail grips with trex grips. This finally solved the vibrations and now the heli flys as it should. So for you that are experiencing a similar issue, its just a matter of tracing down the vibrations and resolving them. Hope this helps

Why don't cats get gray hair with age?.....

PM  EMAIL  GALLERY  Attn:RR  Quote
10-15-2013 11:52 PM  4 years agoPost 11
cudaboy_71

rrElite Veteran

sacramento, ca, u.s.

My Posts: All  Forum  Topic

i've had several beastx start to take off in one axis or the other. in every case it has always been a vibration issue.

you can mask it with different tape for a while. but, if it just started happening out of the blue (that is, not the result of a crash) you have a part wearing....likely a bearing or shaft. best to locate the source of the vibe and fix it, as it will only get worse and happen again...or worse fail alotgether.

eliminate the vibration and the unit will lock in again.

if it ain't broke, break it.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 1195 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › Really weird issues, random aeloron rolling out of no where?
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Friday, July 20 - 1:59 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online