RunRyder RC
WATCH
 1 page 1079 views POST REPLY
HomeAircraftHelicopterRadio - Futaba FASST › problem with CGY 750 and my New 14 SG radio Reciever , R7008SB
10-07-2013 08:43 AM  4 years agoPost 1
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

Hi , i just got in my new CGY 750 gyro and went to set it up with my New 14 SG radio with R7008SB reciever, i plugged up all servos , checked all wires , S.Bus connecting wire from gyro to S.Bus port on reciever , plugged in gyro box to 750 , all connections are correct , i have watched numerous videos on install ,, when i turn on transmitter and then reciever switch , Reciever lights up and is working ,,,,,,, THE 750 CGY , LIGHTS WITH ;;;I.D. 21787,, and below it ,,, VER. 1 : 31 , it blinks and blinks , Never see flipping Heli ,,, So The 750 has Power from Reciever but does not Link UP to Reciever , I have checked connections , 8 times , they are correct ,,, SO HOW DO I GET THE 750 TO LINK TO THE RECIEVER THAT CAME WITH MY RADIO???? , Gary Saia

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 09:23 AM  4 years agoPost 2
poerQwa

rrVeteran

Rotterdam, The Netherlands

My Posts: All  Forum  Topic

Is your receiver linked up with your TX ?
Normally the cgy (and gy gyro for that matter) does not initialize if the receiver is not correctly linked with the TX.

Do you see a steady green led on the receiver to indicate that is is linked to the TX ?
If not , check the manual on linking the 7008SB to your TX.

Regards,

Marc

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2013 09:38 AM  4 years agoPost 3
Flying Brian

rrElite Veteran

St. Clairsville, Ohio

My Posts: All  Forum  Topic

You may have your gyro sensor plugged in backwards. Try flipping that connection.

"I just don't Listen" "

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2013 10:59 AM  4 years agoPost 4
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

750 GYRO PROBLEM WITH 14 SGH RADIO
THANKS FOR FAST REPLY ,,,, MY GREEN LIGHT IS IT GREEN , STAYS ON , I HAVE PLUGGED UP ALL SERVOS DIRECT TO RECIEVER BEFORE WORKED PERFECTLY , ,,, THE GYRO SENSOR LEAD HAS A SPRING CLIP ON TOP AND ONLY GOES IN ONE WAY AND SNAPS IN PLACE , SERVOS LEAD GO IN ONE WAY WITH SIGNAL WIRE ON TOP NEXT TO LETTERING ON TOP OF GYRO , I WILL BURNING UP PHONE TOMMOROW WITH TOWER TECH LINE

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 11:17 AM  4 years agoPost 5
Flying Brian

rrElite Veteran

St. Clairsville, Ohio

My Posts: All  Forum  Topic

In my opinion, the only reason the unit would present this, is due to improper installation of S-bus harrness

Are you positive you have the s-bus lead plugged into the correct ports? If it were me, I'd un-plug everything, and only plug into power, and S-bus first.

"I just don't Listen" "

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2013 11:20 AM  4 years agoPost 6
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

problem with CGY 750 and my New 14 SG radio Reciever , R7008SB
Hi Brian , Yes on that receiver , R7008SB reciever itsays S.Bus channel 8 , yes it plugged in correctly, Gary 817-812-7050

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 11:53 AM  4 years agoPost 7
Flying Brian

rrElite Veteran

St. Clairsville, Ohio

My Posts: All  Forum  Topic

Could you possibly take a picture of your set up?

Is there a possibility of you trying a different RX?

Shooting from the hip now. Was the CGY 750 Pre-programmed, or did you install the latest software?

"I just don't Listen" "

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2013 12:42 PM  4 years agoPost 8
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

GOT IT
Brian you were right , the instruction booklet for radio and receiver , picture does not show where to plug s bus lead it is on bottom of receiver , Thanks guys

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 12:50 PM  4 years agoPost 9
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

got it
well that small receiver , and the instructions and pics do not really say where the s bus port is !!! , reverse the battery leads and s bus and works fine , thanks guys ,,,, Heli stress

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 12:54 PM  4 years agoPost 10
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

thanks guys
Brian , it does has the latest software ,, the ports on small receiver , and the instructions do no say that the S bus port is on bottom of receiver and battery leads plugs into 8 channel powered right up , you guys are great , i have been in R/c since 1978 , quit in 2001 , just got back in , wow what changes

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 12:58 PM  4 years agoPost 11
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

next gv-1 governor for my gasser
got all the settings pretty close , nexT THE GV-1 GOV FOR MY GASSER 270 ENGINE

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 01:07 PM  4 years agoPost 12
Flying Brian

rrElite Veteran

St. Clairsville, Ohio

My Posts: All  Forum  Topic

I would definitely goto the Gasser threads with this one. There is extensive information on how to properly set up GOV mode with 2 stroke gasser motors.

Glad you figured it out then.

Brian

"I just don't Listen" "

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2013 03:23 PM  4 years agoPost 13
Santiago P

rrProfessor

South West, Ohio

My Posts: All  Forum  Topic

Proud of you Brian!
Who said an ol dog cant learn new tricks? Well Done.

S

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2013 04:01 PM  4 years agoPost 14
Flying Brian

rrElite Veteran

St. Clairsville, Ohio

My Posts: All  Forum  Topic

Thanks buddy!

"I just don't Listen" "

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2013 07:32 PM  4 years agoPost 15
gary saia

rrApprentice

chandler tx usa

My Posts: All  Forum  Topic

THAN KS GUYS
WOOF WOOF

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 1079 views POST REPLY
HomeAircraftHelicopterRadio - Futaba FASST › problem with CGY 750 and my New 14 SG radio Reciever , R7008SB
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, July 17 - 3:32 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online