RunRyder RC
WATCH
 1 page 2494 views POST REPLY
HomeAircraftMulti-Rotor
e-
Multi-Rotor Main Discussion
DJI › Naza-M V1 with V2 LED Incompatibility Warning
09-16-2013 03:44 PM  5 years agoPost 1
rexxigpilot

rrProfessor

Florida

My Posts: All  Forum  Topic

Just a warning to anyone considering upgrading their Naza-M V1 with V2 components.

I was making some upgrades to my FW500 with the Naza-M V1 controller yesterday. I bought the V2 LED and PMU. I got the PMU to allow expansion of my system to include the OSD and possibly Bluetooth. The V2 PMU also has a more robust BEC compared to the V1 VU. The new LED was added so I wouldn't have the extra BEC components of the original V1 VU which is a combine BEC, LED and USB port connector. The new LED also allows more flexibility in mounting locations since it is smaller.

Well to my surprise the V2 LED doesn't work with the Naza V1. I had read that some early version V1 Nazas were incompatible with the V2 LED unless a resistor or something was used on the power or signal output pins. Most posts read that adding the LED and PMU to a V1 Naza was a simple way to upgrade the V1 to V2 and that there was no problems. Mine must be an early V1. I guess I am just a victim of being an early adopter. Now I will have to put the VU back on my FW550 to get a working LED.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-17-2013 04:38 AM  5 years agoPost 2
TMoore

rrMaster

Cookeville, TN

My Posts: All  Forum  Topic

Is there any way to tell what you have to make sure if an upgrade is possible?

Delayed Response Operator Not Engaged
AMA SECTION 336 = Good
Drones = EVIL

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-17-2013 06:11 PM  5 years agoPost 3
rexxigpilot

rrProfessor

Florida

My Posts: All  Forum  Topic

That's a good question Terry. DJI could provide serial numbers of V1 units that will and won't work with the V2 LED. However, I was not able to find this information.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-18-2013 02:47 AM  5 years agoPost 4
TMoore

rrMaster

Cookeville, TN

My Posts: All  Forum  Topic

That's a shame. It would be handy.

Delayed Response Operator Not Engaged
AMA SECTION 336 = Good
Drones = EVIL

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-21-2013 05:10 PM  5 years agoPost 5
plantone

rrVeteran

Perth wa

My Posts: All  Forum  Topic

I've got another problem, I have a new naza m v1 and when I updated it to 3.16 the vu unit will not allow the motors to start and had to change to the v2 led & pmu unit etc to get the naza m v1 to work, I was told by local dji distributer that this was the case when updating to 3.16 yet my other 2 naza m v1 units are working fine with original vu units and same software update? It seams these naza m units are not all the same ? The new one also does not have the red led glowing inside the box ? So I would think you should not have a problem.

Good luck.

Mongoose
Srimok FAI
SAB Goblin
ENV Rave Next D 450

PM  EMAIL  GALLERY  Attn:RR  Quote
09-21-2013 05:57 PM  5 years agoPost 6
rexxigpilot

rrProfessor

Florida

My Posts: All  Forum  Topic

So plantone, it appears what you're saying is that the older Naza-M V1 can be determined by whether or not you have an internal red LED with the main controller (MC) unit? You may be on to something. My V1 MC does have the internal red LED and it doesn't work with the V2 LED. However, if my MC had no internal LED it should work fine. Perhaps a few more people could verify this by weighing in on this discussion with their results.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-18-2013 01:42 PM  5 years agoPost 7
plantone

rrVeteran

Perth wa

My Posts: All  Forum  Topic

I was hoping more people would jump in here to confirm this idea? I do not know if the red led has anything to do with it or not or i have a faulty unit sorry. It seems really strange this one will not work (start motors) with the original vu yet my other 2 work fine all 3 are on the same firmware.

Mongoose
Srimok FAI
SAB Goblin
ENV Rave Next D 450

PM  EMAIL  GALLERY  Attn:RR  Quote
10-18-2013 03:21 PM  5 years agoPost 8
Dr.Tim

rrElite Veteran

Mojave Desert

My Posts: All  Forum  Topic

I will check my unit.. I did upgrade to the new LED and PMU without any issues. The NAZA works as it should.

From Simple minds come simple ideas! Approach Engineering

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 2494 views POST REPLY
HomeAircraftMulti-Rotor
e-
Multi-Rotor Main Discussion
DJI › Naza-M V1 with V2 LED Incompatibility Warning
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Wednesday, November 14 - 4:06 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online