RunRyder RC
WATCH
 1 page 628 views POST REPLY
Home✈️Aircraft🚁Helicoptere-AlignT-REX 600 › Problem with my 600E
07-23-2013 06:15 PM  6 years ago
Topic Vote0Post 1
copterklutz

rrApprentice

Western Massachusetts

MyPosts All Forum Topic
Problem with my 600E
I have one of the early TREX 600E CF helis from late 2006.
I recently converted it to FBL using the Align 3G head and Microbeast unit. It flew ok for a couple of weeks, but now I'm having an issue with the rotor disc whenever I do any type of flip or roll. The rotor disc will come out of phase and sound terrible. At first I thought it was the motor (which was a couple of years old). I put a new motor in, not a headspeed issue. The cyclic servos are original (2006) with many many flights on them. Could I have worn them out? They are Hitec 6975HB's, but maybe they don't have enough torque for a FBL setup? Also, the BEC is the original 3amp that came with the kit. Do I need to throw more amps at the servos and get new stronger servos??

thanks





" Well, Um.... it's fixable......"
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-23-2013 06:32 PM  6 years ago
rcflyerheli

rrKey Veteran

Granbury, TX USA

MyPosts All Forum Topic
I personally don't use the supplied Align switch/BEC, so I don't know if the newer units (a buddy uses them all the time on 700 sized DFC helis) have more output capability. What is the torque capability of your cyclic servos? As I recall, the phasing unit with the washout arms is a collar type that clamps down on the main shaft and lets you adjust the phasing. Check to insure that the swash to grip links are parallel to the main shaft.

As far as your servos, with the mechanical advantage of the bellcranks from the servos to the swash, I would think the servos would be strong enough, unless something else is binding.
Logo 700, Specter 700, Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-24-2013 05:34 AM  6 years ago
jsenicka

rrProfessor

Eagle River, WI

MyPosts All Forum Topic
Replace dampers first.
Then look for control slop as well
Jim Senicka
Team Manager, GrandRC Flight Team
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-25-2013 12:51 AM  6 years ago
copterklutz

rrApprentice

Western Massachusetts

MyPosts All Forum Topic
The head is new with less than a dozen flights, but I did find a little movement in one of the blade grips. I took it off and replaced the bearings and made sure the little thin spacers were back in place, it seems better now. The dampers are still tight. I'll have to fly it again and see if it's any better.




" Well, Um.... it's fixable......"
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 628 views POST REPLY
Home✈️Aircraft🚁Helicoptere-AlignT-REX 600 › Problem with my 600E
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Saturday, August 17 - 3:38 pm - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online