RunRyder RC
WATCH
 1 page 496 views POST REPLY
HomeAircraftHelicopterMain Discussion › Blue Full side Vbar and 2S rx pack.
05-29-2013 05:02 AM  5 years agoPost 1
helimax-pro

rrNovice

Brockton , MA USA

My Posts: All  Forum  Topic

I used Jive 120A on my Goblin 630 and 2S 2200mah RX pack
The RX pack come out 2 set of wire red and black, they connected to AUX and RUDD/AUX2 port for supply 8.4V to the main unit.

WOW..WOW it did not work.. all the servos gone crazy and shut of the ESC few time in the air.. lucky that I can bring it down safely..

What is wrong here ? Please help !!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
05-29-2013 07:22 AM  5 years agoPost 2
benben

rrVeteran

Taipei

My Posts: All  Forum  Topic

Did you remove the red wire from Jive?

PM  EMAIL  Attn:RR  Quote
05-29-2013 12:00 PM  5 years agoPost 3
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

You are about to fry the BEC in the Jive. Like benben said, remove the red wire from the ESC lead. Also are you running HV servos????

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
05-29-2013 01:39 PM  5 years agoPost 4
helimax-pro

rrNovice

Brockton , MA USA

My Posts: All  Forum  Topic

Yes.. I did remove the red wire
Yes.. Yes and yes .. No BEC from Jive.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-29-2013 02:52 PM  5 years agoPost 5
VANHELI

rrVeteran

Omaha,Nebraska

My Posts: All  Forum  Topic

So you were flying it successfully like this for a while and then it freaked out and shut down? If so, I would look closely at all wires for nicks or cuts and check solder joints. Maybe do a bench check with a simulated load on each and all servos.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-29-2013 03:41 PM  5 years agoPost 6
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Will you post your complete setup please???

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
05-29-2013 03:45 PM  5 years agoPost 7
Clarence Creer

rrVeteran

Fort Worth, Texas

My Posts: All  Forum  Topic

Check to make sure that your sensor is plugged in firmly.

Team Kontronik Team minicopter/PeakAircraft
VTeam EvoPowerBattery

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-30-2013 05:32 AM  5 years agoPost 8
tomvuong74

rrNovice

NE helicrew

My Posts: All  Forum  Topic

Found the problem yet ??
check all the connector and wires.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 496 views POST REPLY
HomeAircraftHelicopterMain Discussion › Blue Full side Vbar and 2S rx pack.
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Friday, August 17 - 10:16 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online