RunRyder RC
WATCH
 1 page 618 views POST REPLY
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › Ikon FBL setup tilt test fails
05-12-2013 10:51 PM  6 years ago
Topic Vote0Post 1
HeliNutAndy

rrKey Veteran

worcester, MA USA

MyPosts All Forum Topic
Ikon FBL setup tilt test fails
I am in the process of replacing my 3G unit with an Ikon FBL unit and I am pulling my hair out. When I perform the tilt test(nose up and down) the swash tilts correctly. The tail also compensates correctly. When I tilt the heli side to side or left to right the swash does not compensate correctly. The software is very intuitive and displays which way the swash should move during the test. If I reverse my Aileron servos in my TX the test works correctly but then my Aileron servos will be backwards during flight. There is a menu item to set the orientation of the FBL unit which is set correctly. I am at a loss because everything appears to be setup correctly except for the tilt test failure.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-12-2013 11:20 PM  6 years ago
HeliNutAndy

rrKey Veteran

worcester, MA USA

MyPosts All Forum Topic
I removed my full blown receiver and just went through the setup using two satellite receivers and my issue is resolved. Not sure what the problem was but I don't care now
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 618 views POST REPLY
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › Ikon FBL setup tilt test fails
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Wednesday, February 26 - 1:50 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online