RunRyder RC
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 3247 views POST REPLY
Home✈️Aircraft🚁HelicopterAlignT-REX 700N › Has anyone used an IKON w/Governor with Trex 700N?
05-09-2013 02:32 PM  6 years ago
Topic Vote0Post 1
Frankcm1

rrNovice

Richmond, VA

MyPosts All Forum Topic
Has anyone used an IKON w/Governor with Trex 700N?
Has anyone used an IKON w/Governor with Trex 700N successfully?
Frank_C
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-10-2013 01:42 AM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
I plan on using it with my 1.05 HZ-R.. Should have it flying by mid next week.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-10-2013 04:50 AM  6 years ago
kthane

rrVeteran

Pensacola

MyPosts All Forum Topic
Yes and sort of. Governor not that spectacular. After 3 weekends of monkeying with gov gains I ended with PID gains of 55,45,60 and cyclic and pitch gain both at 12.

-- End of the sort of part ---

Yes part would be that it flies fantastic. Haven't messed with any of fbl part except for upping tail gyro gain.

http://m.youtube.com/watch?v=bqrR1_3rsvo

This is before I got governor settings figured out. !!Warning!!
Regular Joe flying.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-10-2013 04:50 PM  6 years ago
Frankcm1

rrNovice

Richmond, VA

MyPosts All Forum Topic
I'm just looking for alternatives to the Silverline Vbar plus the Pro software upgrade.

I currently have the SK540 in which the Governor works great but I'm still not use to the SK540 as far as how it controls my 700N. I've flown other controllers such as BeastX, IKOn, and MiniVbar. They are doing great on the helis that I have them on but I have 1 issue with the SK540 on my 700N. When I do stationary flips the tail wants to kick out occasionally. I've played around with gain settings, re-did the linkages around cyclic. I'll keep experimenting with different things. I'm changing out my tail blades next.
Frank_C
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-10-2013 04:51 PM  6 years ago
Frankcm1

rrNovice

Richmond, VA

MyPosts All Forum Topic
Hey NQNA,

Let me know how it goes with the IKON.

Thanks,
Frank_C
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-10-2013 08:25 PM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
Sure enough!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-17-2013 10:35 PM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
Well it's all together. Waiting on some non-rainy weather and I'll give the Ikon a try.

SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-17-2013 10:38 PM  6 years ago
MoneyMike

rrNovice

corpus christi, tx usa

MyPosts All Forum Topic
Not to burst your bubble, but I tried it on my 700N and it just did not work right. I might have had to much vibrations or something, but I ended up putting on my 700E and it works great.Trex700E FBL, Trex700N FBL, Trex450 FBL
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-17-2013 10:39 PM  6 years ago
kthane

rrVeteran

Pensacola

MyPosts All Forum Topic
Wow, certainly a super neat wiring job on that one. Don't forget some hot glue or goop on the connectors.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-17-2013 11:45 PM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
If it doesn't work I'll run the Align unit.. I have a spare.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-19-2013 12:31 AM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
Well I didn't expect this result.. but see for yourself...

The governor function may not be an issue..

But maybe Ikon is the issue..

Watch at YouTube

SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-19-2013 09:58 AM  6 years ago
Frankcm1

rrNovice

Richmond, VA

MyPosts All Forum Topic
It seemed to be doing fine at first and while hovering.

What do you think caused the crash?
Frank_C
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-19-2013 10:36 PM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
It was an Ikon issue. The unit appeared to simply fail. It pitched up to vertical, then pitched back to level, then priored to the left 90 degrees and rolled 90 degrees right and dropped to the ground. I had no control during that timeframe. After the crash no servos would move. I plugged the setup into an Align unit and every thing worked correctly. It took several attempts to rebind the system and now the unit will sometimes work..
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-19-2013 11:10 PM  6 years ago
kthane

rrVeteran

Pensacola

MyPosts All Forum Topic
Wow, that sucked. That was 60 sec of airtime on that unit. You might/should be able to get it exchanged. That looked like a 1st gen unit with glued case. Case and hardware has gone through numerous changes since then. I have 2 of them. One on a raptor 50 and one on a trex 700n. None of them have done anything that stupid.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-24-2013 02:23 AM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
So far no help on my Ikon issue from the company.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-24-2013 04:02 AM  6 years ago
Frankcm1

rrNovice

Richmond, VA

MyPosts All Forum Topic
Did you get the latest firmware update on the IKON?Frank_C
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-24-2013 04:05 AM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
Yep. Clean setup with the newest off their website.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2013 06:52 PM  6 years ago
Simmer

rrElite Veteran

Massachusetts

MyPosts All Forum Topic
Sorry for your crash!

If it was the Ikon, were talking infant mortality. Not really a common event.

There are lots of things on your heli. Did you check the voltage after the crash or the rec battery?

The connectors (must be different) cause some plugs appear not all the way plugged in.

I too have emailed Ikon with a question and got no answer.

If it worked ( and it appears it did) then something did fail for sure. If you cannot get the Ikon to work after the crash, it does point to the Ikon, but simply moving things to another heli is not conclusive in my mind. Too many variables.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-29-2013 09:55 PM  6 years ago
Frankcm1

rrNovice

Richmond, VA

MyPosts All Forum Topic
Did you ever get your Ikon issue resolved?

Is the DFC 700N back kup and running?
Frank_C
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-30-2013 01:51 AM  6 years ago
NQNA

rrElite Veteran

USA

MyPosts All Forum Topic
MSHeli came through and sent me a Brain unit. It has been flying well but I don't like the nitro governor function..
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 3247 views POST REPLY
Home✈️Aircraft🚁HelicopterAlignT-REX 700N › Has anyone used an IKON w/Governor with Trex 700N?
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Sunday, February 23 - 5:21 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online