RunRyder RC
WATCH
 1 page 759 views POST REPLY
HomeAircraftHelicopter
e-
Compass
Other › Ouch.. Stupid sensor failed.. Really..
04-28-2013 05:52 PM  5 years agoPost 1
w.miller

rrVeteran

jenks, OK

My Posts: All  Forum  Topic

PM  EMAIL  GALLERY  Attn:RR  Quote
04-28-2013 07:13 PM  5 years agoPost 2
KevinB

rrKey Veteran

Saskatoon, Saskatchewan, Canada

My Posts: All  Forum  Topic

I recently had a static issue on my stretched Embla. The static hit during the first test flight was almost a mirror image of your last pass in the video with the way the heli reacted. The only difference was that I was about 50 feet higher and regained control just before the ground.

My vbar log showed a complete sensor disconnect. After adding a grounding strap between my tail boom and the frames, all the glitches and bad log entries went away.

Sorry about the crash.

KevinB

PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2013 05:21 AM  5 years agoPost 3
niyot

rrApprentice

Baltimore, Maryland

My Posts: All  Forum  Topic

Sorry about the crash . Luckily no one was injured

Hood HeLi : RIP Roman

PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2013 11:36 AM  5 years agoPost 4
onebigjunker

rrKey Veteran

Wellsville, Ks

My Posts: All  Forum  Topic

it was an ugly crash, but the flight was good till then, and you gave us something to talk about the rest of the day!

work hard, play even harder!!!!
Team Empire Hobby/GAUI USA

PM  EMAIL  GALLERY  Attn:RR  Quote
05-04-2013 07:13 PM  5 years agoPost 5
BladeScraperz

rrApprentice

Nor Cal

My Posts: All  Forum  Topic

Sorry to hear about the crash.. keeps things interesting no doubt..

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 759 views POST REPLY
HomeAircraftHelicopter
e-
Compass
Other › Ouch.. Stupid sensor failed.. Really..
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Wednesday, August 22 - 6:37 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online