RunRyder RC
WATCH
 1 page 519 views POST REPLY
HomeAircraftHelicopterMain Discussion › Blade 450x ds92a+ servo problem
02-20-2013 09:55 PM  5 years agoPost 1
stormheli

rrNovice

Dublin, New Hampshire

My Posts: All  Forum  Topic

Hello,
My left aileron servo is acting very strange it is a Mks Ds92a+ im running a ar7200bx, It is moving up and down very quickly as soon as its plugged in and even after the gyro is initialized it only gets worse I've tried unplugging and plugging back in all the servos, calling the local hobby store and rebinding the helicopter, but strangely nothing has worked, has anyone found a solution to this or had the same problem?

Trex 700e dfc(BeastX) Gaui Nx4 (Ikon fbl) Spektrum dx8 tx

PM  EMAIL  GALLERY  Attn:RR  Quote
02-21-2013 05:26 AM  5 years agoPost 2
Solmanbandit

rrElite Veteran

Tucson , AZ

My Posts: All  Forum  Topic

Sounds like you either have gear damage or your potentiometer has gone bad. Most likely the pot went bad which means you have to replace the servo.

Trex 700E / Trex 500 ESP - Ikon/ HD 500 - Ikon 2/ Goblin 500 Ikon 2

PM  EMAIL  GALLERY  Attn:RR  Quote
02-21-2013 12:02 PM  5 years agoPost 3
stormheli

rrNovice

Dublin, New Hampshire

My Posts: All  Forum  Topic

The gear is fine i guess ill have to get a new servo then ty for your reply.

Trex 700e dfc(BeastX) Gaui Nx4 (Ikon fbl) Spektrum dx8 tx

PM  EMAIL  GALLERY  Attn:RR  Quote
02-21-2013 04:01 PM  5 years agoPost 4
Solmanbandit

rrElite Veteran

Tucson , AZ

My Posts: All  Forum  Topic

plug another servo into the port to make sure it is the servo. Also if the servo is bad, save the gears in the servo.

Trex 700E / Trex 500 ESP - Ikon/ HD 500 - Ikon 2/ Goblin 500 Ikon 2

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 519 views POST REPLY
HomeAircraftHelicopterMain Discussion › Blade 450x ds92a+ servo problem
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, July 17 - 10:33 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online