RunRyder RC
WATCH
 1 page 1893 views POST REPLY
Home✈️Aircraft🚁Helicoptere-MSH Protos, Mini Protos › Protos 500 Main Rotor Blade Holder Issue
01-08-2013 08:49 PM  7 years ago
Topic Vote0Post 1
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Protos 500 Main Rotor Blade Holder Issue
I am in the middle of building a new Ptotos 500 and can't seem to get the blade holders to rotate freely on the spindle. I was able to get one of the holders included in the kit to rotate smooth and free but the other not. I purchased a second set of blade holders and am still having the same issue. Is there a metal grip upgrade that works better? Or is there a trick to making the plastic ones work correctly?
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-09-2013 05:06 AM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
Mine rotate freely . The plastic usually work fine. Check your installation of the bearings ?
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-09-2013 05:25 AM  7 years ago
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Bearings
I have checked and double checked the bearings. On two sets of grips with the same issue. Was only asking about metal as a possible solution. Would rather run with the plastic if possible. Just no luck yet.
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-09-2013 05:30 AM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
There are two spindles. One for FB and on for FBL. The FBL is longer. Could it be you have the wrong one ? Is it tight when you slide it onto the shaft or after you tighten the bolts ?
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-09-2013 03:51 PM  7 years ago
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Spindle
I made double sure I had the correct spindle in. It is tight as soon as I slide it on.
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-09-2013 05:48 PM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
If it is tight as soon as you slide it on it must be the bearings or the spindle shaft not the blade holder. Try putting the tight one on the other side of the shaft and vise versa to see if that make any difference. If it is tight on both sides and the other one is loose on both sides it must be a bearing or spacer.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-09-2013 09:02 PM  7 years ago
jdanks

rrApprentice

OREGON

MyPosts All Forum Topic
Make sure the thrust bearing are lubed well and ordinated the correct direction. larger inside diameter should go on the inside, smaller ID to the outside.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-10-2013 03:28 AM  7 years ago
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Spindle
Thanks for all the replies. I think it is a combo issue. The spindle in the flybarless upgrade works ok with both grips on one end but not on the other. I also think I have some bad bearings with the replacement grips.
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-10-2013 01:32 PM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
Is there a burr or something on one side of the shaft ? Maybe mic the shaft on each end ? If not order new bearings and a FBL spindle shaft and try again.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-11-2013 01:58 AM  7 years ago
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Bearings
Thanks for all the help. Helidirect is sending out a new shaft and bearings. Hope that solves the issue.
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-11-2013 02:28 AM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
Cool should solve the issue. Let us know how you make out.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-13-2013 03:47 AM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
There is a guy on Heli Freak with the same issue. The bearings seem to be the problem. Out of round ? or something. You could try Boca Bearings.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-13-2013 04:11 AM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-13-2013 10:08 PM  7 years ago
prillernut

rrNovice

Chapel Hill, NC, USA

MyPosts All Forum Topic
Hey snbartley, Freeskiken mentioned your problem in my thread over on HF. I've found two bearings that were bad; the inner race I.D. was either too small or out of round on one of my tail rotor shaft bearings and on one of my thrusted tail rotor grip radial bearings. Glad to hear HeliDirect is helping you out I thought about getting in touch with my vendor, but I figured I'd just go ahead and get some bearings from Boca -Tony
SHARE  PM  EMAIL  Attn:RR  Quote
01-15-2013 12:15 AM  7 years ago
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Awesome help
Thanks for all the info. Helidirect was good about shipping replacements out but unfortunately that did not fix the issue. Out of a dozen bearings I was able to find only about half that I could use. And once the grips are placed on the spindle they bind up still and get even worse when tightened down. Checked and double checked setup again. Still no functioning head. Very frustrated. Guess I will order up some boca bearings and see if that helps. My tail bearings seem to be fine so won't mess with them at this point.

Any other ideas I am open to try suggestions.

Scott
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-15-2013 12:32 AM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
I would be frustrated as well. Are you using the same shaft ? Do the bearings slide on the shaft by themselfs. Not in the grips ?

Sure looks like a quality issue with the bearings. Order some Boca bearings and try that. Keep us posted.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-15-2013 12:37 AM  7 years ago
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Bearings
Went ahead and ordered the boca upgrades. Will see if that fixes the issue. Sure hope so.

Scott
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-15-2013 01:37 AM  7 years ago
snbartley

rrApprentice

Eugene, Oregon

MyPosts All Forum Topic
Bearings and shafts
I have tried two different shafts now with the same results. Plus tried to use the best of the dozen bearings I have now. No matter what it still binds. As for slipping on the shaft withou the grips yes they do. That was one of the tests I did to eliminate some of the bearings. If they did not slide on freely I put them aside and did not even try them. One grip moves good not just slid on spindle the other drags and both once mounted and bolts on both sides are not free. They move but not freely like they should.

Scott
You Can Not Reason With Crazy People
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-15-2013 02:32 AM  7 years ago
Freeskiken

rrApprentice

Edmonton, Alberta, Canada

MyPosts All Forum Topic
Well I hope the Boca bearings fix the problem !!
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-31-2013 05:36 PM  7 years ago
ICUR1-2

rrElite Veteran

Ottawa, Ontario

MyPosts All Forum Topic
💎Sustaining Member
there are 2 differant size of spacer that go between grip and dampner

make sure you use right one for spindle or it will bind
spending time, paying attention
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1893 views POST REPLY
Home✈️Aircraft🚁Helicoptere-MSH Protos, Mini Protos › Protos 500 Main Rotor Blade Holder Issue
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Sunday, April 5 - 1:12 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online