RunRyder RC
WATCH
 1 page 1641 views POST REPLY
HomeAircraftHelicopterRadio - Spektrum DSM › Using Lipo in DX8 not charging fully.
10-09-2012 02:24 PM  5 years agoPost 1
meowguy

rrVeteran

Saco, ME

My Posts: All  Forum  Topic

I have two DX8s and I first put a Spektrum lipo in one of them back in Jan. It works as designed. When the lipo is fully charged the logo light goes out at 8.2v.

Bought the second DX8 last month. Also installed the Spektrum brand lipo. Charged for over 30 hours. The logo lamp never goes out. Swapped the battery over to the first DX8. Charged again, light does not go out. So it's not a problem in the TX, it's the battery.

Sent battery back to horizon. They replaced it. Replacement battery light does not go out after charging.

Have two other lipos; Turnigy and Lectron both batteries work as designed in either radio, when fully charged the logo light goes out.

What is going on with the newer Spektrum batteries? Is this a new shipment that contains low performing batteries that will not fully charge in the transmitter?

I have discharged the bad performer to storage charge and recharged several times. This had no effect. Voltmeter on TX reads 8.2 which is correct but light never goes.

Anyone else having this problem, or found a solution other than using a different brand?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-09-2012 04:19 PM  5 years agoPost 2
BigMc70

rrApprentice

Abilene, Texas-USA

My Posts: All  Forum  Topic

I have left my dx8 with spectrum lipo on the charger for three days and my light never went off plus it was extreamly warm. Any info would really be helpful before I damage my radio or home.

Raymond McFaul
Team Grand RC

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-10-2012 10:33 PM  5 years agoPost 3
meowguy

rrVeteran

Saco, ME

My Posts: All  Forum  Topic

Your battery is defective. The battery contains the circuitry that tells the charger to turn-off. This is my problem and I am getting a new battery to try again.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-11-2012 07:46 PM  5 years agoPost 4
Auddiss

rrNovice

CT

My Posts: All  Forum  Topic

The logo light on my dx8 stopped working, but the lipo will go to 8.2v So in assuming everything is good. I've had good luck with turnigy batteries

PM  EMAIL  GALLERY  Attn:RR  Quote
10-11-2012 11:25 PM  5 years agoPost 5
meowguy

rrVeteran

Saco, ME

My Posts: All  Forum  Topic

Does the light work when charging the original NIMH? If so, then you have a problem with the Lipo. I have a Turnigy lipo as well it works the way it should.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-12-2012 05:49 PM  5 years agoPost 6
Auddiss

rrNovice

CT

My Posts: All  Forum  Topic

I'm not to sure i will have to try putting the orginal battety back in, the light will work orange when not charging its the blue light that won't come on at all but it does charge the battery.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-04-2013 05:30 PM  5 years agoPost 7
stubbs

rrApprentice

Tuscon, AZ

My Posts: All  Forum  Topic

These Spektrum lipo batteries are crap...plain and simple... I had three of them after Horizon sent me two replacements. They didn't want the others back in the mail since it's their policy to never have anyone return lipos. I gave all three Spektrum lipos to a club buddy of mine to try in his DX8 and not one of them shut off his charge light, either, despite being left on the stock charger for days. How nice that they advertise a feature...that doesn't work...

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1641 views POST REPLY
HomeAircraftHelicopterRadio - Spektrum DSM › Using Lipo in DX8 not charging fully.
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, August 21 - 7:12 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online