RunRyder RC
WATCH
 1 page 3096 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsSpektrum › AR7200BX setup issue
10-08-2012 06:02 PM  5 years agoPost 1
NQNA

rrElite Veteran

USA

My Posts: All  Forum  Topic

During setup In step G the swashplate is level and the blade pitch reads 0 degrees. When I get to step J the blade pitch jumps to 1.4 degrees. It should not do that.. Any ideas?

Looks like you need to set 0 in the J screen..

PM  EMAIL  GALLERY  Attn:RR  Quote
10-09-2012 02:05 AM  5 years agoPost 2
AWittleWabbit

rrElite Veteran

O.C., CA

My Posts: All  Forum  Topic

G does set center.

Maybe something not at 0 in the x'mitter. I dont remember if the collective works during step j. If it does, do you have 50% at half stick? (Pitch curve)

Heli-itis sufferer.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-09-2012 05:16 PM  5 years agoPost 3
helismash

rrKey Veteran

Gloversville, NY - Fulton

My Posts: All  Forum  Topic

Ron Lund has made some great video's. Here is a link to the one you want I think. There is also a video for step J.

Watch at YouTube

Hey, Who put the ground there!
T-Rex 500/T-Rex 600N FBL/T-Rex 600E PRO/T-Rex 700N/T-Rex 700FBL

PM  EMAIL  GALLERY  Attn:RR  Quote
11-11-2012 06:07 PM  5 years agoPost 4
ttaylor63

rrApprentice

Floresville,Tx

My Posts: All  Forum  Topic

I had same issue in step G. Had 0 degrees pitch. But in step J I had -1 pitch.. In step G you have to have either the blue,red or purple lites on eh Ron setting 0 pitch.. Then in step J it will be same..

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 3096 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsSpektrum › AR7200BX setup issue
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Saturday, August 18 - 11:13 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online