RunRyder RC
WATCH
 1 page 495 views POST REPLY
HomeAircraftHelicopterMain Discussion › Help with loss of head speed.
08-09-2012 06:47 AM  6 years agoPost 1
Galkor

rrNovice

wellington New Zealand

My Posts: All  Forum  Topic

I run a trex 600 nitro with a os5 sx engine. I have the gov setup to give me a head speed of around 2000rpm. In my set up I am running a +10 to -6deg pitch. The problem is when i run norm mode i have lots of punch and gain height very fast but when i go into idle up 1 and punch it of into fast forward flight and then pull back to get height and then follow threw with a big loop on the down part of the loop as i pull out the head almost losses it speed almost stalling out. I am unsure if its because I am not backing of on the throttle/pitch (ie going full noise) or if its tuning or sum-thing else. The motor still isnt getting up very hot the backing plate is just getting warm but not hot. I run 20% with cool power blue. Any help would be awesome.
Happy flying.

Planes are for those who cant fly helis.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-09-2012 10:50 AM  6 years agoPost 2
wrongler

rrProfessor

Brewerton, New York

My Posts: All  Forum  Topic

We had a club member that had something simular, All he did was a little more tuning on the motor and tried different Main Blades until it didn't Bog as much. He said the right main blades made the biggest difference.

Bill Whittaker

PM  EMAIL  GALLERY  Attn:RR  Quote
08-09-2012 12:41 PM  6 years agoPost 3
airdodger

rrElite Veteran

Johnston USA

My Posts: All  Forum  Topic

You sure the gov is working? Try a pitch curve and see what happens.

Chris

PM  EMAIL  GALLERY  Attn:RR  Quote
08-17-2012 09:55 PM  6 years agoPost 4
Galkor

rrNovice

wellington New Zealand

My Posts: All  Forum  Topic

I use the align 3g carbon blades and the gov does work. could it be that I am just putting a huge load on the head? I have also been having trouble tuning the eng. its a OS 50sx hyper.

Planes are for those who cant fly helis.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-17-2012 10:19 PM  6 years agoPost 5
JKos

rrProfessor

Redondo Beach, CA

My Posts: All  Forum  Topic

I am unsure if its because I am not backing of on the throttle/pitch (ie going full noise) or if its tuning or sum-thing else.
What exactly do you mean by "going full noise"? How do you have your throttle curve set in your Idle Up flight mode(s)?

Thanks,
John

PM  EMAIL  GALLERY  Attn:RR  Quote
08-17-2012 10:21 PM  6 years agoPost 6
co_rotorhead

rrVeteran

Centennial, CO, USA

My Posts: All  Forum  Topic

Try going to 0 degrees collective pitch at the apex and through the back side of the loop, then begin feeding in collective as you level out --but not all at once. It sounds like you're going into the loop with a lot of pitch, which is fine, but you need to back off at the apex and through the downline to keep from bogging when you level out.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 495 views POST REPLY
HomeAircraftHelicopterMain Discussion › Help with loss of head speed.
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Saturday, August 18 - 1:22 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online