RunRyder RC
WATCH
 1 page 776 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Servo - Gyro - Gov - Batt › GENS BATTERY 6S 5300mAh HELP
06-05-2012 03:11 PM  9 years ago
Topic Vote0Post 1
TECO

rrVeteran

WARWICK RI, USA

MyPosts All Forum Topic
GENS BATTERY 6S 5300mAh HELP
I'TS been about 2 months that a full charge this battery,(its brand new) yesterday i went to do some work on my 700E and noticed that the balance plug had some green corrosion, i so a checked the batt and the cells are ok, but put on my charger and gives me an error saying thats is 5s, i can charger or descharger without the balance plug,

what you guys thing?
any help?

Richard
"Never argue with an idiot - he'll drag you down to his level and beat you with experience
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-05-2012 04:12 PM  9 years ago
doorman

rrProfessor

Sherwood, Arkansas

MyPosts All Forum Topic
💎Sustaining Member
Low Cell Voltage
If you set your charger to 5s for about 2-3 minutes normal charge with your balance leads attached, that should bring the pack voltage back up to at least the minimum.. then check the balance of the pack and put it on the proper 6s charge rate and keep an eye on it while charging (cell voltages) to make sure that they are all coming up equally...and always charge in a fireproof container, just in case something goes wrong, or outside!!!!!
That should get you going again...

Stan
AMA 2918-Team Spin Blades,,Castle Creations, Unique Aircraft
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 03:11 PM  9 years ago
TECO

rrVeteran

WARWICK RI, USA

MyPosts All Forum Topic
hi?
i tried that too, did worked, i can descharge and charge using the power cables, but when i plug the balance lead shows me output battery connect error,,,,,i descharge and charge it again and check the cells and they are equal,
what should i do now? is the balance lead went bad?

"Never argue with an idiot - he'll drag you down to his level and beat you with experience
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 03:35 PM  9 years ago
doorman

rrProfessor

Sherwood, Arkansas

MyPosts All Forum Topic
💎Sustaining Member
????
If you are able to charge and discharge without the balance board, and get equal cell readings (4.18 to 4.20v on all 6 cells), then I would have to say that either the balance board or something in the charge/balance of the charger is going bad..I..would go for the balance board first.. Do you have a flying buddy that can try it on his charger???
Is your charger a dual charge type?? If so make sure you are using the proper output and balance socket channel.. (bet you can guess how I know about this one!!!)

Good Luck, Stan
AMA 2918-Team Spin Blades,,Castle Creations, Unique Aircraft
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 03:37 PM  9 years ago
3dgimble

rrKey Veteran

Rochester

MyPosts All Forum Topic
If you can still warranty that Lipo, send it back, two months on a lipo is bad, very bad, send it back you wont have much life left on that lipo.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 03:37 PM  9 years ago
TECO

rrVeteran

WARWICK RI, USA

MyPosts All Forum Topic
hahah,i will meet my friend in a few minutes, try his charger, and i give some update later

thanks for now

teco
"Never argue with an idiot - he'll drag you down to his level and beat you with experience
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 03:52 PM  9 years ago
MichiganFlyer

rrElite Veteran

Lansing,MI

MyPosts All Forum Topic
That green corrosion is moisture. Moisture is connecting two of your cells and your charger is seeing 5S and not 6S. If you clean everything on your balance plug and still have a 5S reading then there is moisture in the pack causing the problem.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 06:12 PM  9 years ago
TECO

rrVeteran

WARWICK RI, USA

MyPosts All Forum Topic
thats right!! i change the balance lead and now is reading 6S, i'm gonna descharger and put in store mode

thanks a lot guys
teco
"Never argue with an idiot - he'll drag you down to his level and beat you with experience
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 07:28 PM  9 years ago
doorman

rrProfessor

Sherwood, Arkansas

MyPosts All Forum Topic
💎Sustaining Member
Good News
Glad to hear you were able to determine the problem... that is what this forum is about..
Thanks for letting us know... Stan
AMA 2918-Team Spin Blades,,Castle Creations, Unique Aircraft
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-07-2012 07:50 PM  9 years ago
TECO

rrVeteran

WARWICK RI, USA

MyPosts All Forum Topic
Yeah men, i was about To give it ip with this brand new $100 batt, i callded hobyparts they told these batts only has 30 days waranty , she is good now, got try át. The field now.
I love RR. A lot, and ita always good To save the old batts

Teco
"Never argue with an idiot - he'll drag you down to his level and beat you with experience
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 776 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Servo - Gyro - Gov - Batt › GENS BATTERY 6S 5300mAh HELP
Print TOPIC

 3  Topic Subscribe

Tuesday, June 22 - 8:03 am - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online