RunRyder RC
WATCH
 1 page 615 views POST REPLY
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › Outrage 50N2 Head and Thrust bearing issue
04-02-2012 02:09 AM  7 years ago
Topic Vote0Post 1
waspaloy

rrNovice

Venetia Pa

MyPosts All Forum Topic
Outrage 50N2 Head and Thrust bearing issue
Has anybody had ant issues with the outrage 50n2 head system. Had a bad vibration. Skids shaking violently. Checked all shafts MAIN, FEATHER, STARTER AND ALL ARE STRAIGHT. Took the thrust (washers) out of the blade grip and the thing runs clean and smooth. Seems the thrust washers was riding up on the inner ( Larger ID thrust washer ) and clamping on it. Taking them out was the fix but dont remember seeing anything on Runryder of that being a problem for anyone. Anybody else had this problem. Tried everything I can think of to get them to work while there in. Have grease in the thrust bearing. Pushed in on the dampers to make sure there in all the way. Have less then a 1/2 mm play in the Feathering system with the washers out but no play and very tight with washer in. Any thoughts from any Outrage 50n2 owners.
SHARE  PM  EMAIL  Attn:RR  Quote
04-03-2012 05:16 AM  7 years ago
waspaloy

rrNovice

Venetia Pa

MyPosts All Forum Topic
Wow no feed back on this. How about how much play can there be in the feather shaft before its a problem. With my thrust washers in its too tight and and you feel friction when turning the blade grips and shakes pretty good in flight. Thrust wahers about 1/2 mm each. With them out there is less then 1/2 mm of play. Seems to run fine with them out and at this point just going to leave them out. Outrage pilots are putting them in or I would of heard there was a problem. Maybe feathering shaft cut a MM short or something in the head system not up to spec. Just trying to get it the best I can and go fly the thing. Never ran into this problem before and just looking for a little info about this so I understand. Any info would be helpful at this point.
SHARE  PM  EMAIL  Attn:RR  Quote
04-03-2012 02:05 PM  7 years ago
jonathan

rrNovice

italy, rome

MyPosts All Forum Topic
hi. I had the same problem but let the bearings in even though a bit tight. Mainly because if you pull on each end of the grips then they turn freely and as the blades when spinning pull by nature, then it shouldnt be a problem
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-03-2012 04:06 PM  7 years ago
waspaloy

rrNovice

Venetia Pa

MyPosts All Forum Topic
Thanks for the reply Jon. Actually I forgot to put them ( Thrust washers) in from the start. Had vibration issues but from another problem and fixed it. Its only when I found that I missed that ( Putting in the thrust washers ) in the build and put them in that the heli was virbating pretty good and took them out and it was fine. Going to rip the head apart tonight and look at it again. My thought is how much play is too much. Read some place anything under a 1/2 mm ok and over not good so Im just trying to feel everybody out on there thoughts. I can see the heli when Im hovering and its fine with out the washers and a little play but I dont know whats its doing up in the air putting alot of + and - collective into it. Just trying to gain a little knowledge because knowledge is key in this hobby.
Thanks
SHARE  PM  EMAIL  Attn:RR  Quote
04-03-2012 04:29 PM  7 years ago
AltecLansing

rrElite Veteran

North Carolina

MyPosts All Forum Topic
I don't have the n2. I do have a velocity 50. Did you try new thrust washers? I had one set in the bag that was bad.Man, I miss the eighties.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-04-2012 03:10 AM  7 years ago
waspaloy

rrNovice

Venetia Pa

MyPosts All Forum Topic
Its not the thrust bearing. Think you might of miss understood me. Its the thrust washer. Thin brass washer ( 1/2 mm ) that goes in before the thrust bearing. Not much that can go bad with them. Checked the thickness and its what its supposed to be. Took the head apart tonight. Check everything. Everything looks and feels good. Used a differant grease on the thrust bearing when I put it back together. Grease I was using seemed a little thin. Going to fire it up tomorrow and if its still shaking im taking them out and flying till I get it figured out. Only reason Im trying to get it to work with them in is because I having a very small blade tracking problem with them out. Hovers good with them out and much smoother than if they were in. Seems ok in the air but dont really know for sure cause I cant see things shaking up and away from me. Thanks for your your reply
SHARE  PM  EMAIL  Attn:RR  Quote
04-04-2012 03:24 AM  7 years ago
waspaloy

rrNovice

Venetia Pa

MyPosts All Forum Topic
Just relized you think I should replace the thrust bearings cause they might be bad. They look good. Feel good. Maybe Ill try that if this dont work for the hell of it. i think there fine but you never know. Thanks for the feed back
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 615 views POST REPLY
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › Outrage 50N2 Head and Thrust bearing issue
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Sunday, August 25 - 9:55 am - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online