RunRyder RC
WATCH
 1 page 1181 views POST REPLY
Home✈️Aircraft🚁Helicoptere-MikadoOther › 600SE tail breaks on hard manouvres
04-01-2012 11:32 PM  7 years ago
Topic Vote0Post 1
Reesy

rrKey Veteran

In the doghouse ... Nottingham UK

MyPosts All Forum Topic
600SE tail breaks on hard manouvres
Hello chaps

Having a bit of a problem with my 600SE slight gentle tail wag (suggesting too low gain?) and tail breaks through 90deg if I bang in the collective when inverted.

VBAR 5.2 with tail gain @ 105 which looks a bit high on the scale mikado suggest which makes me think I'm barking up the wrong tree?

12S Pyro440 12T 690blade @ 70% throttle Jive mode4
BLS251 tail servo with everything else stock
Anti static jobbies fitted

I've gone through it till I'm blue in the face, my 500SE (550 blades tango 45/10 7S) flies as sweet as a nut and practically silent

The 600SE makes more noise but nothing I can do makes it super quiet so assume that's normal?

I added the note on my 500SE just to point out I am familiar with setting up a VBAR unless I'm missing something going from a 500SE to a 600SE?

I have 5 heli's flying VBAR's in all and only the 600 tail won't hold.

I could keep raising the gain but it just looks "wrong" on the scale mikado suggest.

I'm on my third motor:
First was a scorp 5025/440 on 12S which gave me no end of grief
Second was the mikado/scorp on 10S which flew OK but got hotter than I was comfortable with.
The pyro on 12S is tons better smooth and much cooler but the tail just isn't locked. (wasn't on any of them)

Any help appreciated

EDIT
I've just read the Johnny eagle thread a few down so no need to repeat that stuff just need to know if my gain settings of 105 are too high or should I be looking in another direction?
Paul
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-01-2012 11:50 PM  7 years ago
wrongler

rrProfessor

Brewerton, New York

MyPosts All Forum Topic
What size tail blades? I use 105's on my 600 SE and they hold well.Bill Whittaker
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-02-2012 12:12 AM  7 years ago
Reesy

rrKey Veteran

In the doghouse ... Nottingham UK

MyPosts All Forum Topic
Hi wrongler

Thanks for the reply as I said everything is stock from the SE kit
Paul
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-02-2012 01:42 AM  7 years ago
gravydrive

rrApprentice

Jacksonville, FL

MyPosts All Forum Topic
Thanks for the reply as I said everything is stock from the SE kit
Reesy, please advise, my 600SE did not come with tail blades and to my knowledge, they haven't started including them. I'm using Edge 105's, tail gain at 110 with great behavior!

From the 600SE product page:
Note:
Mikado LOGO kits do not come with a pinion, tail blades, or main blades. You must choose your own pinion that matches your motor to obtain the headspeed that you desire. Please use our headspeed calculator if you need help figuring out what pinion you need!
Murphy's Law Denier
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-02-2012 10:13 AM  7 years ago
Reesy

rrKey Veteran

In the doghouse ... Nottingham UK

MyPosts All Forum Topic
Hello chaps

Strange? mine had standard looking mikado white plastic tailblades the kind shown in the manual on page4 (2 tail rotor) with the curved tips rather than the slightly squarer looking blades shown on pages 5+6

Manual describes them as edge 95 allthough they measure 90mm from tip to centre of bolt.

Never crossed my mind to try alternatives as all my logo's in the past (I actually began with a logo10 on nicads) seem to have preferred stock mikado over say carbons and suchlike.

Slightly different issue I'd not considered is an "out of round" main gear likely with these? never considered the possibility with my smaller logo's as they all seem super smooth but this has a "noise" I can't pin down, not exactly a clicking more of a beat if that makes sense.
Paul
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-02-2012 11:27 AM  7 years ago
dhoffack

rrApprentice

lanham, md, MHA member

MyPosts All Forum Topic
Reesy,

You definetly need a nice set of carbon fiber tail blades for the logo 600se. The plastic tail blades will just flex too much and not have enough tail power, with the logo 600se disc size (690 blades).

Consider buying a set of edge tail blades.

Dan
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-02-2012 05:55 PM  7 years ago
Reesy

rrKey Veteran

In the doghouse ... Nottingham UK

MyPosts All Forum Topic
Thanks for the replies chaps yes it's new tail blades for me, when I remeasured them the ones I have are more like 87mm so not going to cut it as you say.Paul
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-02-2012 11:58 PM  7 years ago
ElectricSheep

rrApprentice

Orange County, CA - USA

MyPosts All Forum Topic
Good move -- after you put 105s on there you won't have any problems. I'm actually amazed that 87mm blades didn't give you more problems; even 95mm would cause issues when I flew with 640mm blades on a 600 3D.
SHARE  PM  EMAIL  Attn:RR  Quote
04-03-2012 01:10 AM  7 years ago
wrongler

rrProfessor

Brewerton, New York

MyPosts All Forum Topic
Bingo!Bill Whittaker
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-03-2012 01:50 AM  7 years ago
cdrking

rrElite Veteran

Seattle

MyPosts All Forum Topic
Do you also have the Quick UK upgraded tail hub?To hover is divine, the alternative is rather PLANE.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-06-2012 11:21 PM  7 years ago
Reesy

rrKey Veteran

In the doghouse ... Nottingham UK

MyPosts All Forum Topic
Thanks for the replies guys

Took myself off to my local model emporium and picked up a QuickUK tail hub and a pair of Rail 106 tailblades (doubt I can fly well enough to tell between them and say Edge but they looked kinda sexy)

Dropped gain to 100 just to be on the safe side and now waiting to try them out.
Paul
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-13-2012 04:23 AM  7 years ago
ElectricSheep

rrApprentice

Orange County, CA - USA

MyPosts All Forum Topic
@Reesy, How'd everything work out with those 106mm CF blades?

I'd be *very* surprised if your problem wasn't solved by swapping out the plastic blades.
SHARE  PM  EMAIL  Attn:RR  Quote
04-14-2012 10:02 AM  7 years ago
Reesy

rrKey Veteran

In the doghouse ... Nottingham UK

MyPosts All Forum Topic
Ay up
Huge improvement

Tail still has a slight "lazy" wag @ 100 on the Vbar setting but haven't had chance to try higher and lower values yet but heli just feels ton's more "sim" like.

It had a funny feel which took me a while to nail, the QuickUK tail jobbie is quite heavy and altered the CoG backwards by the time I figured it light was going but all in all really happy.

thanks for the input guys
Paul
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1181 views POST REPLY
Home✈️Aircraft🚁Helicoptere-MikadoOther › 600SE tail breaks on hard manouvres
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Saturday, August 17 - 4:11 pm - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online