RunRyder RC
WATCH
 1 page 718 views POST REPLY
HomeAircraftHelicopterGasser Model RC HelicoptersOther › new kalt gasser ,, massive radio glitch ""
03-09-2012 08:35 AM  6 years agoPost 1
chopperbloke

rrApprentice

portsmouth hampshire uk

My Posts: All  Forum  Topic

hello again all,hope all is well.

as per old post i have restored a kalt baron 11 gasser,looks good i have to say.But there is a massive radio glitch? and this is without the engine running i have never seen this before on any gasser,you would expect this yes if the motor was running ,At one point the rudder became the pitch????????,,i have changed the rx,and battery and tried another servo???????????????::: has any one come accross anything like this before,,,,

cheers all.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-09-2012 09:58 AM  6 years agoPost 2
shawmcky

rrElite Veteran

Isle of Wight,United Kingdom

My Posts: All  Forum  Topic

Edit

Team- unbiased opinion.K.I.S.S principle upheld here

PM  EMAIL  GALLERY  Attn:RR  Quote
03-09-2012 10:19 AM  6 years agoPost 3
Dimitris76

rrApprentice

Carmel, IN

My Posts: All  Forum  Topic

If the engine is running then it's NOT gasser's fault.

What band are you using? 2.4Ghz or 35Mhz? Is this a vintage radio too? Has it been involved in a crash? Is the transmitter battery pack in good health? The antenna fully extented? Matching crystals in Tx and Rx?

Plug in a freshly charged battery pack on the receiver and all the servo's and gyro that you will use and do a proper range check. Wingle all the cables and connectors, make sure you don't have an intermittent connection somewhere.

If you are not on PCM modulation with failsafe function, you can turn off the Tx and observe how the servos behave for a few minutes.
Any local intereference sources? Microwave ovens? Large electric motors, etc?

Hope this helps,
Dimitris

PM  EMAIL  Attn:RR  Quote
03-09-2012 03:10 PM  6 years agoPost 4
GMPheli

rrElite Veteran

W. Bridgewater, MA USA

My Posts: All  Forum  Topic

I recently built a Hirobo Freya that I picked up for cheap money. Threw in old electronics I had laying around. 9202 servos, Arcamax gyro, 9254 on the tail, Futaba PCM receiver. When I started flying it around, the engine kept quitting, and then coming back. I thought at first it was the engine, but it turns out it was going into failsafe. Put an fm receiver in it and it was glitching like crazy even without the engine running. As soon as I disconnected the gyro, the glitching stopped. Tried a different gyro, same thing. Plugged a different tail servo in, and everything was fine. Mounted the new tail servo and the glitching came back! Took the tail servo out but left it connected. If I moved the boom mounted tail servo closer to the gyro, the glitching disappeared. Back to the boom and the glitching came back. Turns out (I guess) that the position of the tail mounted servo was just the right length that the servo/gyro wires acted as an antenna. Switched to 2.4 and all seems well, although I have not flown it yet, waiting for good weather. Just something for you to check, don't know if you are on 2.4 or not. Good Luck!

PM  EMAIL  GALLERY  Attn:RR  Quote
03-18-2012 04:04 AM  6 years agoPost 5
YSRRider

rrElite Veteran

usa

My Posts: All  Forum  Topic

Could be a bad crystal or receiver. There were many issues with wires running on carbon tubes giving issues as GMP stated...... Do not zip tie wires or your antenna onto graphite.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 718 views POST REPLY
HomeAircraftHelicopterGasser Model RC HelicoptersOther › new kalt gasser ,, massive radio glitch ""
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Monday, July 16 - 6:14 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online