RunRyder RC
WATCH
 1 page 1905 views Post Reply
Home✈️Aircraft🚁HelicopterAlignT-REX 600N › First flight with beastx and tracx head ( didnt go well)
03-01-2012 11:52 PM  9 years ago
Topic Vote0Post 1
ronmad02

rrApprentice

TOLEDO

MyPosts All Forum Topic
First flight with beastx and tracx head ( didnt go well)
Well I am looking for some pointers, I flew my 600n that I just set up with the beastx and a tracx600 fbl head setup was uneventful and all looked good triple checked all inputs and outputs all worked fine. I mounted the beastx uptop in the front above the servos. I used one of the white foam pads that came with it. Started motor up and spooled it up slow tracking looked good tail held ok a slight wag with it but head speed was still low. everything looked good so I went for the first hover got it up about 8 feet or so and was getting use to the controls trying to see if I need to make any adjustments it was holding very nice. I was liking it. then the not so good thing happened. the heli rolled to the left and went right into the ground. This all happened in a fraction of a second. I tryed to roll right and nothing happened. I was only 8 feet off the ground sonot to much damage, blades, landing gear, canopy, maybe feathring shaft and main shaft. Looking at the aftermath I found one of the servo leads from the rx to the bx was unplugged from the rx It was for the alierons, not sure if it was the cause or a result of the crash. I looked everything else over and didnt see any issues. What really sucks is this was my first crash on this machine. Is one foam pad good for this heli My 520 had two foam and a piece of metal between them?

thanks
Ronald Muir
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2012 11:57 PM  9 years ago
AzHyper

rrKey Veteran

Peoria, Az.

MyPosts All Forum Topic
Vibration. Use 1 layer of 3M tape and strap it down hard.
SHARE  PM  EMAIL  Attn:RR  Quote
03-02-2012 01:10 AM  9 years ago
Kaborkian

rrNovice

Lafayette, LA USA

MyPosts All Forum Topic
I would power it all up and yank that cord out, see what happens. My guess is that when the beast lost the aileron link and the pulsewidth from that channel went to zero, the beast saw it as a full left aileron and did what it was told.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 01:22 AM  9 years ago
CAP232CM

rrNovice

Parkville, MO - USA

MyPosts All Forum Topic
Ya like Hyper said throw the white foam pad away and get the 3M tape, It's the thin gray tape with red backing, the part # is 4011. If you do some searching there is a vid on here somewhere from Heli Pros South talking about it. Maybe someone else can chime in with a link to the video.

One piece is all you need no metal plate. Put the tape on the BeatX and stick it down. The tape I mentioned above is the same width as the beastx and works perfect. No need for any other straping that tape will hold it fine. I've got around 100 or so flights with mine and it's holding just as good as the day I stuck it there.

Another tip on the wires is to run a bead of hot glue across the top of the beast and the receiver. If you need some picks of my setup let me know and I'll try and post them.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 01:25 AM  9 years ago
j5coat

rrVeteran

Phoenix

MyPosts All Forum Topic
loose the tape, i used 3m grey tape a azhyper said, setup 2 this week on 600n and no problems. here watch this video they start talking about the tape at 1:30.

Watch at YouTube

Trex 700, Trex 600n
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 01:37 AM  9 years ago
Kaborkian

rrNovice

Lafayette, LA USA

MyPosts All Forum Topic
Wow, that video brought back some memories. The blanket on the Gasser they are talking about was hilarious to behold...totally destroyed that heli. I'm pretty sure it was a T-shirt though, I seem to remember a shirtless guy chasing it around. Man that was a while ago, I think around 1996?
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 01:41 AM  9 years ago
CAP232CM

rrNovice

Parkville, MO - USA

MyPosts All Forum Topic
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 04:15 AM  9 years ago
ronmad02

rrApprentice

TOLEDO

MyPosts All Forum Topic
thanks for all the replys I will try it tomorrow to see what happens if it loses the connection ..Ronald Muir
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 06:31 AM  9 years ago
ebonicrobot

rrApprentice

East Bay, CA

MyPosts All Forum Topic
So is everyone only using one layer of tape on their NITROS? I'm in the process of converting mine to Beastx also. I was planning on using 2 layers of 4011. It took my about two tip overs on my Protos before I realized the tape was the culprit LOL. I'm afraid of what can happen to my 600.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 12:56 PM  9 years ago
fastflyer20

rrKey Veteran

N. Tonawanda, NY

MyPosts All Forum Topic
Glue the connectors with hot glue or goop. Not sure why, but BeastX connectors come loose very easy compared to the other FBL units.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 01:26 PM  9 years ago
ronmad02

rrApprentice

TOLEDO

MyPosts All Forum Topic
Well I am not sure if it was the connector that caused the crash? I powered it up moved my controls and everything was good then I unpluged the same connector the right rear of the swash just fell slowly but when I crashed it rolled left very fast.. It must be the vibrations... well I will rip off the white foam that came with the beast and use the 3m tape..Ronald Muir
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 02:28 PM  9 years ago
ChrisK7

rrApprentice

Stanfield, Ore. 97875

MyPosts All Forum Topic
I run Beast X on 6 heli's from the 550e to the Radikal gasser. Elec, glow, and gas.
I use both the white stock pads, and the 3M grey tape and I also run a zip tie over the unit.
I either use silicon or foamy Blenderm tape on the connectors to help hold them in the Beast X and the rec.

No problems at all with any of the heli's.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 04:44 PM  9 years ago
j5coat

rrVeteran

Phoenix

MyPosts All Forum Topic
Just put one layer of the 3m tape, I can actually pick the heli up by the beast so I know its not coming off any time soon.Trex 700, Trex 600n
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2012 12:48 AM  9 years ago
Gailvin

rrApprentice

Abbotsford, BC

MyPosts All Forum Topic
To keep connectors connected, like fastflyer mention, hot glue the connectors. Or, since you just bought some 3M tape, cut a small piece and lay it across the connectors.

HK-500 ; Titan 50 SE ; T-600N ; T-700N
40% Yak; F4U; P-47
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2012 01:17 AM  9 years ago
BlakeMcBrayer

rrElite Veteran

Georgetown, Ky

MyPosts All Forum Topic
nomad02

What did the fuel in your tank look like before the crash? If it were vibrating hard enough to mess with the beastX, then your fuel would have looked like it was boiling in the tank.

I find hot glue to be VERY hard to remove when needed. Shoe Goo also known as Goop sticks like crazy but a lot easier to remove. I use those dentist syringes with the curved tip to apply a small bead across the case and connectors. When I need to get it off, I grab one end with some small needle nose pliers and peel the whole bead off in one piece. Unlike hot glue, I only made that mistake one time and spent an hour removing all of it.
Don't come off the throttle untill you see your GOD!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2012 01:48 AM  9 years ago
RACER7696

rrApprentice

Ma

MyPosts All Forum Topic
I have the beast x and I have an earlier unit and I found my servo conectors were not as tight as id like to see I tie my conectors down with dental floss and then i run a bead of silicone on the top no way any of them will come out.When ypur relaying on little connectors between life and death I dont think you can be safe enough.I also belive beastx reccomends the silicone bead trick.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2012 03:45 AM  9 years ago
Evan03

rrVeteran

Idaho

MyPosts All Forum Topic
i realy like the zeal and i think i d mount beast on it along with a velcor strap to snug it down


my bird flies better since going to zeal.

SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2012 08:52 AM  9 years ago
ronmad02

rrApprentice

TOLEDO

MyPosts All Forum Topic
Well bound to figure this out I took off all the blades and fired it up. I had it about half throttle and tryed to unplug the connector that I found it didnt do anything then pluged it back in and retried the test, took up the rpm's and wha do you know the swash would start to lean to the left just like my crash.. I then stripped off all the white foam from the MB and used the 3m tape let it set up for a while as I glued the connectors in. Fire the bird back up and retested. This time the swash stayed nice and steady. Now I have to just wait for my new set of blades to come in.Ronald Muir
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2012 12:38 PM  9 years ago
fastflyer20

rrKey Veteran

N. Tonawanda, NY

MyPosts All Forum Topic
Great news
The BeastX should come with 3M gray tape.
In case anyone else is looking for it, the packaging has changed.

SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1905 views Post Reply
Home✈️Aircraft🚁HelicopterAlignT-REX 600N › First flight with beastx and tracx head ( didnt go well)
Print TOPIC

 7  Topic Subscribe

Sunday, July 25 - 4:59 pm - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online