RunRyder RC
WATCH
 7 pages [ <<    <     1     ( 2 )     3      4     NEXT    >> ] 11873 views Post Reply
HomeRC & Power✈️Aircraft🚁Helicoptere-Castle Electric Components › New Castle 4.0 firmware came out 2/22/12 and 4.01 revision.
03-01-2012 07:13 PM  9 years ago
MrMel

rrProfessor

Gotland

MyPosts All Forum Topic
Castle link is v3.50.20, the firmware is labelled v4Gone fishing..or hunting..or something
My site: http://heli.dacsa.net - VBar videos and more
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2012 08:07 PM  9 years ago
PJRono

rrKey Veteran

Minnesota, Ya!

MyPosts All Forum Topic
Ooops my bad on that one. However all our ESCs are updated so my "timing" advice still applies.If you skip me I can't play!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2012 08:22 PM  9 years ago
PJRono

rrKey Veteran

Minnesota, Ya!

MyPosts All Forum Topic
Link to revisions in firmware=

http://www.castlecreations.com/down...rh-phoenix.html
If you skip me I can't play!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2012 08:26 PM  9 years ago
Steff Giguere

rrProfessor

St-Eustache, Quebec, Canada

MyPosts All Forum Topic
It's not on the download page...why is this?Team Synergy, Rail blades, Team Scorpion, V-Team
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-01-2012 08:32 PM  9 years ago
PJRono

rrKey Veteran

Minnesota, Ya!

MyPosts All Forum Topic
The revision history for firmware has always been on another page. To get there you have to go through the download page though.If you skip me I can't play!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 05:05 PM  9 years ago
rbort

rrProfessor

Franklin, MA - USA

MyPosts All Forum Topic
Anybody seen this with the new firmware 4.0?
I updated both of my Castle 85HV and 120HV and they have the same symptom...

First start up, the motor turns, SLOWS DOWN (during the first 2 seconds) and then spools up. Every other startup after that, the motor spools up normallly with no slowdown.

IF you go to fly on the first spoolup, when you take off and add power to climb, the motor BOGS down like the battery is not charged - first time made me question myself if I charged that pack or not.

Cut power (idle up 1 back to normal), land, and start up again and its fine like nothing happened.

Revert back to 3.28 firmware and this issue is gone.

Anyone else seen this?

-=>Raja.
MA 1005 Hanson 27 3DMax, 4488 flts
Spectra-G Hanson 27 3DMax, 3485 flts
Whiplash V1-2 Hanson 300, 2090 flts
Whiplash V2 Hanson 300, 989 flts
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-02-2012 05:09 PM  9 years ago
rapidgaz

rrNovice

Manchester England

MyPosts All Forum Topic
See my other post and link.
SHARE  PM  EMAIL  Attn:RR  Quote
03-02-2012 05:14 PM  9 years ago
rbort

rrProfessor

Franklin, MA - USA

MyPosts All Forum Topic
Why don't you try my workaround
Spool up for 3 seconds, shut down, spool again and fly and see if it acts normally and does not lose power when you add collctive like you're seeing in yours. Would be interesting to see what you find.

I did call castle on it, but they can't believe there is an issue, said they tested it a 100 different ways and never seen this. I need to send my whole setup to them to look at it. I said no thanks I want to fly just wanted to tell you about it so you know - I got a work around for it for now.

I just want to see if anyone else sees this, as both of my machines do it. I can't be the only guy with this issue, as castle seems to think?

-=>Raja.
MA 1005 Hanson 27 3DMax, 4488 flts
Spectra-G Hanson 27 3DMax, 3485 flts
Whiplash V1-2 Hanson 300, 2090 flts
Whiplash V2 Hanson 300, 989 flts
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-02-2012 05:29 PM  9 years ago
Pistol Pete

rrProfessor

Seffner, FL

MyPosts All Forum Topic
Did you recalibrate radio to it?~~Enjoying the hobby one flight at a time~~
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-02-2012 05:39 PM  9 years ago
rbort

rrProfessor

Franklin, MA - USA

MyPosts All Forum Topic
Yes
Did you recalibrate radio to it?
-=>Raja.
MA 1005 Hanson 27 3DMax, 4488 flts
Spectra-G Hanson 27 3DMax, 3485 flts
Whiplash V1-2 Hanson 300, 2090 flts
Whiplash V2 Hanson 300, 989 flts
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-02-2012 05:41 PM  9 years ago
rapidgaz

rrNovice

Manchester England

MyPosts All Forum Topic
I re did Calib, have also sent my log files to clint. He thinks I have some part of my drive train slipping. I have checked all and there is no sign. Plus I think I would of heard the slip.
SHARE  PM  EMAIL  Attn:RR  Quote
03-02-2012 09:51 PM  9 years ago
Malc1

rrKey Veteran

EVESHAM,UK

MyPosts All Forum Topic
Interesting..

I've got a brand new CC160HV2 here to go with my new KDE 700XF motor and I was going to upgrade the firmware before I install the setup in my 700E.

It's supposed to be fine tuned version to work with this motor but I think I'll hold fire for a bit until things are checked out.
Minicopter Diabolo - Kosmik200,Pyro750-56
SpectraG + G26 3D Max
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 09:56 PM  9 years ago
rbort

rrProfessor

Franklin, MA - USA

MyPosts All Forum Topic
Malc
You can always backtrack the upgrade. If I was you I'd try the spool up first with the current firmware like 5 times in a row to verify its always a normal spoolup and then upgrade and try it again. I found with the upgrade its about 4 out of 5 times it does the funky spoolup, the other time it seems normal on the initial one after plugging in the battery. Evey subsequent spoolup after that is normal.

I may shoot a video of it for fun and post it here to show this as the castle people can see it first hand that way, on the phone they never heard of or seen it in all their testing.

-=>Raja.
MA 1005 Hanson 27 3DMax, 4488 flts
Spectra-G Hanson 27 3DMax, 3485 flts
Whiplash V1-2 Hanson 300, 2090 flts
Whiplash V2 Hanson 300, 989 flts
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-02-2012 10:04 PM  9 years ago
Malc1

rrKey Veteran

EVESHAM,UK

MyPosts All Forum Topic
Hi Raja

Yeah that's right, to revert back is not a major problem.

I'm only interested in this firmware really because I believe that quite a bit of testing has been done with KDE and their motors (the 700XF expecially)to get the governer running spot on.

Anyway it's still all in the packaging for now as is the Flybarless stuff for my SpectraG.

Gotta find some more time.
Minicopter Diabolo - Kosmik200,Pyro750-56
SpectraG + G26 3D Max
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 10:06 PM  9 years ago
CoronaL

rrKey Veteran

Winnebago IL

MyPosts All Forum Topic
?just like they never heard of esc's going up in flames??

Sorry, had to throw that out there.

Clints a great guy and support person for Castle, but many he's gotta be banging his head against the wall after many people reporting motor synch type issues with the new firmware, and the apparent continued fire issues with the ICE2's. I'm hoping this is all just internet paranoia on my part and the "issues" are rather isolated and rare, but man I gotta wonder wtf is going on there! Hope they get it all worked out b/c I do like my ICE2 120hv, but every time I fly it I'm wondering if it's going to catch on fire
Randy!!! I am the liquor
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 10:10 PM  9 years ago
Malc1

rrKey Veteran

EVESHAM,UK

MyPosts All Forum Topic
Hmmm I never had a problem with my old version CC80HV - hope the 160HV version 2 doesn't do anything silly when I first power it up Minicopter Diabolo - Kosmik200,Pyro750-56
SpectraG + G26 3D Max
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2012 10:17 PM  9 years ago
rbort

rrProfessor

Franklin, MA - USA

MyPosts All Forum Topic
ICE 2 120HV
Hope they get it all worked out b/c I do like my ICE2 120hv, but every time I fly it I'm wondering if it's going to catch on fire
I've been using mine since December with no issues so far, but its set for 8 Khz and 5 motor timing. I was talking with Castle and they said to set it for Outrunner mode as I'm using a Hacker motor, it runs better but I was trying to ask the Fire and Ice folks here when they had incidents what their settings were.

I ask because its working now and wonder and hope that if I set it to outrunner mode it will work 'better' as Castle support says and not spark any flames!

Malc: Get that Spectra converted to flybarless, you will like it alot better I was flying someone's Spectra with a flybar recently and man I forgot how comparitively unstable or not 'rock steady' it is as it is with a flybarless system.

-=>Raja.
MA 1005 Hanson 27 3DMax, 4488 flts
Spectra-G Hanson 27 3DMax, 3485 flts
Whiplash V1-2 Hanson 300, 2090 flts
Whiplash V2 Hanson 300, 989 flts
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-02-2012 10:35 PM  9 years ago
rbort

rrProfessor

Franklin, MA - USA

MyPosts All Forum Topic
Here are some confirmations to what I see
http://www.rcgroups.com/forums/showthread.php?t=1605558

-=>Raja.
MA 1005 Hanson 27 3DMax, 4488 flts
Spectra-G Hanson 27 3DMax, 3485 flts
Whiplash V1-2 Hanson 300, 2090 flts
Whiplash V2 Hanson 300, 989 flts
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-03-2012 12:54 AM  9 years ago
3dgimble

rrKey Veteran

Rochester

MyPosts All Forum Topic
is the new firmware for 110,80,120,140hv's beta?
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-03-2012 12:58 AM  9 years ago
3dgimble

rrKey Veteran

Rochester

MyPosts All Forum Topic
Ejeramy is right;
IMO Castle gives people to many settings to mess up. Most of these settings should be in say an expert menu or something.
castle really should reserve
these settings for people who know what they are doing, expert mode.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 7 pages [ <<    <     1     ( 2 )     3      4     NEXT    >> ] 11873 views Post Reply
HomeRC & Power✈️Aircraft🚁Helicoptere-Castle Electric Components › New Castle 4.0 firmware came out 2/22/12 and 4.01 revision.
Print TOPIC

 26  Topic Subscribe

Wednesday, August 4 - 9:12 pm - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online