RunRyder RC
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 3958 views Post Reply
02-29-2012 01:04 AM  9 years ago
badastinner

rrApprentice

Wentzville, MO-USA

MyPosts All Forum Topic
Here's mine
I'm still working on it but here's mine. I still have to mount the total-g and set everything up. This heli went together with no problems at all. I've never put of these together from scratch before and was amazed at how Outrage packaged everything together instead of one big bag of screws and washers with hard to read instructions.

No changes are permanent but...change is.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-06-2012 01:55 AM  9 years ago
badastinner

rrApprentice

Wentzville, MO-USA

MyPosts All Forum Topic
Finished N2

I think the wiring on the N2 is way easier with more room than the V1.
I really like the servo placement and the gyro/fbl plate on top of the frame. Can't wait for some good weather to maiden.
No changes are permanent but...change is.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-07-2012 07:45 PM  9 years ago
jonathan

rrNovice

italy, rome

MyPosts All Forum Topic
heres mine. still working on it.

SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-07-2012 07:47 PM  9 years ago
badastinner

rrApprentice

Wentzville, MO-USA

MyPosts All Forum Topic
Jonathan..Looks good. Did you check to see if the canopy with fit over your battery? Mine is very tight.No changes are permanent but...change is.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-07-2012 09:13 PM  9 years ago
rotor head33

rrApprentice

Louisiana-United States

MyPosts All Forum Topic
bad what motor you runnin with the muscle pipe?
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-07-2012 11:03 PM  9 years ago
jonathan

rrNovice

italy, rome

MyPosts All Forum Topic
hey. I checked it is tight but doable. the main problem i found was that the main elevator servo, the one that is raised higher off the frame, had the uniballs touching the cover so I had to lower that slightly.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-07-2012 11:51 PM  9 years ago
badastinner

rrApprentice

Wentzville, MO-USA

MyPosts All Forum Topic
I'm running an align 55h. I put all my servo balls on the inside of the wheels. Otherwise mine would rub too. The canopy is not very roomy. But neither was the V1.No changes are permanent but...change is.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-12-2012 01:29 AM  9 years ago
John Krebs

rrVeteran

Pittsburgh, PA

MyPosts All Forum Topic
I did the maiden flight on mine today. Flies great and I'm sure it will get even better as I home in on the perfect needle and other settings.

John
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-01-2012 12:34 PM  9 years ago
jonathan

rrNovice

italy, rome

MyPosts All Forum Topic
clutch and N2 carbon tail blades
Hi guys,

Hows it going? tryed to start my engine the other day but it kept shutting off. I htought it was the engine but dismounted it and checked everything and it is fine. I then saw that if i gave immediately half gas it would start fine but anything less it would struggle to rev up and would shut down (ps i tried all combination of carburations so it isnt that), so i think it is the clutch which is kicking in too soon. Anyone have a similar prob? I also had a prob with the starting shaft, it got stuck and wouldnt spin freely so had to dismount it and saw that the fit is too tight within the clutch bell and so sanded it down so it is ok now.

following question. How do you guys find the tail blades given in the kit?

Thanks

Jonathan
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-03-2012 06:27 PM  9 years ago
badastinner

rrApprentice

Wentzville, MO-USA

MyPosts All Forum Topic
Hows it going? tryed to start my engine the other day but it kept shutting off. I htought it was the engine but dismounted it and checked everything and it is fine. I then saw that if i gave immediately half gas it would start fine but anything less it would struggle to rev up and would shut down (ps i tried all combination of carburations so it isnt that), so i think it is the clutch which is kicking in too soon. Anyone have a similar prob? I also had a prob with the starting shaft, it got stuck and wouldnt spin freely so had to dismount it and saw that the fit is too tight within the clutch bell and so sanded it down so it is ok now.
following question. How do you guys find the tail blades given in the kit?
I didn't have any of those problems. I did strip the front torque tube gears when i land in some high grass. I used kbdd tails on mine so i don't know how the one with kit are.
No changes are permanent but...change is.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-04-2012 03:46 AM  9 years ago
John Krebs

rrVeteran

Pittsburgh, PA

MyPosts All Forum Topic
I drilled the pinion gear out. That eliminated the friction from the shaft rubbing the pinion.

John
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-04-2012 04:00 AM  9 years ago
aerosmith

rrApprentice

Mississippi - USA

MyPosts All Forum Topic
Hey guys, I'm flying with the supplied tail blades & I like them just fine. Of course, I'm sure somebody will chime in & say they hate em. Different opinions are expected & that's cool. I for one like them just fine.

badastinner,I think your engine issues are are from your engine. I haven't had any problems with the starting shaft or clutch either. I followed the instructions to the tee, (not saying you didn't) But I found this kit to be a pleasure to build & fly. I'm thinking about getting another kit just for a spare everything!

I hope you get your problems resolved so you can enjoy that N2
Good luck!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-04-2012 11:37 AM  9 years ago
jonathan

rrNovice

italy, rome

MyPosts All Forum Topic
thanks for the feedback. will fiddle with it this w.e and hope to get it running smooth.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 3958 views Post Reply
Print TOPIC

 5  Topic Subscribe

Thursday, July 29 - 10:48 am - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online