RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 835 views POST REPLY
11-20-2011 07:04 PM  6 years agoPost 1
buster1

rrKey Veteran

Manhattan, NY

My Posts: All  Forum  Topic

Seems the tourque tube in my 450 has lost it rigid integrity and can twist much more then normal. Seems it might have cracked internally and need to replace.

I've put maybe 20 flights on this tube since replacing it after a crash a while back.

Has anyone seen any issues with their torque tube failin? Well, it actually didn't fail, I just checked it after a flight and noticed that it would fail completely in another few flights.

The alignment and installation seems correct.

Any insight would be helpful.

Thanks,
Jeff

PM  EMAIL  Attn:RR  Quote
11-20-2011 07:12 PM  6 years agoPost 2
littleman

rrKey Veteran

Pasadena, Ca

My Posts: All  Forum  Topic

The only time I have seen this other then in a crash was when the bearing was not glued properly.
A.J.

Proud member of Teams Castle, MSH USA, Futaba, Scorpion, & Nick Maxwell Products

PM  EMAIL  Attn:RR  Quote
11-20-2011 07:17 PM  6 years agoPost 3
buster1

rrKey Veteran

Manhattan, NY

My Posts: All  Forum  Topic

pleae elaborate regarding the bearing not being glued correctly.
Do you mean, the bearing started to move?
Mine is still in place, but I do have a slight crach along the length of the tube.
Maybe I glued incorrectly.

Thank you,
Jeff

PM  EMAIL  Attn:RR  Quote
11-20-2011 07:22 PM  6 years agoPost 4
littleman

rrKey Veteran

Pasadena, Ca

My Posts: All  Forum  Topic

I meant that either the bearing was glued in the wrong place, or that it had come loose.
I have broken a TT when I hit the ground without stripping tail gears. I had the same syptoms, tail wasnt holding, it was wagging and it had too much play.
A.J.

Proud member of Teams Castle, MSH USA, Futaba, Scorpion, & Nick Maxwell Products

PM  EMAIL  Attn:RR  Quote
11-20-2011 07:35 PM  6 years agoPost 5
buster1

rrKey Veteran

Manhattan, NY

My Posts: All  Forum  Topic

yeah, that were my symptons as well - I think may have been off on where I glued it. Thanks for the help.
At least I caught it and only a torque tube that needs to be replaced.
Thanks,
Jeff

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 835 views POST REPLY
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, June 18 - 4:40 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online