RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 666 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › tail let loose.
11-19-2011 11:45 AM  6 years agoPost 1
D-fly

rrApprentice

cincinnati, oh

My Posts: All  Forum  Topic

I have the BeastX on a Helibug converted 700 Gasser. It flew well for about 10 flights then the following happened:
1. during spool up the tail start to twitch.
2. Then if I get it off the ground it darts left and right about 6-10
inches.
3. It may hover for a minute or less then the tail would spin out of
control to the left.
Yes, I did reprogram it and it did the same thing.
I bought it at IRCHA a couple months ago.

Help any one ?
Del

PM  EMAIL  GALLERY  Attn:RR  Quote
11-19-2011 01:19 PM  6 years agoPost 2
theriddick45

rrVeteran

United States

My Posts: All  Forum  Topic

D-fly

1- check the connection of the servo
2- check for binding
3- check or swap your tail servo and check for temp
4- what servo do you use did you select the right frequency? If so.
5- redo the tail servo set up start on parameter d on purple and a low gain. Then adjust it properly to obtain the right setup.

Hope this help!!

Suzi Janis 800e & 700e 3blade both w/Ikon

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-19-2011 02:24 PM  6 years agoPost 3
Mputu

rrVeteran

Killeen, TX

My Posts: All  Forum  Topic

what servo do you use did you select the right frequency?
This can really be the issue,

Fly hard, Land safe

PM  EMAIL  GALLERY  Attn:RR  Quote
11-19-2011 02:28 PM  6 years agoPost 4
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Sounds like a bad tail servo to me....can you replicate the failed tail with hand pressure on the ground??? Are you using the correct voltage to the tail servo??? What tail servo is it?

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
11-20-2011 10:52 PM  6 years agoPost 5
D-fly

rrApprentice

cincinnati, oh

My Posts: All  Forum  Topic

Well
My settings
Jr 8900G, 1520us, 270Hz

There is some slop not that much.
The sv wire wasn't pushed in all the way.

I will try it again once I fix the slop and ensure the sv wire is secure.

BeastX web site listed the 8900G as 270Hz and I have been flying it like that for 10 flights. Should it be 50Hz?

Thank for the help.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-21-2011 01:55 AM  6 years agoPost 6
theriddick45

rrVeteran

United States

My Posts: All  Forum  Topic

No 50 hz will be to low.

Suzi Janis 800e & 700e 3blade both w/Ikon

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 666 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › tail let loose.
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Tuesday, June 19 - 8:04 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online