RunRyder RC
WATCH
 1 page 3269 views POST REPLY
HomeRC & PowerAircraftHelicopter
e-
Electric Battery-Charger-pSupply
› Hyperion EOS 720i Super Duo 3 Problem
10-29-2011 09:09 PM  6 years agoPost 1
theflyingman2

rrApprentice

Winter Haven, FL USA

My Posts: All  Forum  Topic

I have been using this charger for about 3 weeks now charging 2 6x 5100 packs with no issues at all the sync charging is awesome.

However, when I try to charge any of my receiver packs I always get the Output voltage to high error and am unable to charge them.

I am able to charge my 3s 2200 packs just fine.

When Hook up and set the charger to the following packs I get the error every time (it happens on charge, discharge, storage, and balance modes):

2s 3600 LiPo
2s 2100 LiPo
2s 1800 Lipo
2s 3000 LiFe
2s 2100 Life

I have no problems charging them on my other charger (Thunder Power 1010c) (except that it burnt up last week and I have to use my new Hyperion to charge receiver packs now)

Does anyone have any suggestions?

Thanks in advance.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2011 09:15 PM  6 years agoPost 2
TheWoodCrafter

rrKey Veteran

Costa Mesa, Ca.

My Posts: All  Forum  Topic

Funny they are all 2S packs.

You are setting the charger to 2S right?

Are you using an external balancing board?
Is the 2S balancing port messed up?

Thanks, TheWoodCrafter

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2011 09:18 PM  6 years agoPost 3
theflyingman2

rrApprentice

Winter Haven, FL USA

My Posts: All  Forum  Topic

It is very strange indeed. Yes setting the charger to the correct cell count and chemistry. It does the same thing on all 4 balance boards that came with the charger. It does it on both ports of the charger as well.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2011 10:15 PM  6 years agoPost 4
TheWoodCrafter

rrKey Veteran

Costa Mesa, Ca.

My Posts: All  Forum  Topic

It does the same thing on all 4 balance boards that came with the charger.
These each come with there own cable from the board to the charger?

You are not using the same cable?

Bummer.

May be time to send it in for warranty repair.

Thanks, TheWoodCrafter

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2011 10:18 PM  6 years agoPost 5
theflyingman2

rrApprentice

Winter Haven, FL USA

My Posts: All  Forum  Topic

I have tried each with both cables, no luck.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2011 10:29 PM  6 years agoPost 6
cwright

rrKey Veteran

Blossvale New York

My Posts: All  Forum  Topic

Try a different charge lead. I had one go bad on my Hyperion 610I and I got the same error message. Chuck

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2011 11:59 PM  6 years agoPost 7
theflyingman2

rrApprentice

Winter Haven, FL USA

My Posts: All  Forum  Topic

Thanks, but I have already tried several as I use different leads on different packs.

Thanks.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-06-2011 03:23 AM  6 years agoPost 8
TECO

rrVeteran

WARWICK RI, USA

My Posts: All  Forum  Topic

i have a similar problem, i get a alarm of to high volts with a power supply 15amp 27.2v and with another power supply 40 amps 25v the charger ON WINDOW 2, (RIGHT SIDE) jut shuts off complete, , work perfect on side 1. any help i will thank you and worse case where can i send it in for repairs thanks.

rich

"Never argue with an idiot - he'll drag you down to his level and beat you with experience

PM  EMAIL  GALLERY  Attn:RR  Quote
11-06-2011 04:25 PM  6 years agoPost 9
MrMel

rrProfessor

Gotland

My Posts: All  Forum  Topic

What firmware version did your chargers come with? (you see it when you boot up the charger)

Let me know.

Gone fishing..or hunting..or something
My site: http://heli.dacsa.net - VBar videos and more

PM  EMAIL  GALLERY  Attn:RR  Quote
11-06-2011 04:28 PM  6 years agoPost 10
theflyingman2

rrApprentice

Winter Haven, FL USA

My Posts: All  Forum  Topic

Mine says v5.1

Thanks.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-06-2011 04:33 PM  6 years agoPost 11
Steff Giguere

rrProfessor

St-Eustache, Quebec, Canada

My Posts: All  Forum  Topic

Funny mine has not done it in a little while now...wonder what I did different.

Team Synergy, Rail blades, Team Scorpion, V-Team

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-06-2011 04:49 PM  6 years agoPost 12
TECO

rrVeteran

WARWICK RI, USA

My Posts: All  Forum  Topic

Mine says v5.1 TOO

"Never argue with an idiot - he'll drag you down to his level and beat you with experience

PM  EMAIL  GALLERY  Attn:RR  Quote
11-07-2011 04:05 PM  6 years agoPost 13
TECO

rrVeteran

WARWICK RI, USA

My Posts: All  Forum  Topic

just let you guys know that,
i called the empires rc this morning and talked with guy name JC and i explained the situation, he told me to go back to my local rc hobby shop and grab a new CHARGE, i did, got a BRAND NEW CHARGE in mu hands guy, 10+ to empire rc and the costumer support.

Richard

"Never argue with an idiot - he'll drag you down to his level and beat you with experience

PM  EMAIL  GALLERY  Attn:RR  Quote
12-28-2011 04:49 PM  6 years agoPost 14
rcslopesurfer

rrNovice

Southwest UK

My Posts: All  Forum  Topic

I get the very same "voltage to high" error on my 720i duo 3 running the latest firmware. It only ever happens on port one & I have tried various leads, batteries & ballance boards but all 2s lipos tried give this error. I can swap the lead & ballance board over to port two & it charges & discharges with no errors something seems to be bugged with port one & 2s packs all other packs seem to charge ok on port one.

PM  EMAIL  Attn:RR  Quote
12-28-2011 05:08 PM  6 years agoPost 15
TECO

rrVeteran

WARWICK RI, USA

My Posts: All  Forum  Topic

send it back and get a new, very easy

"Never argue with an idiot - he'll drag you down to his level and beat you with experience

PM  EMAIL  GALLERY  Attn:RR  Quote
12-28-2011 05:52 PM  6 years agoPost 16
MrMel

rrProfessor

Gotland

My Posts: All  Forum  Topic

Do try the 5.5 firmware which is out first.
Http://media.hyperion.hk/dn/

Gone fishing..or hunting..or something
My site: http://heli.dacsa.net - VBar videos and more

PM  EMAIL  GALLERY  Attn:RR  Quote
12-28-2011 06:43 PM  6 years agoPost 17
rocket_33

rrElite Veteran

Mount Pleasant, Michigan USA

My Posts: All  Forum  Topic

One thing I love about the Hyperion is post purchase support. Firmware updates, software updates, it keeps my charger right on the top of its game

PM  EMAIL  GALLERY  Attn:RR  Quote
12-28-2011 06:49 PM  6 years agoPost 18
Steff Giguere

rrProfessor

St-Eustache, Quebec, Canada

My Posts: All  Forum  Topic

Guys I might have found the problem, instructions say to plug battery leads before balancing leads, since I've been doing this I have not had the problem...you guys try it out and let us know if you get the same results.

Team Synergy, Rail blades, Team Scorpion, V-Team

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-20-2015 09:05 AM  33 months agoPost 19
madhun

rrNovice

Sunshine Coast, Queensland- Australia

My Posts: All  Forum  Topic

If you haven't fried the channel by arcing a live deans male connector against something you might also find that cleaning the banana plugs out with some contact cleaner will help the cause; mine wasn't working for a while then did that and good as gold.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 3269 views POST REPLY
HomeRC & PowerAircraftHelicopter
e-
Electric Battery-Charger-pSupply
› Hyperion EOS 720i Super Duo 3 Problem
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Friday, September 21 - 10:37 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online