RunRyder RC
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 4059 views POST REPLY
HomeAircraftHelicopterFuel-Helicopters New or Limited ActivityJS › Frenzy metal tail upgrade Issues
10-25-2011 04:33 PM  6 years agoPost 1
rspiegel

rrVeteran

Austin,TX South Buda

My Posts: All  Forum  Topic

OK got the Frenzy JS metal tail upgrade a few weeks back. All installed. Problem is just after spool up when the head head to speed. The tail makes this wooshzh sound. I can not find the issue. I have tighten the belt and swapped spacers in the tail. Still does that sound. I like the metal but I may just go back to the plastic tail housing. What could it be. The metail tail is in two half maybe the two are not aligned right causing a vibration.??????

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2011 04:34 PM  6 years agoPost 2
rspiegel

rrVeteran

Austin,TX South Buda

My Posts: All  Forum  Topic

d
It does go away right after it spools up and Gov takes over but somethings not right.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2011 05:10 PM  6 years agoPost 3
kc8qpu

rrElite Veteran

sc

My Posts: All  Forum  Topic

Was there something wrong with the plastic tail????? I have been flying on my plastic tail for 3 years and have no had an issue at all.

Carpe Diem!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2011 09:23 PM  6 years agoPost 4
sonnyhad

rrProfessor

Holland,Mi

My Posts: All  Forum  Topic

Make sure you don't have an extra twist in the belt. I had that once.

Bald Pilots usually wear hats!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-26-2011 01:28 AM  6 years agoPost 5
rspiegel

rrVeteran

Austin,TX South Buda

My Posts: All  Forum  Topic

tail
Belt is good no twist. yes the Plasitc tail was good and my go back on soon. The tail push rod was loose in the guides that go to the tail and I roated the guides to snug it up some. I will try a spool up in the morning. If it still does it I will install plastid tail and forget the metal crud.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-26-2011 04:34 PM  6 years agoPost 6
rspiegel

rrVeteran

Austin,TX South Buda

My Posts: All  Forum  Topic

Tail
Installed old tail plastic housing and still there. New main shaft still there. Pinion alignment adjust still there. May just have to live with it. I could put new tail shaft in but the one on there looks great. After spool up it looks great and flys good. Just during full head speed and after spool up it woshzzes. Flys great I just did not want it to blow up on me.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-26-2011 04:39 PM  6 years agoPost 7
sonnyhad

rrProfessor

Holland,Mi

My Posts: All  Forum  Topic

That's an odd one, let us know what you find out with it. Are the trust bearings in the grips ok?

Bald Pilots usually wear hats!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-30-2011 04:44 PM  6 years agoPost 8
rspiegel

rrVeteran

Austin,TX South Buda

My Posts: All  Forum  Topic

Tail
Installed old tail and lowered the head speed some and now its barley there.

PM  EMAIL  GALLERY  Attn:RR  Quote
07-25-2012 01:49 AM  6 years agoPost 9
jcer93705

rrApprentice

fresno california USA

My Posts: All  Forum  Topic

Very odd I have similar problem. When I lift off it's ok until I get into hover then tail blade makes a louder noise then I get trim problem on tail and vibration. Something on the tail is not ok. I don't know where the problem. I lowered down the gain. I never had such of a problem with any other helis. I'm using 401 with matched tail servo.

PM  EMAIL  Attn:RR  Quote
07-25-2012 02:22 AM  6 years agoPost 10
sonnyhad

rrProfessor

Holland,Mi

My Posts: All  Forum  Topic

Check the tail grip bearings!

Bald Pilots usually wear hats!

PM  EMAIL  GALLERY  Attn:RR  Quote
07-25-2012 06:23 AM  6 years agoPost 11
jcer93705

rrApprentice

fresno california USA

My Posts: All  Forum  Topic

Did that. I widen some of the holes so tail slider move freely.

PM  EMAIL  Attn:RR  Quote
08-11-2012 04:37 PM  6 years agoPost 12
FIELIES

rrNovice

South Africa

My Posts: All  Forum  Topic

Bought my TZ50 used four months ago. Got the same problem. The tail on mine vibrates so bad, that it snapped the crank on a new asp 52.
This is what i tried.

New OS 55
Changed all the bearings on the heli with good quality bearings
New complete head assembly
New main shaft
New main gear
New auto gear
New cluth
New clutch bell with liner
New fan
New front belt drive gear set
New belt
New plastic tail unit with new shaft
New metal upgrade tail unit with new shaft
New Raptor metal tail unit with new shaft
New tail pitch slider
New Align 600 tail rotor grip assemly
New Align main and tail blades

After all this, and IT IS STILL VIBATING BADLY. The same noise on the tail when spooling up , as the head speed goes up it goes away and when you go idle up 1 to 1850 its back and on idle up 2 , 2000RPM, then its realy very bad.

On my other TZ50,it does have the noise on the tail when spooling up but it goes away as headspeed picks up and is very smooth.

PM  EMAIL  Attn:RR  Quote
08-11-2012 04:52 PM  6 years agoPost 13
sonnyhad

rrProfessor

Holland,Mi

My Posts: All  Forum  Topic

Have you tried the tail blade grips, sometimes the thrust bearings are backwards.

Bald Pilots usually wear hats!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-11-2012 05:42 PM  6 years agoPost 14
Rotors Up

rrApprentice

Reading, Pa

My Posts: All  Forum  Topic

Sell it.

Better now then never... Fly Skids Up!!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-11-2012 06:10 PM  6 years agoPost 15
FIELIES

rrNovice

South Africa

My Posts: All  Forum  Topic

I tried a new TZ set and then a new Align metal and plastic set. Still the same. I did check the thrust bearings. Bearings are right way around . Still vibrating.

PM  EMAIL  Attn:RR  Quote
08-11-2012 06:24 PM  6 years agoPost 16
FIELIES

rrNovice

South Africa

My Posts: All  Forum  Topic

Rotors Up, the thought of selling it has crossed my mind, but i have spent such a lot of time and money on it, i would like to know what the problem is.

PM  EMAIL  Attn:RR  Quote
08-14-2012 01:17 AM  6 years agoPost 17
slickporsche

rrVeteran

American/Philippines

My Posts: All  Forum  Topic

rspiegell
When was the last time you put a dial indicator on the main shaft and tail shaft? When you hear this wierd sound, what are the main blades doing? Is the tracking ok? Also check the feathering shaft, and check the balance on everything that rotates. Well, almost everything. You could also try some carbon tail blades, but be sure to match their weight, and make sure the spanwise cg matches.

NO!, not all carbon blades are balanced that good. It pays to get real picky with main and tail blade balance and matching weight.

I also think the problem was there before you put the metal tail on, and the plastic was flexible just enough to absorb some of movement or vibration that is causing the unusual noise.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-16-2012 09:20 AM  6 years agoPost 18
jcer93705

rrApprentice

fresno california USA

My Posts: All  Forum  Topic

I have the same problem with mine. I did found that some links are tight on the tail. Had to sand some links. Now it move alot easier. The belcrank was to tight to the slider so i enlarge it a bit but went to far that there is slop now. Hope it works out when I receive it. But yea rpm on tail seem to go higher then it drift and I can see that there is vibration at the back. It's a well made helicopter. If thing work out I would say it has better built then my align 600 pro. I would lift up and things are good then when it hover i can hear the tail rpm rise and then I get drift. Something is wrong and it's not funny.

PM  EMAIL  Attn:RR  Quote
09-06-2012 06:36 PM  6 years agoPost 19
MartyH

rrProfessor

USA

My Posts: All  Forum  Topic

Did the OP ever find a solution to the issue?

PM  EMAIL  GALLERY  Attn:RR  Quote
09-07-2012 05:30 PM  6 years agoPost 20
FIELIES

rrNovice

South Africa

My Posts: All  Forum  Topic

Problem solved!!!!!!
The TZ50 tail shaft supplied by JS is under size. got four new shafts and used a micrometer to measure them. They all differed in size.The best one was 0.05mm under size. I ordered a 5mm HSS shaft used in lathes for trueness, cut it to length, used the Dremel to grind the flats for the rotor hub grub screw and tail pully grub srews. Man this heli is so smooth now. No vibrations what so ever.
Tried it with the standard plastic tail unit with the HSS shaft , perfect, and with the metal upgrade unit, perfect.

Hope it helps.

PM  EMAIL  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 4059 views POST REPLY
HomeAircraftHelicopterFuel-Helicopters New or Limited ActivityJS › Frenzy metal tail upgrade Issues
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Friday, September 21 - 10:35 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online