RunRyder RC
 6  Topic Subscribe
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 8263 views POST REPLY
HomeAircraftHelicopter
e-
MSH Protos, Mini Protos
› Tail issues...problem solved!...
10-24-2011 08:20 PM  6 years agoPost 21
Ecaf

rrApprentice

West Dundee, IL

My Posts: All  Forum  Topic

Good to hear Ray.

Mine is still available if you want a second!

PM  EMAIL  GALLERY  Attn:RR  Quote
11-11-2011 04:30 PM  6 years agoPost 22
rcnut

rrElite Veteran

Rockford, Illinois

My Posts: All  Forum  Topic

I received a replacement servo from MKS for my Protos 500, DS 8910A+. So tonight I will install it and re-program the Beast X. Then tomorrow I will test fly it again, hopefully this will work.

Team Miniature Aircraft
"I love the smell of Nitro in the morning!"
...Citizen 654!

PM  EMAIL  GALLERY  Attn:RR  Quote
11-15-2011 03:31 PM  6 years agoPost 23
rcnut

rrElite Veteran

Rockford, Illinois

My Posts: All  Forum  Topic

So far the replacement servo is working great! Put in 2 flights on Saturday without any problems. Plus it was fairly windy, 15-20 MPH.

Last night I had the chance to play with the settings in the Beast X on a much calmer day. I turned off the Cyclic Response and Pitch Boost. It fly's a lot better...for my likes.

I picked up on a great deal for my Protos, night flying gear. By the time Thanksgiving is here and passed, it will be dark coming home from work...SUCKS!!! Well I'll just fly at night by my house, that sould be interesting.

Team Miniature Aircraft
"I love the smell of Nitro in the morning!"
...Citizen 654!

PM  EMAIL  GALLERY  Attn:RR  Quote
11-30-2011 01:35 PM  6 years agoPost 24
rcnut

rrElite Veteran

Rockford, Illinois

My Posts: All  Forum  Topic

So far I have over 25 flights on my Protos. Took it out last Friday (day after Thanksgiving) for a couple of flights / demo's. The wind was 20-30 mph and gusty. The Protos flew very well and almost seemed as if there wasn't much of a wind.

Team Miniature Aircraft
"I love the smell of Nitro in the morning!"
...Citizen 654!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-12-2011 02:45 PM  6 years agoPost 25
rcnut

rrElite Veteran

Rockford, Illinois

My Posts: All  Forum  Topic

29 flights and no issues with the tail. The last flight was Friday after work with the sun setting fast, 27 degrees and dropping. My Protos flew and didn't worry about anything...except for my freezing and shaking fingers.

Team Miniature Aircraft
"I love the smell of Nitro in the morning!"
...Citizen 654!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-12-2011 03:58 PM  6 years agoPost 26
GetToDaChopper

rrElite Veteran

Las Vegas , NV

My Posts: All  Forum  Topic

Dang i love a happy ending !!!

    ▲
  ▲ ▲
▲ ▲ ▲ One of a Kind !!!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-30-2012 01:54 PM  6 years agoPost 27
wbefield

rrNovice

atlanta, ga

My Posts: All  Forum  Topic

Great Post here!!. I'm having the same exact problem as the OP. Tail kicking out on pitch pumps. I had already moved my ball on the tail servo to the 10.5mm hole since I couldn't lower my gyro gain anymore without putting the tail in rate mode.

PM  EMAIL  GALLERY  Attn:RR  Quote
01-31-2012 08:24 PM  6 years agoPost 28
Ecaf

rrApprentice

West Dundee, IL

My Posts: All  Forum  Topic

You were lowering the gain on your tail gyro?

PM  EMAIL  GALLERY  Attn:RR  Quote
02-01-2012 02:11 AM  6 years agoPost 29
wbefield

rrNovice

atlanta, ga

My Posts: All  Forum  Topic

I lowered the tail gain, raised it, moved the ball in to 10.5, then back out to 13.5. When I set my torque precomp to high on my BeastX, that's what did it. The tail is holding rock solid now.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-01-2012 01:39 PM  6 years agoPost 30
rcnut

rrElite Veteran

Rockford, Illinois

My Posts: All  Forum  Topic

COOL!!! Like what GetToDaChopper said:
Dang i love a happy ending !!!
wbefield, I tried everything possible before replacing the servo. Actually I was getting ready to start replacing all the electronics (servo, Beast X, receiver). This drove Ecaf and Coronal nutz for a little while. But it had to be something simple...and it was, a bad servo in my case.

Glad to read you worked it out and now your Protos is flying great! Post some Pic's!

Team Miniature Aircraft
"I love the smell of Nitro in the morning!"
...Citizen 654!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-01-2012 02:17 PM  6 years agoPost 31
wbefield

rrNovice

atlanta, ga

My Posts: All  Forum  Topic

Very happy ending indeed! With my work schedule and limited daylight I haven't been able to fly it much. This weekend was nice and was able to get about 15 flights in. So hard to tweak, when I was only flying a coupe of times a week. I'm a relative newb, so it takes me some time to figure things out, but that's why I love this hobby.

I posted one pic in my "Hi All" thread. I will post more when I finish painting my canopy.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 8263 views POST REPLY
HomeAircraftHelicopter
e-
MSH Protos, Mini Protos
› Tail issues...problem solved!...
 Print TOPIC  Make Suggestion 

 6  Topic Subscribe

Tuesday, June 19 - 11:26 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online