RunRyder RC
WATCH
 3 pages [ <<    <     1     ( 2 )     3     NEXT    >> ] 3116 views POST REPLY
Home✈️Aircraft🚁Helicoptere-MikadoLogo 600 › Flew my Logo 600 yesterday......and blew the esc
06-02-2011 03:58 AM  8 years ago
Rogman88

rrElite Veteran

West Monroe, LA

MyPosts All Forum Topic
I've been blessed with my trusty ole CC HV 85. The governor isn't the greatest but works ok and I've got over 1000 flights on it over the past year and a half. It still works like the day I got it. Had it on 6S scorpion 4025-1100 15T/170 on my Trex 600 ESP, then 12S 4025-630 13T/170 on the same bird and now put it on my Logo 600 12S Scorpion 4035-500 13T/106. I've got a good one and will fly it till I fry it.High Voltage just works better
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-02-2011 04:18 AM  8 years ago
Josh Moen

rrApprentice

Denver, CO

MyPosts All Forum Topic
I know Jive is the best way to go I just have a BIG problem with my spending almost the same amount on my esc as I did on the heli itself! If it comes to needing a Jive just to fly my Logo, I'll sell the heli.

I've thought about trying a friends Ice HV80, but after this last esc I don't think I'll do anything until CC replaces the two ESCs that I've blown.
Thanks,

Josh Moen
Team Synergy Factory Pilot
Team Scorpion
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 04:21 AM  8 years ago
cdrking

rrElite Veteran

Seattle

MyPosts All Forum Topic
How much does it cost to buy TWO CC ESC's?To hover is divine, the alternative is rather PLANE.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 04:23 AM  8 years ago
Josh Moen

rrApprentice

Denver, CO

MyPosts All Forum Topic
I have another project for the second esc.Thanks,

Josh Moen
Team Synergy Factory Pilot
Team Scorpion
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 04:40 AM  8 years ago
jesse

rrVeteran

Houston, TX.

MyPosts All Forum Topic
Sounds Like you have a different problem, but if your looking for an esc that works well with not so much of a hit try a yge 90hv. I'm running 623's on mine with this esc at 2050 rpm and it doesnt even get warm. not cheap but not $500 dollars. I got mine for 289. Also Llike's been said a kontronic 80hv can be had for 350 or so used and will work fine. I have a flying buddy flying his 600se on an 80hv with heatsink no problems. he's not a stick banger but it's plenty for him to power thru all kinds of manuvers like piro tictocs and stuff.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 04:44 AM  8 years ago
Wingman77

rrProfessor

Pulaski Tennessee

MyPosts All Forum Topic
the 120 ice is currently having wide spread problems... I just opted for the 160 on my new e90. Hopefully Castle will get the 120 fixed up soon.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-02-2011 01:22 PM  8 years ago
rnkasp

rrApprentice

Pottstown, PA USA

MyPosts All Forum Topic
I just experienced the exact same problem with the HV120. Maiden flight of my Logo 600se about 4 minutes in the motor cut out. As I started to auto it in the motor spooled back up. After getting back to the house and checking out the heli I noticed now the "power up tones" were very faint. I also checked it on another motor with the same results. After talking with Castle and mentioning the tones they said it needs to replaced. I'm really regretting not just going with the Jive and being done with it. It is going to be real hard soldering the replacement HV120 in.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 03:18 PM  8 years ago
mmc205

rrElite Veteran

PA - USA

MyPosts All Forum Topic
seems like the hv120 has some issues.....more than the other models. I kind of agree with rnkasp, i'm starting to regret getting castles on my logos. If i could do it all over again i might have sprung for the jives. Back in my airplane days, castle WAS the top notch esc, for heli's it just doesn't seem to be the case.***Logo 600 vbar***Henseleit TDR vbar***
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 03:37 PM  8 years ago
Wingman77

rrProfessor

Pulaski Tennessee

MyPosts All Forum Topic
castle esc's are still great, and my favorite, however as of recently they are having issues with the hv120. I know people that have just used the hv 80 or the 160hv which both work fine to avoid the 120 until the issues are resolved.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-02-2011 03:51 PM  8 years ago
rnkasp

rrApprentice

Pottstown, PA USA

MyPosts All Forum Topic
I agree. The Castle ESCs have always been on all of my helis and have always been my favorite. My frustration just comes from being one of the poor folks that are vested in the 120 issues. Luckily for me it didn't end in a crash. I truly hope that all issues are resolved before they send me a replacement. In the meantime I'm going to through an HV80 on it. Who knows maybe it will just stay on. Probably won't have much luck selling the replacement HV120 though.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 05:31 PM  8 years ago
psych-lick

rrKey Veteran

Portland, OR

MyPosts All Forum Topic
not good. it was just last year when we heard of report after report of HV80's burning..
Here is one of many examples: https://rc.runryder.com/t600981p1/
-Jeff T.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2011 07:29 PM  8 years ago
Sam2b

rrElite Veteran

Tacoma, WA

MyPosts All Forum Topic
It's unfortunate we don't know if we get a good Castle ESC or a bad Castle ESC and seems to be a bit of a gamble. As for me I've had zero issues with my first (and only) Castle HV80 ESC using both gov and airplane mode on my heli. Granted I'm running a NEU 1915 15Y motor with 12S flying hard on a 90 heli pulling 80A on average, but I don't see many NEU motors being used out there, particularly with the pilots having the fires. I've heard from reputable sources the Scorpion motors tend to pull more and that might increase the potential for Castle ESC fires (my speculation). It kinda seems Castle ESC's and Scorpion motors are a bad combo. Off topic, but IMO NEU motors are worth it anyway.

It goes without saying, but the correct motor timing & PWM Rate is crucial, else POOF!
_Sam B_
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-03-2011 02:50 AM  8 years ago
johnnie eagle

rrApprentice

Florham Park, NJ 07932

MyPosts All Forum Topic
CC HV120
I had a cc HV120 in my logo 600se. After 10 or so flights the esc burst into flames right after spooling up. Very scary when you have two 6s batteries plugged in. needless to say it burned my new carbon frame set, western robotics esc and some other wiring. Castle did make good on the esc and sent me a 160 which has been working great.
Team Minicopter - Peak Aircraft, Team Kontronik USA
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2011 04:10 AM  8 years ago
Sam2b

rrElite Veteran

Tacoma, WA

MyPosts All Forum Topic
What motor are you running Johnnie? And what timing on the ESC?_Sam B_
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-03-2011 05:58 AM  8 years ago
Josh Moen

rrApprentice

Denver, CO

MyPosts All Forum Topic
Those of you running a 160 on your Logos - Are you using the anti-static kits and where are you grounding them? Motor mount or negative of the ESC?? And have you done a continuity test between the bearing on the tail belt in the tail box to the motor mount or negative ESC lead to make sure everything is connected? I installed the kit on mine and had to scrape lots of the anodizing off to make continuity all the way.Thanks,

Josh Moen
Team Synergy Factory Pilot
Team Scorpion
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2011 12:22 PM  8 years ago
johnnie eagle

rrApprentice

Florham Park, NJ 07932

MyPosts All Forum Topic
I am using the anti static kit and I ground it right to the motor.Team Minicopter - Peak Aircraft, Team Kontronik USA
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2011 04:57 PM  8 years ago
Josh Moen

rrApprentice

Denver, CO

MyPosts All Forum Topic
to the motor or the mount? and which esc? and motor? Have you ever done a continuity check on the anti-static kit?Thanks,

Josh Moen
Team Synergy Factory Pilot
Team Scorpion
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2011 05:31 PM  8 years ago
johnnie eagle

rrApprentice

Florham Park, NJ 07932

MyPosts All Forum Topic
o the motor or the mount? and which esc? and motor? Have you ever done a continuity check on the anti-static kit?

Josh M.

I run to the ground screw right to the motor.
Team Minicopter - Peak Aircraft, Team Kontronik USA
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2011 05:44 PM  8 years ago
Sam2b

rrElite Veteran

Tacoma, WA

MyPosts All Forum Topic
Like I said before, every fire with a Castle has been with a Scorpion motor. Call Castle to get the exact settings to run before next time. Going up in amp size does not matter. i.e. I'm using an HV80 and fly hard with a 12S._Sam B_
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-03-2011 06:54 PM  8 years ago
Josh Moen

rrApprentice

Denver, CO

MyPosts All Forum Topic
@sam2b - I never had a fire. I was told to run at 8kHz by castle techs. I did this and still lost an esc. - TWICE

Johnnie - what motor are you running?
Thanks,

Josh Moen
Team Synergy Factory Pilot
Team Scorpion
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <     1     ( 2 )     3     NEXT    >> ] 3116 views POST REPLY
Home✈️Aircraft🚁Helicoptere-MikadoLogo 600 › Flew my Logo 600 yesterday......and blew the esc
 Print TOPIC  Make Suggestion 

 9  Topic Subscribe

Wednesday, May 27 - 10:45 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online