RunRyder RC
WATCH
 1 page 917 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Futaba FASST › Heli piro problems, Using Futaba Gy520
04-29-2011 04:42 PM  10 years ago
Topic Vote0Post 1
bluefronted

rrVeteran

Pretoria, South Africa

MyPosts All Forum Topic
Heli piro problems, Using Futaba Gy520
Hi Guys,

Some history : My Align 700e F3C heli was bought secondhand complete with a Futaba Gy520, good as new. The previous owner also had a Futaba 10CHG radio, so we just copied the settings to my radio.Prior to me taking the heli the previous owner test flew it.
I've picked up a problem where the heli's nose is rotating counter clockwise.When hovering i need to give about 25% rudder to the right
I've checked the neutral position of the rudder and all seems ok. When initialized the gyro positions 100%.

What am i missing or not doing right ??

Thanks
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2011 05:05 PM  10 years ago
DGS

rrNovice

Hamburg, NY

MyPosts All Forum Topic
Make sure that your trim(s)are centered for all flight modes. If you are switching into idle-up and it has some rudder trim it will rotate the heli.

Dave
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2011 05:45 PM  10 years ago
bluefronted

rrVeteran

Pretoria, South Africa

MyPosts All Forum Topic
Hi,

trims are on centre, just removed the canopy an saw that the gyro is on normal mode, light on Gyro is blue. My radios gain is on 80% AVCS / HH. Not sure how to change her to Red status / AVCS mode
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2011 05:56 PM  10 years ago
TMoore

rrMaster

Cookeville, TN

MyPosts All Forum Topic
Reverse the gyro gain channel. If the nose is drifting that means that the machine is not trimmed properly in rate mode, which happens to be the mode you are currently in.

TM
Part 107.
The only ZERO flight hour certificate in the world.
It's like getting a driver's license without the driver's test.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-29-2011 06:12 PM  10 years ago
bluefronted

rrVeteran

Pretoria, South Africa

MyPosts All Forum Topic
I reversed the Gyro channel and no change, took the Gyro sensing on the radio to all the way to Normal then to AVCS , no change in status light.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
04-29-2011 06:14 PM  10 years ago
TMoore

rrMaster

Cookeville, TN

MyPosts All Forum Topic
Look in the servo page and make sure the gyro gain channel is changing when you flip the gain switch.Part 107.
The only ZERO flight hour certificate in the world.
It's like getting a driver's license without the driver's test.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-29-2011 06:41 PM  10 years ago
bluefronted

rrVeteran

Pretoria, South Africa

MyPosts All Forum Topic
Thanks Guys,

You'll led me to finding the problem
I checked the servo page, all was ok. Then I check the Rudder and Gyro gain leads on the RX, sure enough , the Gyro gain lead was reversed.Status now on Red / AVCS.

We are thousand of miles apart ( I in South Africa) and many times zones in between , your help is appreciated.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 917 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Futaba FASST › Heli piro problems, Using Futaba Gy520
Print TOPIC

 2  Topic Subscribe

Sunday, September 26 - 12:56 pm - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online