RunRyder RC
WATCH
 1 page 723 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › setup problems
04-22-2011 03:00 PM  7 years agoPost 1
Eric L

rrApprentice

Minnesota

My Posts: All  Forum  Topic

quick question for yall. I am trying to setup my beast x, every servo moves and corrects the right way but i have no elevator control from my radio. All the servos are in the right terminals.....and suggestions?

Team KingKongHobbies.com-----Team Synergy

PM  EMAIL  Attn:RR  Quote
04-22-2011 04:00 PM  7 years agoPost 2
nitroburner

rrApprentice

pikeville ky. us

My Posts: All  Forum  Topic

Maybe check that you had the servo plug lined up with pins on the BeastX.

OMG how much did i spend................

PM  EMAIL  GALLERY  Attn:RR  Quote
04-22-2011 06:09 PM  7 years agoPost 3
wrongler

rrProfessor

Brewerton, New York

My Posts: All  Forum  Topic

Did you start with a Model setup that was never used in your TX? Is your elevator servo at the right frequency? Plug another servo in the elevator of the RX and see if it works.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-22-2011 06:23 PM  7 years agoPost 4
bigwolf1

rrVeteran

USA

My Posts: All  Forum  Topic

yes make sure your using one servo not 3 servo radio mix.. doesn't work that way the Beast will do that in the setup. If all else fails reset unit and start over usually fixes most issues..

MAH blade Rep
Trex700LE
Magnum fuels

PM  EMAIL  GALLERY  Attn:RR  Quote
04-22-2011 08:49 PM  7 years agoPost 5
Eric L

rrApprentice

Minnesota

My Posts: All  Forum  Topic

the servo works just fine when i use collective or tilt the heli..just not when i inout elevator in my radio, it is setup with a 1 servo swash and everything as the manual says....confusing me

Team KingKongHobbies.com-----Team Synergy

PM  EMAIL  Attn:RR  Quote
04-23-2011 05:09 AM  7 years agoPost 6
Eric L

rrApprentice

Minnesota

My Posts: All  Forum  Topic

i reset it all back to defaults and now it works awesome

Team KingKongHobbies.com-----Team Synergy

PM  EMAIL  Attn:RR  Quote
04-23-2011 12:32 PM  7 years agoPost 7
wrongler

rrProfessor

Brewerton, New York

My Posts: All  Forum  Topic

Do you mean you set all the parameters (blinking lite) to the default settings?

Bill Whittaker

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 723 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › setup problems
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Saturday, July 21 - 3:23 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online