RunRyder RC
WATCH
 1 page 1502 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › Trex 450 pro, Align GP780 gyro problem
01-13-2011 09:37 PM  7 years agoPost 1
heli8159

rrNovice

CA

My Posts: All  Forum  Topic

I just put together a Trex 450 pro super combo that came with the GP780 gyro. Nothing happens when I plug it in. The servo works fine in the receiver, bypassing the gyro. But when the gyro is put in between nothing happens, no lights or anything on the gyro. Am I missing something, or is it DOA?

PM  EMAIL  Attn:RR  Quote
01-14-2011 12:08 AM  7 years agoPost 2
JOLT

rrVeteran

Baltimore, MD

My Posts: All  Forum  Topic

Are you plugging the servo correctly into the gyro?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2011 02:41 AM  7 years agoPost 3
heli8159

rrNovice

CA

My Posts: All  Forum  Topic

yes i did check that. shouldnt the light on the gyro be on?

PM  EMAIL  Attn:RR  Quote
01-14-2011 03:24 AM  7 years agoPost 4
JOLT

rrVeteran

Baltimore, MD

My Posts: All  Forum  Topic

Yes, it should come on. Futaba or Spektrum?-- and have you checked all channels on the Rx are working to rule out a bum receiver?

Did you make sure that you plugged the gyro in to the Rx correctly? Then plug the Servo (all the way in) to the gyro? Connect a charged battery with TH on and you should get a green light on the gyro and the servo should jump to center.

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2011 04:45 AM  7 years agoPost 5
ch-47c

rrElite Veteran

san jose, ca

My Posts: All  Forum  Topic

Are you using an early model Spectrum rx?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2011 05:31 AM  7 years agoPost 6
Michaelm0268

rrApprentice

Louisiana

My Posts: All  Forum  Topic

You have to turn on your radio on the 780 before the light on the gyro comes on i noticed that on mine anyway!

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2011 07:08 AM  7 years agoPost 7
heli8159

rrNovice

CA

My Posts: All  Forum  Topic

Using Futaba 8UHPS hi tech receiver 72 mhz all receiver channels are working. Everything is plugged in right. Been using this radio 4 different helis but with futaba gyros.

PM  EMAIL  Attn:RR  Quote
01-14-2011 07:52 AM  7 years agoPost 8
ch-47c

rrElite Veteran

san jose, ca

My Posts: All  Forum  Topic

So all servos are working when directly plugged into the RX?
The Rudder servo is plugged in CH4 and Gain into Ch5?
The Rudder servo into gyro?

Then when powered on, there is No steady Green or Red lite? Not even flashing?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2011 02:30 PM  7 years agoPost 9
heli8159

rrNovice

CA

My Posts: All  Forum  Topic

Yep, this leads to a dead gyro, in 15 years and about 8 gyros I have never had a totally dead gyro. Bought locally to support local hobby shop and they said I have to talk to Align,

PM  EMAIL  Attn:RR  Quote
01-14-2011 04:58 PM  7 years agoPost 10
jsenicka

rrProfessor

Eagle River, WI

My Posts: All  Forum  Topic

one easy question
Are you sure the gain lead is not plugged in upside down? The single wire yellow gain lead? Needs to match up with the white signal wire on the rudder plug

Jim Senicka
Team Manager, GrandRC Flight Team

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2011 10:21 PM  7 years agoPost 11
JOLT

rrVeteran

Baltimore, MD

My Posts: All  Forum  Topic

Hey man, I know this sounds wierd but if you pm me your phone number, maybe we can talk about it on the phone this weekend. I have had 3 GP780's and no hitches. I can set my heli in front of me while we are on the phone and try to trouble shoot. I use Futaba as well.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1502 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › Trex 450 pro, Align GP780 gyro problem
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Thursday, July 19 - 11:10 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online