RunRyder RC
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 1427 views TOPIC CLOSED
HomeAircraftHelicopter
e-
Mikado
Logo 400 › BLS153's on a 400
01-11-2011 04:11 PM  7 years agoPost 1
rnkasp

rrApprentice

Pottstown, PA USA

My Posts: All  Forum  Topic

Does anyone use BLS153's on a Logo 400? Looking for some feedback.

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 05:46 AM  7 years agoPost 2
Bugcatcher

rrApprentice

Perth, Australia

My Posts: All  Forum  Topic

Not as yet but I think theyre ideal for the Logo 400 and might be putting them in my nightflyer shortly. Loads more torque for 0.01 less speed and brushless. Can't really go wrong. I have 9650's in my Logo at the moment and although suited for the heli. They do feel a little slow and sluggish at times of heavy load.

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 12:57 PM  7 years agoPost 3
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

ohh man, i ran 5245's in my logo 523 stretch and replaced them with bls153's after i had a crash due to the servos not being strong enough. I was flying fast close to the ground, punched the collective and the 5245's didn't respond.

I would go out and buy bls153's tomorrow if i were you!

PM  EMAIL  Attn:RR
01-12-2011 02:55 PM  7 years agoPost 4
rnkasp

rrApprentice

Pottstown, PA USA

My Posts: All  Forum  Topic

WOW. That's sounds exactly like what I just experienced resulting in a crash. I'm also running 5245's and swinging 523's.

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 03:06 PM  7 years agoPost 5
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

yeah, its seeems like teh 5245's can't handle the load of the larger blades.

how are you liking your stretched logo, what other equiptment are you using?

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
01-12-2011 03:23 PM  7 years agoPost 6
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

edited.

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
01-12-2011 03:26 PM  7 years agoPost 7
mmc205

rrElite Veteran

PA - USA

My Posts: All  Forum  Topic

are you sure it was the 5245's? I've pushed rnkasps logo pretty hard (tic tocs, fast directin changes, etc) and it never missed a beat.

***Logo 600 vbar***Henseleit TDR vbar***

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 03:27 PM  7 years agoPost 8
mmc205

rrElite Veteran

PA - USA

My Posts: All  Forum  Topic

maybe your thinking of the walkera...

***Logo 600 vbar***Henseleit TDR vbar***

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 03:36 PM  7 years agoPost 9
rnkasp

rrApprentice

Pottstown, PA USA

My Posts: All  Forum  Topic

Here is my setup - Logo 400se (690 tail boom) Edge 523's, Hs5245MG on cyclic and BLS251 on tail, MiniVbar, Scorpion 4020-1100, CC Ice 100 on 6s 3300mah. I also modified and installed a tail from a Logo 600. I actually just finished my rebuild with 3 brand new 5245s. I had considered the BLS153's but had a hard time with the cost. I may run the 5245's at 6 volts which bumps the torque up to that of the 153's and see what happens.

I love the stretch. The little heli is a beast. Here is a thread I started a while back that may interest you.

https://rc.runryder.com/t612642p1/

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 04:48 PM  7 years agoPost 10
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

man, i heard the ice esc's suck. That thing is going to catch on fire and burn your heli up for sure! you had to rebuild and bought new 5245's? i feel bad for you, money wasted.

mmc205, don't be such an idiot, its comments like that that get everyone ticked off. My walkera flies as good as my logo so shove it!

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
01-12-2011 05:01 PM  7 years agoPost 11
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

i read your stretch thread, pretty cool.

I'm running a jive 80, 3026-1900 with a 20 T pinion, edge 523's and a 6S 2200mah 20C lipo and a gy 401 giro, the main gear that came with it. (i think its mod 0.5, i bought it as a used airframe and put electronics in it. i'm not sure what headspeed i'm running, but it sounds real, real fast. i don't have it governed, i just have a throttle curve at 100%

i think theirs something wrong, because it really has a lot of power for like 2 minutes, but then the power cuts out and when i land it the motor is literally smoking and the batteries are like twice their normal size.

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
01-12-2011 05:03 PM  7 years agoPost 12
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

its weird too, because everyone says flybarless is so much more stable, but mine is all over the place.

Whats that "vbar" thing on yours?

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
01-12-2011 05:09 PM  7 years agoPost 13
Heli 770

rrProfessor

USA.

My Posts: All  Forum  Topic

logoextreme22
I don't think your 20C batt pack can handle the load.

PM  EMAIL  Attn:RR
01-12-2011 05:14 PM  7 years agoPost 14
rnkasp

rrApprentice

Pottstown, PA USA

My Posts: All  Forum  Topic

I have had great experience with CC Ice series ESC's. I have many hundreds of flights combined and never an issue. I have had great results in the past with the 5245's too so I really don't see it as money wasted. I will probably up the voltage on the cyclic servos and see what that gets me. I believe my crash was associated with a static hit and not servo failure anyway. My reason for questioning the BLS153's was only because my Logo 600 is equipped with BLS451's and I really love the slop free smoothness that they offer and was hoping the 153's had the same feel.

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 05:16 PM  7 years agoPost 15
rnkasp

rrApprentice

Pottstown, PA USA

My Posts: All  Forum  Topic

Are you running a flybarless head with only a GY401?

PM  EMAIL  GALLERY  Attn:RR
01-12-2011 05:31 PM  7 years agoPost 16
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

no, the gy 401 is on the tail not on the head.

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
01-12-2011 05:43 PM  7 years agoPost 17
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

should i get a bigger battery?

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
01-12-2011 05:56 PM  7 years agoPost 18
Heli 770

rrProfessor

USA.

My Posts: All  Forum  Topic

It's not the size of the batteries. You need a higher discharge rate, like 35C or better.

Edit: You should consider that Batt Pack Toast! Since you have Puffed them.

PM  EMAIL  Attn:RR
01-12-2011 06:16 PM  7 years agoPost 19
rnkasp

rrApprentice

Pottstown, PA USA

My Posts: All  Forum  Topic

I think you have much bigger problems than just the battery.

Looks like your headspeed is over 4000 rpm. You were worried about my ICE ESC catching fire, I'm surprised your Logo doesn't just explode. You have some serious setup/component issues.

PM  EMAIL  GALLERY  Attn:RR
01-13-2011 04:27 PM  7 years agoPost 20
logoextreme22

rrNovice

Sacramento, CA

My Posts: All  Forum  Topic

can you poke holes in the pack with a nail or something and let the extra air out?

rnkasp, how do you know what my headspeed is, i never even measured it, unless your psychic or something.

Why would my logo explode, i used to have airplanes and the propellors would spin like 10,000 rpm, i thought the higher the better.

picco z --- walkera 22 ---logo 400 w/ 523's

PM  EMAIL  Attn:RR
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 1427 views TOPIC CLOSED
HomeAircraftHelicopter
e-
Mikado
Logo 400 › BLS153's on a 400
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Friday, July 20 - 11:33 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online