RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 683 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › Microbeast 2.0 Firmware
12-29-2010 12:42 AM  7 years agoPost 1
az_heliguy

rrKey Veteran

San Tan Valley, AZ

My Posts: All  Forum  Topic

so, i updated the firmware to the newest realease and completel piled that heli in today. everything seemed to work great except when inverted, it shot the tail out completely and would no regain. needless to say. that heli is no longer around.

anyone else seen this?

Mastercard Team Pilot :)

PM  EMAIL  GALLERY  Attn:RR  Quote
12-29-2010 12:44 AM  7 years agoPost 2
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

I heard that when you updated the new software you had to redo the setup, did you???

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-29-2010 12:50 AM  7 years agoPost 3
az_heliguy

rrKey Veteran

San Tan Valley, AZ

My Posts: All  Forum  Topic

yea, setup was redone. when flashing the new fw, it goes back to factory settings, so setup has to be redone. whats weird is it only happened while inverted...

Mastercard Team Pilot :)

PM  EMAIL  GALLERY  Attn:RR  Quote
12-29-2010 10:51 AM  7 years agoPost 4
rox33

rrApprentice

Norway

My Posts: All  Forum  Topic

Why do you think that it had anything with the update to do?
It could just as easily be a connector coming loose, servo failure, broken link or something else...

PM  EMAIL  Attn:RR  Quote
12-29-2010 11:10 AM  7 years agoPost 5
az_heliguy

rrKey Veteran

San Tan Valley, AZ

My Posts: All  Forum  Topic

no loose connectors, no broken links etc. flashed to 2.0 fw, did the setup again and flew. everything worked fine up until it went inverted, then all hell broke loose, lol...

no worries, its par for the course. just was curious if anyone else had an issue similar or not.

Mastercard Team Pilot :)

PM  EMAIL  GALLERY  Attn:RR  Quote
12-29-2010 11:48 AM  7 years agoPost 6
maj

rrVeteran

united Kingdom

My Posts: All  Forum  Topic

I haven't seen it. I can't see it been a firmware issue when inverted. The Beastx wouldn't know its orientation to the ground. I suspect a hardware fault or something letting loose on the machine.

I assume you were in idle up? Reducing throttle may cause tail to let go and head towards the ground.

MJ

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 683 views POST REPLY
HomeAircraftHelicopterFlybarless Rotor Head SystemsBeastX › Microbeast 2.0 Firmware
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, June 25 - 8:37 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online